This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Riffaz 6 months ago.

Assigned support staff: Riffaz.

Author Posts
April 4, 2019 at 1:26 pm #3535287

alexT-20

I am trying to: access my translated site at : hidden link

Link to a page where the issue can be seen: any page contained in hidden link

I expected to see: the products, the categories etc.

Instead, I got: Internal Server Error

Page are shown sometimes after repeatedly REFRESHES.

April 4, 2019 at 1:49 pm #3535505

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

It is 'internal SERVER error'
So you can find the cause by checking the server log.
Please contact the hosting company and ask them to check the server log.
They can find the issue.

Before that you can try:

Plugin conflict
Could you please disable all the plugins and check this?

Minimal Setup
If you disable all non-related WPML plugins, switch to one of the default themes like twenty seventeen, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Console Errors
In your chrome browser Press Ctrl + Shift + J (Windows / Linux) or Cmd + Opt + J (Mac) before you go to this step.
Check if you see any red errors here : hidden link and let me know.

Debugging
1. Please follow the debugging information provided here: https://wpml.org/documentation/support/debugging-wpml/#enabling-the-built-in-debugging-feature-in-wordpress.
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see

Let me know.

Regards,
Riffaz.

April 5, 2019 at 4:21 pm #3545863

alexT-20

The problem started by the time I changed the permalinks for the translated site (Greek). I changed the Product Category slug and the Product slug.

April 7, 2019 at 8:48 am #3551075

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I changed the Product Category slug and the Product slug.
- are your other pages working fine?
- you have issues with products and products category pages?

The problem started by the time I changed the permalinks for the translated site (Greek).
- if you revert back the change as how it was before, does this work?

Let me know.

Regards,

April 8, 2019 at 8:33 am #3555589

alexT-20

Hello,

- also the other pages of my translated site are not working (contact, faqs etc..)
- I have issues with products and product categories

Be fore I revert to my previous translated permalinks,
I attach a screenshot of an alert found in your plugin.

Thank you in advance.

April 9, 2019 at 2:24 pm #3568013

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I am setting the next reply as private.
Please let me know your site login details to check this closely.

Also, let me step by step procedure to reproduce this issue and let me know how to check.
URLs and screenshots will help a lot in this to understand better.

Regards,

April 15, 2019 at 12:12 pm #3613263

alexT-20

Problem seems solved.
I will come back if something happens.

Thank you.

April 15, 2019 at 2:26 pm #3613981

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

That's great!

Please close this ticket and open new one if you have any other issue.

Regards,
Riffaz.