Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
The client was experiencing an Internal Server Error when navigating the menu/page in a language that was not set as the default. The URL structure was incorrect, with the language code (/en/) incorrectly placed in the middle of the URL instead of at the end.

Solution:
We reviewed the debug log and found no fatal errors related to the Internal Server Error. However, we noticed a PHP Notice error related to the 'The Events Calendar: Community Events' plugin. We deactivated this plugin and confirmed that the member pages then loaded correctly without the Internal Server Error. We provided a screen recording of the correct functionality for the client to review. We recommend the client to check their site after deactivating the plugin to see if the issue is resolved.

If this solution does not seem relevant to your situation, please open a new support ticket with us.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by Long Nguyen 2 months, 2 weeks ago.

Assisted by: Long Nguyen.

Author Posts
December 1, 2023 at 5:31 am #14968735

paulL-72

I am trying to: Navigate the menu/page in the language that is not set as the default language.

Link to a page where the issue can be seen: hidden link

I expected to see: It does not happen to at the same sequence every time but after checking on the different pages, I always get directed to the Internal Server Error page.

Instead, I got: Internal Server Error. I think I know what the issue is but I don't know how you can fix the bug. If you look at the page URL attached, the /en/ is supposed to come at the very end, but instead, it got sandwiched between the site name and the page it is trying to access.

We see: ds-labo.jp/en/members/4cfb0299/friends/
But we should see: ds-labo.jp/members/4cfb0299/friends/en/

2023-12-01_internal_error.png
December 1, 2023 at 10:00 am #14970995

Long Nguyen
Supporter

Languages: English (English )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Hi Paul,

Thank you for contacting WPML support, I'd be happy to help you with this issue.

By default, the language code should be added to the URL right after the site name and this is the correct URL hidden link

I'm trying to visit your site to check the issue but it requires to login to view the page. Can you please share the temporary access (wp-admin and FTP) to your site to take a better look at the issue? It would be better to have a testing site where the issue is replicated. Your next reply is set to private to share the info.

❌ IMPORTANT: Please backup your database and website before proceeding ❌
You can use this plugin to create the backup: https://wordpress.org/plugins/duplicator/
✙ I would need your permission to de-activate and re-activate Plugins and the Theme to change configurations on the site if needed. This is also a reason the backup is critical.

The minimum requirements are 128M, but we do recommend 256M and the debug information of your site shows it set to 40M. Please check this link for more details
https://wpml.org/home/minimum-requirements/.
You can increase it by adding the following code in your wp-config.php file, right before the /* That’s all, stop editing! Happy publishing. */ line:

define( 'WP_MAX_MEMORY_LIMIT', '256M' );
define( 'WP_MEMORY_LIMIT', '128M' );

After adding the code you can confirm that the memory was changed correctly from WPML > Support > WordPress > Memory limit.

Look forward to your reply.
Thanks

December 1, 2023 at 1:04 pm #14972957

paulL-72

Hi Sorry I forgot to add - yes you have my permission to de-activate and re-activate Plugins and the them to change configuration. I have also added the maximum memory and memory limits like how you specified.

December 3, 2023 at 3:23 pm #14980403

Long Nguyen
Supporter

Languages: English (English )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Hi,

The password of WordPress admin account isn't correct. Can you please recheck this?

Thanks.

December 4, 2023 at 4:04 am #14981785

Long Nguyen
Supporter

Languages: English (English )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Hi,

I don't see any fatal error in the debug log when the error message Internal Server Error appears. Just a notice error message:

[04-Dec-2023 03:48:57 UTC] PHP Notice:  Trying to get property 'edit_posts' of non-object in /Applications/MAMP/htdocs/labo/wp-content/plugins/the-events-calendar-community-events/src/Tribe/Integrations/Virtual_Events.php on line 93

that indicates there is an issue with the plugin "The Events Calendar: Community Events". I deactivate this plugin on your site and visit the member pages in the frontend and it works properly. Here is a screen record hidden link
Can you please recheck this on your end?

Look forward to your reply.
Thanks

December 7, 2023 at 7:20 pm #15020733
paulL-72

Thank you Long. I have increased both the memory limit for my wp-config.php file and on the server side (both to 512M) and the Internal Server Error seems to have disappeared for now. However your point about Events Calendar is something that I can now (without the server error issue) clear see:
1. Japanese is my default language and the default page (www.ds-labo.jp) works just fine as you can see from my attached image:
2. English event page (www.ds-labo.jp/en/event) however shows a blank page which does not match the Japanese page. I clearly remember when setting up Events Calendar that this plug-in displays events not through a "page" but through a "slug" which it says there is no such page for Events that exists. This could be the reason why the English page comes up blank when we insert the "/en/" into the URL as it probably does not know where to go fetch the content. I am sure this is not the first plugin that display a "page" like this. Could you talk to others to see if there is a workaround?

Thank you so much for your help!!
Regards,
Paul

New threads created by Long Nguyen and linked to this one are listed below:

https://wpml.org/forums/topic/events-page-doesnt-display-any-items/

events_english_2023-12-08_04-18-35.png
events_japanese_2023-12-08_04-12-30.png
December 8, 2023 at 3:00 am #15022467

Long Nguyen
Supporter

Languages: English (English )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Hi,

We can handle one issue per ticket only so I will split your new issue with the Events page into a new ticket. If you see the issue with the internal server error is resolved, please mark it as resolved.

Thanks.

December 9, 2023 at 11:36 am #15029067

paulL-72

Thank you so much for your help!!!

paulL-72 confirmed that the issue was resolved on 2023-12-09 11:36:13.
This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.