This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by Bigul 1 year, 5 months ago.

Assigned support staff: Bigul.

Author Posts
May 4, 2018 at 12:18 pm #1974798

stevenH-12

When switching to another language I'm getting an Internal Server Error.
It's rather unpredictable when these occur.

May 4, 2018 at 4:19 pm #1979018

stevenH-12

The problem is with "all" my sites that have restricted to content. When going to account pages and switching languages and then switching back to another page that is accessible I get Internal Server Error.
I activated debug mode, but no errors turn up.
I had a developer check it, but he can't find anything, except that it's related to WPML and not to any other content restriction plugin.

May 7, 2018 at 5:51 am #2002889

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please let me know the following for tracking the issue.

1) Are you getting this error in all the pages/posts? Because I am not able to reproduce the issue on your site. It works as expected when I switch between the languages(French & Dutch).

2) Hope you are used the following code to enable the debug mode.

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

3) Please check you are getting any error in your server error log while having this issue

--
Thanks!

Bigul

The topic ‘[Closed] internal server error when switching language’ is closed to new replies.