This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by tiborA 3 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
June 25, 2019 at 12:35 pm #4084591

tiborA

I have installed WPML as a plugin to my website. Went through all setup. Then inserted the site key, and everything broke.

I'm getting this error:

Warning: Invalid argument supplied for foreach() in /wp/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-wp-installer.php on line 677

June 25, 2019 at 12:51 pm #4084715

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. . It seems like an issue with the WPML registration.

Can you please try the following steps:

- Go to Plugins -> Add New -> Commercial page
- Try to remove the WPML registration
- And again Register WPML with the new key.

Please let me know if this solves the issue or if you need further assistance with this issue.

Thank you

June 25, 2019 at 12:59 pm #4084743

tiborA

I have tried that. I get the same error. Regarding the debug information, I cannot access that section since the admin side menu doesn't show up and I cannot access wpml.

I've tried several things like disabling, removing plugin folder, updating. To no avail. I got the latest version and replaced it, still not working.

It's a local instalation on my own machine so I can't provide access either.

June 25, 2019 at 1:00 pm #4084751

tiborA

Is there any way I can remove everything related to wpml from the database and make a clean install?

June 25, 2019 at 1:07 pm #4084767

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

=== Please backup your database and website ===

You can reset WPML plugin by following below steps:

- Please go to WPML >> Support >> Troubleshooting (the link is at the bottom of the support page). >> There, click on “Reset and deactivate WPML” >> then Delete the plugin.

After deleting all data and WPML related plugins then please install WPML plugins again.

Here is doc for more details:
https://wpml.org/faq/how-wpml-reset-works/

OR

- Please go to *_options database table and delete the ‘icl_sitepress_settings’ entry. This caused WPML to start over with set up.

Thank you

June 25, 2019 at 1:15 pm #4084819

tiborA

Hello,

Like I stated before the first option does not apply since I cannot access the WPML menu.

I did try the second options (removing that from the DB) and went through the setup again. All the data I've set before was already there, which leads me to the conclusion that the reset didn't actually happen.

Anyway, I finished the setup and the large shiny error message is still there. What else could I do?

June 25, 2019 at 1:17 pm #4084835

tiborA

Could you maybe provide me with the direct url to the settings reset?
Something like: /wp-admin/admin.php?page=sitepress-multilingual-cms

June 25, 2019 at 1:45 pm #4085013

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Here is troubleshoot page URL:
wp-admin/admin.php?page=sitepress-multilingual-cms%2Fmenu%2Ftroubleshooting.php

If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

June 25, 2019 at 2:20 pm #4085431

tiborA

Hello Norman,

WP access and FTP are not possible at this moment. The staging is not similar to what we have on our local environment.

Is there a direct link to see the "debug information" page directly? Same as the link you've provided in your reply? (which didn't fix our problem).

June 25, 2019 at 3:31 pm #4085969

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Here is debug information page link:
/wp-admin/admin.php?page=sitepress-multilingual-cms%2Fmenu%2Fdebug-information.php

Thank you

June 26, 2019 at 3:20 pm #4093573

tiborA

Hello again,

I've added the debug information from the link you've provided. Do you think this might help?

Also, I noticed that the error appears only in the local env. Also, On a website that runs WP 5.1 I do not get this error even though it's the same version of WPML. Might it be WP related?

I'd very much appreciate your help. Thank you!

June 27, 2019 at 7:08 am #4097143

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Your WP version is good and WPML works perfectly fine with updated version of WordPress. Could you please follow below steps and let me know results.

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

=== Please backup your database and website ===

2. Please upgrade your server’s MySQL version to a higher level: https://wpml.org/home/minimum-requirements/
MySQL 5.5.5 version in your site, is lower than the required for WPML.

3. Please make sure your current site URL and registered site URL are same e.g. with www or without www.

If still issue persists, please follow the steps below and let me know how it goes?
- Please backup your database and website
- Deactivate the existing WPML plugin and add-ons.
- Delete the plugin files – this does not delete your translations. You will just delete the plugin files from your "wp-content/plugins" folder, all your data will be kept saved.
- Install and activate WPML again. You can download it from your account: https://wpml.org/account/downloads/
- Again register WPML in your site and enter the new key:
Please Login to your WPML account >> go to Sites page >> Remove your current site / domain from there >> and re-add your site >> it will give you New key which you can add back in your site: https://wpml.org/account/sites/

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

July 9, 2019 at 2:56 pm #4172151

tiborA

My issue is resolved now. Thank you!