This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Joe 1 month, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
September 9, 2019 at 5:56 pm #4539525

Joe

I am trying to: register a site key for a staged version of a production website for testing purposes. The staging website is hidden link

Link to a page where the issue can be seen: (please see attached screen shots)

I expected to see: A successful site key registration.

Instead, I got: An error: "Invalid site key for the current site."

I am copying and pasting the site key from my WPML account management. I have also confirmed that the charset specified in the wp-config.php and the blog_charset field in the wp_options table are the same. (utf-8)

I have tried deleting and creating a new site key several times, but with the same result. The instructions in the other support issues addressing this have not solved my problem. This used to work.

September 10, 2019 at 1:47 am #4540759

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Please, try the following:

1 - Add this to your wp-config.php so we will get more information about the issue:

define( 'WPML_DEBUG_INSTALLER' , true );

before the line

/ That's all, stop editing! Happy blogging. /

After you enter this code, when you try to register, you will get message looking like this
hidden link

2 - Please contact your hosting company and ask if their firewall is blocking access to WPML.org API ( api.wpml.org ) and our JSON : hidden link?

Please, let me know the results, have a nice day.

September 10, 2019 at 2:55 pm #4546615

Joe

Hi Marcos,

Here is the output from the WPML_DEBUG_INSTALLER:

POST <em><u>hidden link</u></em>
Array
(
    [body] => Array
        (
            [action] => site_key_validation
            [site_key] => SsqyxaZ3HD
            [site_url] => <em><u>hidden link</u></em>
            [source] => 3
            [using_icl] => 
            [wpml_version] => 4.2.5
            [installer_version] => 1.9.4
            [theme] => Divi 2.0 Child
            [site_name] => RESP Dealers Association of Canada
            [repository_id] => wpml
            [versions] => Array
                (
                    [sitepress-multilingual-cms] => 4.2.5
                    [wpml-string-translation] => 2.10.3
                    [wpml-translation-management] => 2.8.4
                    [wpml-media-translation] => 2.5.1
                    [wpml-sticky-links] => 1.5.0
                    [wpml-cms-nav] => 1.5.0
                )

        )

    [timeout] => 45
)

stdClass Object
(
    [info] => Array
        (
            [site_key_validation] => Site key validation
        )

    [error] => Site key not matching
)

I will post a follow-up when I hear back from my hosting provider about the firewall blocking access.

Thanks,

Joe

September 10, 2019 at 4:46 pm #4547515

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Joe,

Thank you for the updates. Are you sure you are entering the full url of your website, including any extra paths? For example you mentioed you are registering this url: hidden link;, while your website is located in this domain: hidden link;. Please, let me know, have a nice day.

September 10, 2019 at 5:46 pm #4547857

Joe

Hi Marcos,

My website host provider said that xmlrpc is blocked by default, so they've overridden that restriction; however that didn't help.

As per your instructions, I've registered the key to hidden link and now it seems to register the key, but when I try to update the plugins, I get error messages like the following:

"WPML Multilingual CMS cannot update because your site's registration is not valid. Please register WPML again for this site first."

Thanks,

Joe

September 10, 2019 at 7:18 pm #4548465

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Joe,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

September 11, 2019 at 6:12 pm #4555883

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Joe,

Thank you for the provided details. I took a detailed look in your website and noticed your 'Site Address (URL)' from your WordPress Dashboard > Settings > General settings is set as 'hidden link' instead of 'hidden link'. Please, make sure everything is consistent and you have both 'Site Address (URL)' and 'WordPress Address (URL)' urls set with the url you have registered in your wpml.org account.

See: https://wpml.org/forums/topic/your-subscription-appears-to-no-longer-be-valid-please-try-to-register-again-us/

Please, let me know if it helps, have a nice day.

September 12, 2019 at 1:53 pm #4561459

Joe

Hi Marcos,

I've never had to make both the site address (what comes up in a browser) and wordpress address (where the core WP files are stored) the same before. As well, hidden link was the first address I tried before you told me to use hidden link instead. Are you saying that the site key worked for you when you registered it?

Joe

September 13, 2019 at 12:24 am #4564495

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Joe,

Thank you for the updates. I recommend you to test it using the registered url for both your 'Site Address (URL)' and 'WordPress Address (URL)' since it was the solution provide for a customer facing the same issue at: https://wpml.org/forums/topic/your-subscription-appears-to-no-longer-be-valid-please-try-to-register-again-us/. Please, proceed according the instructions in the provided url and let me know if it works for you. Thank you for your collaboration, have a nice day.

September 13, 2019 at 4:47 pm #4570175

Joe

Hi Marcos,

Temporarily changing the WordPress Address (URL) and Site Address (URL) to the same value in order to register the site key was the work-around that worked for me. Hopefully this will be fixed in a new release. Thanks for your help.

Joe

September 13, 2019 at 4:47 pm #4570177

Joe

My issue is resolved now, as per my last reply.