This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 30 replies, has 2 voices.

Last updated by Marcel 5 months, 4 weeks ago.

Assigned support staff: Marcel.

Author Posts
February 19, 2019 at 6:22 am #3215189

michalS-45

I am trying to: I had issues with WPML plugin update, so I did what it was suggested on forum:
1) unregistered the site
2) tried to registered it again and it failed

Link to a page where the issue can be seen: hidden link

I expected to see: Successful registration

Instead, I got: Invalid site key for the current site.

February 19, 2019 at 10:45 am #3216138

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Michal,

Welcome to the WPML support forum. I am sorry to hear that you have problems updating our product.

Can you please create a new WPML site key?:
- Please go to https://wpml.org/account/sites/ look for your current key and erase it.
- Create a new site key with “Add new site”
- Open your site and go to Plugins -> Commercial and click the "Register" button on WPML plugin to enter the new key

When updating your site key WPML settings and translation will remain intact, but a backup is always a good idea.

Please let me know if this solved the issue.

King Regards
Marcel

February 19, 2019 at 10:54 am #3216210

michalS-45

I have tried it already many times, different URLs, it does not work. What's next?

February 19, 2019 at 1:21 pm #3216741

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Michal,

Do I understand it correct, that you can't generate the site key on WPML account page? If yes did you entered a trailing slash on the URL when creating the site key?

Please check the following steps.

1. Go to https://wpml.org/account/sites/
2. Register your site here, please note that site url should not contain trailing slash ( hidden link - Wrong ) ( hidden link - Correct )
3. After registering your site you will get the new key.
4. Go to Plugins > Add New > Commercial, enter your site key and click OK button.

For more information on installation of WPML, please refer: https://wpml.org/faq/install-wpml/

Please let me know if it worked for you.

Kind Regards
Marcel

February 19, 2019 at 1:43 pm #3216901

michalS-45

As I mentioned in my previous message, I tried different URLs:

hidden link
hidden link
hidden link
hidden link
motionsystems.eu

There is always the same result "Invalid site key for the current site".

It worked fine in the past so what has changed?

February 19, 2019 at 3:28 pm #3217579

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Michal,

Sorry for the misunderstanding. I thought you are stuck on our WPML account page and even not be possible to move on to your site:

Please follow the following manual step-by-step, if no this will not works:

- Go again to WPML account page and create the site key only for " hidden link " Copy the key as you need it in the next step.
- Please navigate in your WordPress Backend to “Dashboard” -> Updates -> and clicking on the "Check Again" Button. This flushes out the updates history.

Next, reinstall the WPML Core plugin using this way:

- Go to your plugins and Deactivate & Delete “WPML Multilingual CMS”
- Download our new version (4.2.1) from https://wpml.org/account/downloads/
- Install the zip File manual and & enter the site key

Now it's essential that you go again to “Dashboard” -> Updates and press the “Check Again” button to Flush the Update History.

Please let me know if this solution worked for you.

Kind Regards
Marcel

February 21, 2019 at 6:18 am #3225064

michalS-45

I didn't work, it still complains about invalid site key.

BTW. I have already tried this solution before I created this support ticket. I tried ALL solutions that I found on public forums. In other words I think that I have tried all "reinstall and hope for the best" solutions already.

Can we try something different than? Perhaps you should look into root cause: why does it complain about invalid site key? Is there any log somewhere that could provide more details?

February 21, 2019 at 3:03 pm #3228289

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Michal,

I would please need to request temporary access (WP-Admin and FTP) to your site then I will update our products for you.

Please don't forget to add your WPML account login data that I'm able to generate a new site access key for you. You can enter this information in the text area of the private reply.

For this, your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would need please additionally your permission to de-activate and re-activate Plugins and the Theme and to change configurations on the site. This is also a reason the backup is really important.

I am looking forward to your reply to solve your problem fast.

Kind Regards
Marcel

February 26, 2019 at 10:31 am #3244152

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Michal,

thank you for the site access.

I was able to reproduce your error. My fix was to register the site key using an /wp endpoint on the URL (hidden link), as your WordPress installation has this in the WordPress Address (URL) field in your Settings configured. When I try to run the update, it gets automatically unregistered.

It looks like we have here a general problem with your URL structure and access paths. I will try to reproduce this now on a Sandbox site and come back to you asap to find a solution.

Thank you for your patience

Kind Regards
Marcel

February 26, 2019 at 12:35 pm #3244710

michalS-45

Do you still need access to our website or can we disable your account?

February 26, 2019 at 12:48 pm #3244773

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Michal,

Please leave the access for the moment open as I want to add our 2nd LVL support to your case and they may need access.

Thank you.

February 28, 2019 at 11:22 am #3254840

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Michal,

I wanted to update you about your ticket:

The error comes from the sub-directory "/wp" of your installation. Our Systems team is looking at your case, and I will update you soon as I know the next steps.

Thank you for your patience.

Kind Regards
Marcel

February 28, 2019 at 11:30 am #3254877

michalS-45

Thank you for the update. I'm just reminding you that WPML plug-in worked fine for moths in past (in 2018) and we have this '/wp' sub-directory from the beginning. There have been no changes made in web site directory structure since we have installed WPML first time (May 2018 if I recall correctly).

February 28, 2019 at 11:45 am #3254948

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Michal, that's right. Probably this got changed/conflicted in one of the latest updates. We also had another client having the same issue. I will let you know.

Kind Regards
Marcel

March 7, 2019 at 7:23 am #3282557

michalS-45

Any updates?