This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 12 replies, has 2 voices.

Last updated by dkoop-sprlb 2 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
July 25, 2019 at 3:36 pm #4284811

dkoop-sprlb

Hi,

i find similar issue but i don't find how to solve it. (https://wpml.org/forums/topic/invalid-subdomain/)

I follow these step to set up a subdomain for the translation and no way. https://wpml.org/2016/04/use-wpml-different-domains-per-language/

I'm joining the 2 screenshots.

Regards

July 25, 2019 at 5:57 pm #4285425

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Have you updated the DNS setting for the subdomain? Please try the following steps and check you are getting the expected result or not.

1) Please WPML>>Languages>>Language URL format
2) Untick the *Validate on save* check box option of *A different domain per language*
3) Save the settings.
4) Go to Settings>>Permalinks
5) Resave settings

--
Thanks!

Bigul

July 25, 2019 at 6:09 pm #4285451

dkoop-sprlb

Hi,

thanks for your help 🙂

usually i uncheck *Validate on save* and it works.

You'll find attached a screenshot of dns.

All my other sites don't have problems and this one, i can't resolved the issue :/

July 25, 2019 at 7:05 pm #4285687

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

July 26, 2019 at 9:20 am #4288609

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login details. Can you please try the solution recommend in the following thread.

https://wpml.org/forums/topic/invalid-subdomain/

To be able to work with WPML, all the secondary language domains should point to the same WordPress install either because they are parked domains or because they are add-ons domains pointing to the same directory of the default language domain (WordPress install).

It helps to solve the issue in similar cases. Please check and let me know your feedback.

--
Thanks!

Bigul

July 26, 2019 at 9:57 am #4288811

dkoop-sprlb

it is the link i put in my first post 🙁

Of course it is useless that you give it to me because i already try what is in the thread.

July 26, 2019 at 12:40 pm #4289643

dkoop-sprlb

Somebody to give some help please ?

July 26, 2019 at 2:05 pm #4290061

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I shared the details with our second tier team and waiting for their feedback now. We will get back to you soon. Please wait.

--
Thanks!

Bigul

July 26, 2019 at 2:06 pm #4290065

dkoop-sprlb

Thanks

July 26, 2019 at 3:38 pm #4290613

dkoop-sprlb

Well done, i forgot that i've set up cloudflare, sorry.

I create a A records but it seems doesn't point to the subdomain. An idea ?

July 26, 2019 at 6:16 pm #4291293

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have shared it with our second tier team and waiting for their feedback now. We will get back to you soon. Please wait.

--
Thanks!

Bigul

July 29, 2019 at 7:20 am #4297307

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, probably you needs to click on the *Cloud* icon to disable Cloudflare cache and use only Cloudflare DNS. Please try it and let me know your feedback

--
Thanks!

Bigul

July 31, 2019 at 4:27 pm #4316753

dkoop-sprlb

My issue is resolved now. Thank you!