Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: It takes several times to successfully translate a product. Errors seem to happen randomly. Solution: max_input_vars variable needed to be increased to 10000. Besides, there were some struck translations in WPML > Translations that needed to be completed or resigned. Relevant Documentation: https://wpml.org/documentation/getting-started-guide/translating-theme-options/#resolving-issues-with-maxinputvars-value

This topic contains 11 replies, has 2 voices.

Last updated by michaelV-51 7 months, 2 weeks ago.

Assigned support staff: Oscar Miras.

Author Posts
April 1, 2019 at 6:09 pm #3510759

michaelV-51

I am trying to: Do really simple things and it's not doing what I ask it to do, it should in theory work with the InVogue theme seamlessly.

Link to a page where the issue can be seen: under construction

I expected to see:

1. As mentioned, it's supposed to be compatible with InVogue so I don't know why in-theme options aren't making it through to the advanced translator? My theme header (banner, title) is not recognised and comes through the translation missing, I could swear it's picking up things that aren't even there any more, like old image versions. Also my shop page when translated doesn't show any products in any other other languages apart from English, 'no products available'.

2. (Side issue) The pen iconography to indicate that translation is complete (woo commerce multilingual page) is providing random indication, I'm actually translating each page 3 or 4 times to just try and get an overall graphical resolution, out of 6 languages translated a seemingly random combination will indicate completion. Annoying AF. If it's completed then it's done, where is the delay coming from? It's like I'm waiting on the teacher checking each of my pages!? Argh, hurry up.

Instead,

1. I got: A translated page but with vital elements from InVogue VC not making it into the advanced translator. I have an FAQ page with various texts within a clickable drop down system (part of the InVogue theme) and it's not recognising the internal text for translation.

2. Just pens and update icons all over the place, a page with a mind of it's own.

OK Thank you so Much!!! :D:D:D - Nearly there.

April 2, 2019 at 9:15 am #3515097

Oscar Miras

Hi,

Welcome to the WPML support team.

According to your debug information, I have noticed that there are some low parameters. That could be the reason for some of the random save issues.

Could you increase the WP_MEMORY_LIMIT in your wp-config.php file?

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '128M' );

The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

There is another parameter that might be needed to be changed. This is max_input_vars. It might be needed to be changed as WordPress may need a higher value to correctly save your posts.

Currently, it is set to 1000. Try to change it to a higher value such as 10000. To change it, you could one of the following:

  • Add or change the line max_input_vars = 10000 in php.ini
  • Add or change the line php_value max_input_vars 10000 in .htaccess

If you wish to know exactly which value should you set here, this information may be useful: https://wpml.org/documentation/getting-started-guide/translating-theme-options/#resolving-issues-with-maxinputvars-value

To check if you have successfully changed these values, you can go to WPML > Support and check the Info section.

After applying these changes, please try to translate again some content. Please, notice that we have some detailed information about how to translate content with WP Bakery Builder: https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/

Lastly, about the empty Shop page, check if "Show only products with custom prices in secondary currencies" option is enabled in WooCommerce -> WooCommerce Multilingual -> Multicurrency.

Do not hesitate to contact me in case you need further assistance, I’ll be happy to help.

Best wishes,
Oscar.

April 5, 2019 at 6:41 pm #3546391

michaelV-51

Greetings Sir Oscar,
Thanks for the info, most of it went some way to making the website run wordpress a bit faster.

I managed to get the input_vars increased today via hosting support, but it's a bit of an unmerry merry-go-round burning in hell at the mo, I've made two posts today and I've updated them for translation somewhere between 10 and 15 times, pretty much about as much time updating as writing!

I just don't get it, I say 'complete translation', it says 'what?' , is it lost in translation? Is this is a film reference I'm supposed to be picking up on? Some kind of twisted binary humour...

Any other ideas? Could I give you site access so you can just zoom about and make everything work better?

April 8, 2019 at 8:41 am #3555655

Oscar Miras

Welcome back,

Thank you for your (funny) response. I'm sorry you are dealing with this inconvenience.

I would like to know in advance what are you trying to achieve. Are you trying to translate a concrete page? Maybe you want to translate the front page of your shop? Is the procedure to translate a post clear to you but your concern is about the huge time needed to update a translation?

Please notice that we have some detailed information about how to translate Woocommerce pages and products with Woocommerce Multilingual: https://wpml.org/documentation/related-projects/woocommerce-multilingual/

I'm requesting access to your Website, so I can have a look. Please, make sure you have a full backup of your website before granting me access.

Kind regards,
Oscar.

April 9, 2019 at 11:20 am #3565971

Oscar Miras

Welcome back,

Thank you very much for your response. It is very clear now the work to do. So we are going to face the first issue.

After accessing your site and checking the environment variables information I found out that the Max Input vars have not been successfully updated. The value is still set to 1000. We really need to increase this number to check if it solves the first problem.

If you give me access to an FTP account for the Website, I may try to increase that variable in the .htaccess file and check other configuration parameters.

Then, I will create a test product. As long as I am concerned, I can assume that it is safe for me to create a test product as it is a site under construction. In another case, please let me know and we’ll find another solution.

Best wishes,
Oscar.

April 9, 2019 at 1:04 pm #3567071

michaelV-51

Hi Oscar,
argh, it should be changed already. I actually emailed server support and was sure that it had been changed to something larger than 1000. I've emailed them again (we're not allowed to change .htaccess files apparently), and I'll email back once I've had a response.

Yep, feel free to make any test products needed, it's all in maintenance mode anyhoo.

April 9, 2019 at 5:20 pm #3569671

michaelV-51

Hi Oscar,
Ok so, there was confusion between the PHP settings file and WP backend, this has now been fixed by the hosting support people. I just checked and input vars is indeed now at 10 000.

:D:D Thanks in great abundance to you for your continued help in resolving these issues 😀 I look forward to experiencing the benefits and functionality of operating a multi-language e-commerce site, not much further to go now (I tell myself, hahahah)

Mike

April 10, 2019 at 9:38 am #3574333

Oscar Miras

Hi Michael,

You are very welcome. I’m just sorry you have to deal with it but I hope we’ll be able to manage it to work.

I think have some good news.
After increasing the max_input_vars value, it seems that things are working fine now.
Nevertheless, some works need to be done to update all the translation’s state.

Paradoxically, products can be displayed in English and the translated language:

Default language: hidden link
Spanish language:
hidden link

Whereas in Woocommerce > Woocommerce Multilingual Products some translations are still displayed as “Spanish: Update translation”. This may be happening as a result of the previous misconfiguration of WordPress and variables.

To fix it, I need that you complete all the pending translations:

  • Go to WPML > Translations
  • Find all translations that either is “In Progress” or “Complete - (needs update)”. Click Translate or Edit and complete the translation.
  • You may try to do it first for a single secondary language, to check that it works. For example, you can filter on the top of the page translations: “From English to Spanish”. Leave “All statuses” and click Filter

You may notice some PHP Warning when coming back from the Advanced Translator. I think it’s not something to worry about but I will check it with my team (I think it is also related to the previous misconfiguration).

Now, if you go to Woocommerce > Woocommerce Multilingual, Product tab, the translation of that product for the secondary language should be set as translated, represented by the icon of a pencil.

During my tests, the site worked pretty smooth, and after completing the translations, products were immediately displayed as translated. I hope you will experience the same. If that’s not the case, just let me know.

Finally, I have realised that some translations for your product categories and tags are missing. It is recommended to translate them before even translating products. You can do that in Woocommerce > Woocoomerce Multilingual, and open Categories and Tag tabs to translate them.

After you do some work and make some tests, please let me know if now you are able to translate products to secondary languages so we can move on to the other issues.

Best wishes,
Oscar.

Related documentation:
https://wpml.org/documentation/related-projects/woocommerce-multilingual/#translating-product-categories-tags-attributes-and-custom-taxonomies

April 10, 2019 at 12:29 pm #3576127
michaelV-51

Hello,
ok, so like you said, I've gone into translations and completed all of those product listings. By doing so it's now updated those specific listings with a completed pencil icon when viewed in Woocommerce. This I can confirm.

While I was in WPML>Translations, I also noticed that there is a lot of pages (cloud storage, websites, url shortener, artwork) that no longer exist. Should these be removed automatically? are they part of this mismatch that's being seen or is it a manual remove on my part, I couldn't find a delete button.

I'll just send you this so far, to confirm the change was successful,

cheers

April 10, 2019 at 2:15 pm #3577277

Oscar Miras

Hi Michael,

If those pages do not exist anymore so their translations are not needed, you can cancel them by clicking on the "Resign" button next to each translation.

We are required to work in one single issue on every ticket. Therefore, I have created two tickets for the other two issues we are dealing with:

https://wpml.org/forums/topic/i-cant-translate-some-parts-of-vogue-theme/
https://wpml.org/forums/topic/shop-in-secondary-language-is-empty/

They have been assigned to me.

I would kindly ask you that, in case your first issue is resolved, to close this ticket and we'll continue working in the other two tickets.

Thank you,
Óscar.

April 10, 2019 at 2:22 pm #3577303

michaelV-51

"Resign" button next to each translation. < I missed that, thanks.

Now closing this current ticket as resolved.

Thanks for you assistance in resolving this current issue, I hope to not take up any more time than is required in solving the remaining problems.

Thanks Oscar.

April 10, 2019 at 2:23 pm #3577315

michaelV-51