Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Dražen Duvnjak 3 months, 3 weeks ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
April 8, 2020 at 5:46 pm #5868717

andyB-15

Hi there,

For one of our clients (geminibv.nl) we are using the multiple domain setting (geminibv.fr, geminibv.com, geminibv.de) and we activated single sign on in the settings of WPML, so that users are automatically signed in and out through all domains.

We've unset the X-Frame-options response header, so that the cross-domain are allowed to communicate with each other (as mentioned in https://wpml.org/errata/single-sign-on-feature-not-working-due-to-setting-the-x-frame-options-to-sameorigin/).

However, the single sign on is still not working. When we log-in on hidden link and switch to hidden link, we're immidiately logged out.

Could you help us resolve this asap?

April 10, 2020 at 11:46 am #5883741

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello Andy,

I will do my best to help you solve the issue.

In the debug information provided I see you are using an old WPML version.

1) Can you please update all WPML plugins to the latest version. Also, update all other plugins/themes to avoid any compatibility issues.

2) In order to run correctly, WPML requires MySQL 5.6 or above. Please contact your hosting and ask to update the MYSQL version.

More info: https://wpml.org/home/minimum-requirements/

Please let me know how it goes and don't hesitate to ask if you find any problem along the way.

Regards,
Drazen

April 20, 2020 at 9:22 am #5946879

andyB-15

Hi,

We’ve updated WPML and all relevant plugins to the latest version. MySQL has been updated to MariaDB 10.4, which is an equivalent for MySQL 5.7 (but is backwards compatible to 5.5).

Could you help us out with the problem?

Thanks

April 20, 2020 at 11:17 am #5947905

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for the reply.

Can you please do the next few tests that might help me find what is causing the issue:

1) Please enable error logging that will save all errors in a file called debug.log, log file inside the /wp-content/ directory.

To do so, please add the following

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false);

Once you have added those lines to your wp-config.php file, please try and replicate the issue. Then go to your installation's wp-content folder and find the "debug.log" file that should've appeared by now (it will appear if it encounters an error in your server).

Share the errors if any,

2) - Disable all other not related plugin and theme. Leave active only WPML plugins on the WP default theme.
- Disable any cache related system if active on hosting
- After disabled everything as mentioned above, test the option in incognito mode, other browser (Chrome, Firefox) and if possible different devices (PC, Phone).

Please let me know how it goes and don't hesitate to ask if you find any problem along the way.

Regards,
Drazen

April 30, 2020 at 10:01 pm #6033921

andyB-15

Hi Drazan,

1) There were no errors in the debug.log.

2) We disabled all plugins on the website (active only WPML) but this did not solve the problem.

We hope to use the multilangual cms asap because we paid a lot of money for this plugin.

Hope to hear from you soon.

Regards

May 2, 2020 at 6:01 am #6042561

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi Andy,

In order to investigate this issue and to understand it better, I would need to access your website.

Please make a full backup of your site (files and database) and confirm it in your next reply.

I would need to access your site's wp-admin and FTP account. I have enabled the private username and password fields in your next reply.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the fields mentioned above.

You can safely add your information into these fields. I would also need your permission to access the database as well.

Thanks and regards,
Drazen

May 7, 2020 at 1:31 pm #6080405

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for sharing access, I haven't done much testing since I tested the option and it is working fine for me. When I log-in on hidden link and switch to hidden link or any other domain, I am still logged in. I tried also changing language in the backend using a language switcher.

xdomain_data is passed between domains as described here and I stay logged in:

- https://wpml.org/documentation/getting-started-guide/language-setup/passing-session-data-between-languages-in-domains/

Please check the video, maybe I am doing something wrong:
- hidden link

Please let me know.

Thanks,
Drazen

May 8, 2020 at 3:56 pm #6090265

andyB-15

Hi Drazen,

Thanks for your comment.

Very strange that everything works for you. We have tested it and now it is visible in 2 languages. We still see no results on the German website, see also this video: hidden link

How can we get everything working asap? We do pay for WPML as a tool.

Thanks

May 9, 2020 at 8:16 am #6093375

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for sharing the video. That is very strange, I have done some further testing on my side with different browsers and it seems to be working fine on my side.

I am doing my best, but I will need to be able to replicate the issue to see what it goes wrong.

Since before it didn't work on fr and now it works , only DE is not showing correctly. Maybe you are seeing cached version or you are somehow being blocked from accessing the admin dashboard.

Can you please test a few more things and see if the issue still happening:

1) Try testing in new incognito mode (without any Chrome addons active)
2) Try using some other browsers (Edge, Firefox, Opera)
3) Try on some other devices
4) Try to use the user admin account I am using (wpml) and see if the issue still happens
5) Does this happen only to you/your admin account or there are other users with the same issue

Please let me know how it goes.

Thank you and regards,
Drazen

May 15, 2020 at 3:24 pm #6142149

andyB-15

Hi,

1) Try testing in new incognito mode (without any Chrome addons active)
-> Everything works fine (NL/DU/FR/EN)!
2) Try using some other browsers (Edge, Firefox, Opera)
-> On Firefox, it doesn't work for other languages (DU/FR/EN)
3) Try on some other devices
-> No differences compared with my own device
4) Try to use the user admin account I am using (wpml) and see if the issue still happens
-> The issue still happens
5) Does this happen only to you/your admin account or there are other users with the same issue
-> Other users have the same issue

Regards

May 16, 2020 at 7:47 am #6145947

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

ok, that is good news, so we got it to work on your side.

If it is working fine in an incognito mode that means there is either some addon blocking on more likely you have the same cached old version of the page on your side which is showing to you.

I am sorry I am just suggesting steps to try, but since my colleagues and I can't see the issue on our side, and it is working fine this is the best we can do at this point. We are getting progress at least we know it working fine in incognito.

Please check following next steps and let me know how it goes:

1) Create a new user in chrome with no addons and test if it is working

Info: hidden link

2) Does it work in Firefox in private mode

3) Clear all cache for all domains and test if it working fine. Be sure to clear cache and cookies for all domains in question.

Info: hidden link

4) Please try to download Opera and test in normal and private mode if it is working

5) When you have issue appearing, check if any console errors

Info: hidden link

Please let me know how it goes.

Thanks and regards.
Drazen

May 26, 2020 at 4:28 pm #6221965

andyB-15

Hi Drazen,

I'm sorry for the late reply.

We have tried all steps / browsers but it still doesn't work at our side.

Please let us know how we can solve it asap.

Thanks and best regards

May 27, 2020 at 9:47 am #6227911

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hey,

thanks for the update.

I am sharing this problem with our 2nd tier support, and will update you when I get a reply. If needed we will escalate this ticket to our developers.

I will update you soon.

Thanks for the patience.

Regards,
Drazen

May 27, 2020 at 2:18 pm #6230101

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

I have received a reply from 2nd tier, it seems it working fine for them too.

They are suspecting there is a cache issue on your side. Since it is working fine for you in incognito mode, as you confirmed before.

Can you please test it once again as per 2nd tier instructions:

- Go to hidden link
- Make sure to clear all cache and cookies. Please double-check this.
- Let the login page load completely before entering the details
- Log in and let me know if the issue still there

Thank you for your patience.

Regards,
Drazen

June 3, 2020 at 6:49 am #6279923

andyB-15

Hi Drazen,

Thanks for your reply. We will check this asap and come back to you.

Regards

The topic ‘[Closed] Issue multiple domain setting’ is closed to new replies.