This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 31 replies, has 2 voices.

Last updated by mikeT-12 1 month, 1 week ago.

Assigned support staff: Bruno Kos.

Author Posts
March 25, 2020 at 5:40 pm #5763239

mikeT-12

I am trying to:

- Update the English homepage (or any page) to be identical to the French homepage in layout.
- Link Rogers 60 page in the back end

Link to a page where the issue can be seen:

- about.rogers.com
- about.rogers.com/rogers-60th/

I expected to see:

- layout exactly the same in EN+FR

Instead, I got:

- I tried to update the Rogers 60th page the other day. However, every time I went to the French page, two blocks (moment #2/3, and moment #5/6) wouldn't update correctly. Every time I tried to update the French side, I would enter the French, click update, and English would automatically appear after updating. I've gone through WPML Translation/String Translation/Translation Management, and everything looks correct in there.

- But that's the smaller issue right now, and likely part of a bigger issue. I tried to add a new block a couple of days ago on the homepage. I did this in English, clicked update, and everything looked great. When I switched over to view the French page, titles were in the wrong sections, extra blocks were added randomly, missing blocks, missing or incorrect text, links going to the wrong places, pictures on the wrong side ... basically everything that could go wrong, went wrong. So I fixed it on the French page. I saved, then went to the English page. Everything messed up on that side. I went back and forth for about 5 hours to get to where it is right now. As you can see, all text and titles are correct, but the boxes don't align properly. If I align then correctly, the entire English page will mess up again, so I'm leaving as it is right now because it's as "close" to normal as I can get. And for what it's worth, it usually takes a few minutes after updating the English version to see the results/mess up on the French side.

In the past, I'd simply add a new box on the English side, save, go to the French side, add that box, save, and everything would be perfect. But something happened and it's very frustrating to try to figure out.

I'm working with a vendor on this, and they have suggested it was a WPML issue, and advised I provide you with the following:

"From what I could tell, it looks like a “crossed-wires” type of situation. It seems as though there’s some sort translation issue that’s overwriting content in existing ACF fields, and not properly copying them when creating a new translation; for clarity, when I say “not copying them”, I’m referring to not copying the fields themselves, not necessarily the field values (some will only copy over once, or never). I’ve noticed this when trying to create test pages:
1. Create a test page in English with some ACF fields.
2. Create a French translation. Upon saving a draft, no fields are duplicated / synced.
3. If you go back to English and update some text, it’ll show the French page as needing to be updated.
4. Going back to the French page shows a Warning: You are trying to edit a translation that is currently in the process error, but going to the Translation Management Dashboard shows nothing out of place.
Replicating those above steps might give the WPML team some insight into what’s going on, along with telling them what you told me re: your content input troubles."

Is this something you're able to help with? We don't want to roll back the site, as recently, we've updated a lot of pages and only want to roll back as a last resort. Any info you could provide would be greatly appreciated!

March 26, 2020 at 7:17 am #5766407

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Would you be willing to provide me with WordPress credentials so I could investigate the issue directly?

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

I marked your next reply as private so that you can safely add credentials.

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

But before you do, can you do this:
- update Advanced Custom Fields PRO
- increase WordPress memory limit

https://wordpress.org/support/article/editing-wp-config-php/#increasing-memory-allocated-to-php

So just add this into wp-config.php file:

define('WP_MEMORY_LIMIT', '128M');

before this line:

/* That's all, stop editing! Happy publishing. */

I will then see if I can emulate this:

I’ve noticed this when trying to create test pages:

In fact, if you could create a short video explain the issue on a test page, that would really help me as I would know we are on the same page with reproducing.

Regards,
Bruno Kos

March 27, 2020 at 6:48 am #5775725

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I checked the first video and from what I see, this is a wrong workflow in creating translations. As far as I see, you're basically creating them on their own and then using " connect with translations" option, am I right?

ACF fields ( specifically the translations) is already requiring a quite complex logic behind the scenes and using anything other than regular workflows through translation editor could cause issues that are mostly unsolvable.

For example have a look at this page:
hidden link

Try changing something on this English, then open French translation and try modifying something there, then returned to English and update, etc.

You will see that they translate properly and are handled individually. So how have I done this? Given that custom fields translation preferences are set properly, I simply activated WPML translation editor for this page, I translated it first, copy-once did its job and then disabled translation editor and can translate as I wish.

But I do not see how could I use any other page created individually and then use connect with translations, because ACF can hardly know which fields belong to each and this whole connection is already broken or in fact nonexisting.

Am I correct in guessing the workflow here?

Regards,
Bruno Kos

March 27, 2020 at 12:11 pm #5778303

mikeT-12

I checked the first video and from what I see, this is a wrong workflow in creating translations. As far as I see, you're basically creating them on their own and then using " connect with translations" option, am I right? >> They were originally linked and created using the correct workflow, but because the translation messed up, I had to de-link them in order to have those pages work correctly. I only linked them back together again for the video. When the pages are linked, no matter via whichever workflow, it doesn't work correctly.

I tested out your page, and yes, it initially works correctly. But just for those two blocks that you originally set up. However, I updated the French page by adding more blocks, and when I did this, it completely wiped out the content on the English page. Please review both EN + FR versions of that page - run some tests by updating the English copy or adding a new block, then go back to the French and see what happens.

The creation of the pages is not the issue - it's when updating the pages, that's when all of the issues occur. Thanks again for looking into the issue, Bruno!

March 27, 2020 at 1:50 pm #5780069

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

run some tests by updating the English copy or adding a new block, then go back to the French and see what happens.

I've been doing this for about 5 minutes, but nothing happened. Maybe some particular element you used, or?
hidden link

When 5 minutes of free screencast expired (wasn't recorded), I removed some blocks to see if that will trigger deletion, but also nothing, everything is still there:
hidden link

Regards,
Bruno Kos

March 27, 2020 at 2:35 pm #5780537

mikeT-12

hidden link << please see the third video here. If I'm doing something wrong, please let me know and I'll test out again ... but hopefully you'll see what's happening through this. Creating a new page from scratch, adding blocks, switching to French, adding blocks, and those blocks are now empty on French. If I kept going, you'd see things would get to exactly how it is on that second video, with blocks switching places, emptying text, links changing, pictures changing, etc. I'm hoping I'm just doing something incorrectly and perhaps you can solve that? But I've created the entire site the exact same way, and there were no issues until a couple of weeks ago. I'm stumped.

March 30, 2020 at 5:19 am #5790897

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I'm just doing something incorrectly and perhaps you can solve that?

While comparing yours and my workflow, there are only two differences I was able to notice:
- In your site, there are numbers in the slug, could it be that?
- you're switching the language through language bar when creating translation, I did it by clicking the + sign, even though I don't think it should matter at all

Apart from that I really don't know what's going on.

Regards,
Bruno Kos

March 30, 2020 at 2:28 pm #5795961

mikeT-12

Yeah, it happens when no numbers in the slug, and I've done the plus sign way for almost every page. So nothing, huh ... reco at this point is to revert the site back to a point where it was working correctly? Or is there any way we can revert WPML back to a previous version? I'm not completely sure the issues coincided when I upgraded WPML to the newest version or not (I started noticing these issues around that same time), but perhaps there's a small chance that's what happened?

March 30, 2020 at 6:14 pm #5798161

mikeT-12

I did a little bit of additional troubleshooting on my side. I tried delinking the EN/FR versions of a page, updating both versions, then relinking them ... this seems to work correctly in most cases as a work around (as long as I don't touch anything afterwards). But it's a bit of a pain. I also tried deactivating all WPML plug-ins, but this didn't help and the same issue appeared.

However ... when I deactivated the Advanced Custom Fields Multilingual plugin, the issue appears to be resolved, and I can update freely once again. Are you aware of any issues with that plugin? Has there been an update to it that may have caused the problems? What would happen if I completely disable that plug-in going forward? Thanks as always for your help!

March 31, 2020 at 6:41 am #5801129

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

How about reverting ACFML to https://wpml.org/download/acfml/?section=changelog and perhaps checking if the issue is happening there?

But as for your question, since you're not using WPML translation editor when doing translations, I believe you can resume working without ACFML because it is mostly needed for proper synchronization between all the fields when translation editor is used.

I did some tests on my localhost and if no ACFML is used, then all the fields have "don't translate" values set meaning you can modify them as you wish on the translated pages.

Regards,
Bruno Kos

March 31, 2020 at 6:22 pm #5807341

mikeT-12

I went from 1.6.1 to 1.6.0 and ran a couple of preliminary tests - the issue remained. However, when I went back to 1.5.0, I believe that everything worked correctly. I tested it out on the live site and it looked good. Afterwards, I disabled it, and the site remains intact. Not sure if others have experienced this with 1.6.0/1.6.1, or if it's the way my site is set up, but there ya have it! Looks like the bigger issue is now resolved.

But that still leaves the first issue above ... where I was trying to update the Rogers 60th page and when I go to the French side and try to update moment's 5+6, the English remains. It also happens on our COVID-19 Resources page ... when I click Update on the French side, it deletes all of the french cards except for one, which is now completely empty. This issue appears only to happen when using that specific block - I don't seem to be having issues on any other block as far as I know.

Not sure if this is something you're able to help with, but you're more than welcome to go into the staging site and play with those pages. Feel free to link them together, recreate them, etc. And if this isn't something that you're able to help with, no worries, as we've solved the main issue. 🙂

Thanks!

April 1, 2020 at 6:22 am #5809737

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

It says "Unknown username. Check again or try your email address." when trying to use these credentials.

Did you remove the user already?

Regards,
Bruno Kos

April 1, 2020 at 10:30 am #5811717

mikeT-12

Apologies, I backed up the site yesterday which removed it. I've re-added the user account.

April 1, 2020 at 11:55 am #5812767

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

This issue appears only to happen when using that specific block

Sorry to ask, but which block exactly? Page Cards?

So when this block is used on some page, the issue happens

Regards,
Bruno Kos

April 1, 2020 at 11:56 am #5812775

mikeT-12

That's correct ... the Page Link Cards block. As far as I can tell, that's the only one that's causing issues.