Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 31 replies, has 2 voices.

Last updated by mikeT-12 7 months ago.

Assigned support staff: Bruno Kos.

Author Posts
April 2, 2020 at 4:57 am #5819235

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

hidden link
hidden link

No matter how hard I try, still nothing, can you break it (don't unlink them as translation though) and tell me which action at which point did it?

Regards,
Bruno Kos

April 2, 2020 at 12:16 pm #5822261

mikeT-12

Couple easy ways to break it. On the French page, try removing the pictures and click update. The pictures remain. Next, remove the Page Link Cards block. Add a blank Page Link Cards block, then click update. The English version appears with the text and pictures.

April 2, 2020 at 1:04 pm #5822967

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Can you perhaps do this?
- login here:
hidden link
boris@example.com
V2hUJQOyqq6EiZMnvJ1yh18h
- install the latest ACF PRO plugin
- import the field group
- see if the issue with cards is happening here as well

We need nothing else - no other plugins, theme, content, nothing. That will tell us whether there is something wrong on your site or the set of these fields.

Regards,
Bruno Kos

April 3, 2020 at 1:20 pm #5832353

mikeT-12

Great idea. However, having issues when trying to login ... says "ERROR: User can't find."

April 6, 2020 at 5:08 am #5844379

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Can you try with these?

mikeT-12
Wn0s76lgBaA7OduZAz$$wUr!

Regards,
Bruno Kos

April 6, 2020 at 4:15 pm #5850739

mikeT-12

Perfect, thanks Bruno! Those credentials worked. I'm not sure when my vendor will be able to install ACF Pro, but they advised me it'll be early this week. Will get back to you once it's installed and I've tested everything.

April 7, 2020 at 6:21 am #5853849

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Ok, sounds like a plan, keep me posted.

Regards,
Bruno Kos

April 9, 2020 at 6:32 pm #5878901

mikeT-12

Hey Bruno, so sorry for the delay on this. So I created a test page in English, but it's gave me the gears icon (instead of the + icon) when trying to translate. That doesn't happen on our site, it's always straight into the edit page without having to go through that gear icon. I turned off the Use WPML Translation Editor button from the right, but that didn't help.

So I just clicked copy/all, saved, and then went into editing the page. Everything seems to work perfectly over there - no issues at all. I was able to update/move/delete, nothing broke - assume that's a good thing. 🙂 Wondering if the gears icon means anything in this situation? If not, what does it mean that everything functions correctly?

April 10, 2020 at 6:44 am #5881353

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Gears icon only means that the translation is in progress, like it started but you have not completed it to 100%:
https://wpml.org/documentation/translating-your-contents/#how-to-check-the-status-of-translation-jobs

But since you say it works, then it could be any of the following:
- some of your plugins on the site interfering with his behavior
- maybe a theme
- something on the server level not working properly
- some particular setting on the site

Can I ask you the following? In order to debug this issue, I will install Duplicator plugin, will create packages and will try this on my localhost and possibly escalate further to 2nd tier.

https://wpml.org/faq/provide-supporters-copy-site/

Let me know if this is OK with you.

Regards,
Bruno Kos

April 13, 2020 at 2:34 pm #5897055

mikeT-12

Yes, this is fine ... please go ahead and install. Thanks!!

April 14, 2020 at 6:00 am #5901071

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

I restored the site to my localhost and am trying to break these two pages, but I guess I am bad with breaking stuff 🙂

hidden link
hidden link

Can you perhaps record a screencast with audio and show/explain how can I do it myself on my localhost installation?

I am trying this - https://wpml.org/forums/topic/issue-syncing-english-and-french-pages/page/2/#post-5822261 - but to no avail, maybe I am look at the wrong things.

Regards,
Bruno Kos

April 21, 2020 at 6:28 pm #5962511

mikeT-12

Sorry for the late reply on this, was on vacation for the past week. Hope you're staying safe and healthy.

On your pages, see here for the video (the pictures won't change, even after deleting the block): hidden link

For the 60th one page, the blocks go blank (see the second video).

Sometimes the words won't change or go English, sometimes the pictures don't update, sometimes it deletes everything that's added, sometimes the links don't update ... it's random on what happens, but it only happens with that particular block. And it only messes up the last block on the page ... if there are 3 blocks, it'll mess up the 3rd one. If there's 1, it messes up that one. But the others all remain intact.

April 22, 2020 at 7:03 am #5965105

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

On your pages, see here for the video (the pictures won't change, even after deleting the block):

But when I check hidden link, link_image, it has "Translation preferences" set as Copy, so it would be expected that on translated page - hidden link - that is, it would always sync with original and cannot be changed on translation.
Regards,
Bruno Kos

April 23, 2020 at 2:31 pm #5978203

mikeT-12

Bruno, you amazing man. I think you figured it out. 🙂 I've personally never been on that page before (the vendor set up everything in there). I changed all of the page link cards fields to "Do not translate" and tested ... it didn't work. Then changed them over to "copy once", and it worked like a charm. I copied the entire live site back over to staging, changed them to "copy once" immediately, but it didn't work. So I tried the same thing again - do not translate, then copy once, and it worked. Went to the live site ... changed do not translate, saved, changed to copy once, saved - and lo and behold, everything works perfectly now! I can't thank you enough for your assistance on this - so thankful that you were able to figure it all out!!

April 24, 2020 at 6:48 am #5983313

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

So it means we got it resolved finally? 🙂 I believe that all this time I was misguided when you were saying that the original language gets wiped out completely. Translation preferences would not do this, so I wasn't sure what we were looking for and where the issue could have been.

Regards,
Bruno Kos