This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by davidB-169 1 year ago.

Assigned support staff: Mihai Apetrei.

Author Posts
October 4, 2018 at 9:40 am #2787024

davidB-169

I am trying to: translate MailChimp Form from French to German

I have installed the plugin for MailChimp and tried to follow the instructions under the following link: https://wpml.org/documentation/related-projects/mailchimp-for-wordpress-multilingual/

To follow the procedure we need to be registered as "Translation Manager". But with a Translation Manager account we get a blank page to WPML -> Translation Management page and we cannot complete the procedure.

All WPML plug-ins are up-to-date.

Thank you for your help

David

October 4, 2018 at 4:52 pm #2788353

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

At this long section here (https://wpml.org/documentation/related-projects/mailchimp-for-wordpress-multilingual/#translating-your-forms) it also says this:
"To be able to translate yourself, you must be added as a Translator in WPML. You also need to have the corresponding language pairs associated with your translator role. Learn more about this in the first section of our Getting Started Guide.".

This might be the reason why you see no translatable items there and you receive an empty page instead.

Can you please let me know if you assigned the translation request to a user that has the corresponding language pairs associated to his account?

I will be waiting for your answer.

October 5, 2018 at 7:34 am #2789722

davidB-169

Hello

Thank you for your reply. Until yet we have been able to translate the whole website without problem. The problem occurs if we want to translate MailChimp for WP. For that WPLM ask me to be "translation manager". If I assign myself this role, the whole translation manager page becomes blank and we cannot go on.

Do I make a mistake? Is it a configuration issue?

I attache the Screenshot for a better explanation of the issue.

Regards
David

October 8, 2018 at 3:07 pm #2796548

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi David.

Thank you very much for the screenshots and the detailed information.

I think you might be in the wrong place from what I see in the screenshots.

After you set the content for translation and assign it to the user that you want, can you please log to that user, go to WPML > Translations and let me know if the forms show up in there for translation?

That is the place where the assigned translations should appear.

Please let me know how it goes. I will be waiting for your answer.

October 9, 2018 at 4:11 pm #2801005

davidB-169

Hello Mihai

Thank you for your reply. Nothing appears If I go to WPML > Translation. it says "No translation language configured for this user."

Could you let me know how I have to proceed to assign that translation (MailChimps for WP) to the user, please?

Regards
David

October 10, 2018 at 6:39 pm #2805446

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi David.

If it says "No translation language configured for this user." I guess that the right language was yet not assigned to the user.

In order to set the Translation Roles for a user, you need to:

1. Go to WPML > Translation Management > Translation Roles. Here you can add new translators or edit current translators. The "Translation Managers" section is for the user that's assigned to be the translation manager and the "Set Local Translators" section is the section where you add new translators by using the "+ Add Translator" button on the right
2. In the "Set Local Translators" section you will see that on the row named "Name" you can find the users of the current translators. Hovering over a user name will show you a text link called "Edit Languages" (I am attaching a screenshot, too). Click on it and there is where you can select the languages a user can translate to and from.

Here are the steps that would need to be followed for the rest of the process:

1. Go to Translation Management
2. Go to Translation Roles and make sure the site has a Translation Manager
3. Then make sure that the languages for the user that you want to give translation jobs to are according to the language that you want that user to translate the content into
4. Then go to the Translation Dashboard
5. Select the item/items for translation
6. Scroll down and click on the “Translate” rounded checkbox
7. Click the blue “Add selected content to translation basket” button
8. Go to Translation Basket
9. Go through the 3 steps where you review the documents for translation, set the batch name and deadline and then go through the final step where you select the translator you want from the drop-down menu
10. After this, click the blue “Send all items for translation” button
11. Now go to WPML > Translations and you should see that item with the “Translation status” set to “Waiting for translator”

Please let me know if these steps helped you accomplish what you needed or if you still need help.

I will be waiting for your answer.

October 12, 2018 at 2:08 pm #2812259

davidB-169

Hi Mihai

Thank you for these detailed explanations. I actually found the solution.

As mentioned in my first message, I couldn't follow the instructions because the translation management page was completely blank. The problem seems to be related with the Webcraftic Clearfy – WordPress optimization plugin. If this plug-in is activated, the WMPL Translation Dashboard becomes blank.

I have deactivated this plug-in and the problem is solved. For your information the web page of Webcraftic is the following:

hidden link

I will inform their support team about this issue. They will probably release an update.

For me, the problem is solved. You can close this case.

Best regards
David

October 12, 2018 at 2:09 pm #2812260

davidB-169

My issue is resolved now. Thank you!