Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 24 replies, has 3 voices.

Last updated by Laura 1 day, 16 hours ago.

Assigned support staff: Laura.

Author Posts
November 12, 2019 at 7:23 pm #4934359

thibaultC-3

I am trying to:
My language is French and the translation is for Japanese.
But when I go to Advanced Translation Editor it translate in Spanish... Very strange and no way to change this...
Thanks
David

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

November 13, 2019 at 6:01 am #4935751

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

I see you have these languages : hidden link
So you have Spanish in your site.
if you click any language pair, then it is translating to Spanish?
Does this happen all the posts or in a specific post?

Let me know.

Regards,
Riffaz.

November 15, 2019 at 6:23 pm #4956185

thibaultC-3

Hi Riffaz,
I have the same issue with Japanese and Chinese...
Only good in English and French.
Thanks for your help.
David

November 17, 2019 at 12:56 pm #4960163

thibaultC-3

Hi Riffaz,
No news from you...Could you please give me a help ?
Best,
David

November 17, 2019 at 12:57 pm #4960175

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I have the same issue with Japanese and Chinese
- do you mean that, if you click on Japanese and Chinese pair it is translating to Spanish?

Are you using local translators ? or any translation services?

Let me know please.

Regards,

November 17, 2019 at 1:36 pm #4960285

thibaultC-3

No sorry I am mixing issues... Look at the 14.34.42... This is the french to Japanese I need to translate.
Now when I click the link to translate it gives me the 14.34.20 ...To spanish ?????
I don't know how and why ?
Thanks for your help

November 17, 2019 at 1:52 pm #4960361

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

create a temporary admin user.
Let me know that username and password to check this closely.
The next reply is private.

Regards,

November 18, 2019 at 11:39 am #4964645

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

I could not sync the translators and managers as well: hidden link
This is because your site ID:global and site ID:ATE are not same: hidden link
To fix this, we have to replace the siteID:ATE value with siteID:global value.
I did that for you but still no luck.
I have to check this with our second tier now.

And, I created a test post in French hidden link
Tried to translate it to Japanese and it goes to Japanese translation: hidden link but it is in classic translation editor.
As you have selected ATE for new contents hidden link it should be opened in in ATE but it is not.

Then how did you manage to get this? https://wpml.org/wp-content/uploads/2019/11/4960285-Capture_d_e_cran_2019_11_17_a_14.34.20.png

Are you able to open the ATE when you try to translate new contents?
If yes, how?
The screenshots you provided in the initial question of this ticket : Are they old content which you created before activating ATE?

Let me know please.

Regards,

November 19, 2019 at 8:49 am #4969487

thibaultC-3

Hi Riffaz,
Since the beginning I was using the ATE.
When I update a page it opens ATE each time. I did nothing special to open in ATE. Now That it is on global I have no more access.
So I have no old content created before activating ATE.
If We create a template of the page and delete the existing page, would it be possible activating ATE before to create new translations ?
Is that a possible solution ?
Best,
David

November 19, 2019 at 12:51 pm #4972291

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Before going further we have to fix this first: hidden link

If We create a template of the page and delete the existing page, would it be possible activating ATE before to create new translations ?
Is that a possible solution ?
- not really. issue is related to your UUID of the ATE as well.

So, could you confirm please?
1. new pages translations are NOT using the ATE
2. old contents as well are NOT using the ATE

Based on this, I will update it to ATE department.
So they will have a look at this issue.

Regards,

November 19, 2019 at 1:45 pm #4972811

thibaultC-3

Hi Riffaz,
So I checked and disabled the ATE for new content.
Waiting for your feedback.
Best

November 20, 2019 at 7:35 am #4977317

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Sorry, I did not ask you select the second option.
Actually I asked to confirm the issues are :

1. new pages translations are NOT using the ATE
2. old contents as well are NOT using the ATE

I logged in to your site and changed back to ATE. 🙂

I discussed with the team.
please do the followings and check the issue.
If you still see the issue our second tier will check this.

1. disable all the plugins except WPML
2. go to WPML > Support > Troubleshooting and click on all the buttons there except "reset"

Then check the issue.

Let me know the results, please.

Regards,

November 26, 2019 at 10:00 am #5019853

thibaultC-3

Hi Riffaz,
So, I went to troubleshooting but there is a lot of things, could you please be more specific on what to do.
Is it this page correct ?
Best

November 26, 2019 at 11:18 am #5020571

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

All of them except this: hidden link

Regards,

November 26, 2019 at 11:42 am #5020907

thibaultC-3

I did what you asked but still having this error