This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: After install WPML RTL, the dashboard becomes RTL on arabic language

Solution: This was caused by a conflict with the YITH Woocommerce compare plugin

It was fixed by the plugin author on the lastest version

This topic contains 22 replies, has 2 voices.

Last updated by Hassan Saggaf 1 year ago.

Assigned support staff: Diego Pereira.

Author Posts
July 18, 2018 at 10:02 pm

Hassan Saggaf

I am trying to: install WPML

Link to a page where the issue can be seen: After install WPML RTL, arabic the dashboard becomes RTL

I expected to see: TO LTR as English default...

Instead, I got: in Arabic RTL

I want to set ALL LTR in Dashboard ... i want either in English / Arabic Dashboard remain as default English. but when i go to Arabic, The WordPress Dashboard becomes RTL with arabic... i want all in english as default...

July 19, 2018 at 11:30 am #2534572

Hassan Saggaf

Hello ANy updates?...

THere is big problem with WPML your plugin... I cant translate any pages and even in English Dashboard showign Arabic languages... alot of problems. Pls fix asap..

Awaitign Thanks.

July 19, 2018 at 12:12 pm #2534682

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @hassan Saggaf, welcome to the WPML support Forum!

You need to define the dashboard language of your user. For this go to Users > All Users, click on your user, set language as english and save.

After that your dashboard should appear in english and LTR.

Please let me know if it worked for you.

May I kindly ask you please to open a new ticket for the additional issues? This will help other users with similar problems to find solutions when searching the forum.

All the best,
Diego

July 19, 2018 at 12:33 pm #2534729

Hassan Saggaf

Hello..

I did what you have asked... after changed to English saved... but when i go to pages ... Arabic the dashboard completely turns to Arabic pls check in an attach the screenshot;..

Awaiting Thanks.

July 19, 2018 at 12:43 pm #2534742

Hassan Saggaf

i already opened new ticket regarding error for duplicate of pages...

Awaiting for Dashboard issue.. i want either in in ENGLISH or ARABIC page, the dashboard remains as English Default LTR always..

Awaiting thanks.

July 19, 2018 at 1:09 pm #2534812

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Could you clear your browser cache and try again?

If the issue persist, please send us access to your WordPress dashboard (website URL, login and password) I'll check and do some tests. - Please use the private field to send the sensitive data - do not post if you do not see it.

It would be better if you give me a test site rather than the live site.

IMPORTANT Please backup a working copy of site files and database before.

Regards,
Diego

July 19, 2018 at 1:24 pm
July 19, 2018 at 1:35 pm #2534868

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

It is being displayed in English for me (see screenshot).

Could you please try again on an anonymous tab (Ctrl+Shift+N on chrome) and log in using these same credentials?

Regards,
Diego

July 19, 2018 at 1:41 pm #2534884

Hassan Saggaf

yes... in English as i mentioned in English is ok,,, now go to arabic i have created by WPML,... see on your screenshot THE ENGLISH? Choose arabic you will see all RTL ARABIC DASHBOARD.... Pls see in an attach i have attached;

July 19, 2018 at 2:27 pm #2535008

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I can see the issue now. There is an option in Users > Your profile that need to be unchecked (see screenshot). I already unselected it. Now please clear All caches (browser, WordPress, server) and the WPML cache (WPML > Support > Troubleshotting) and test it again.

Please let me know if it worked for you.

Regards,
Diego

July 19, 2018 at 2:49 pm #2535064

Hassan Saggaf

Still the problem.. i now used even new browser FIREFOX that never open this site before... and still the same problem; pls find in an attach the screenshots;

Try yourself by converting any English page to Arabic; click on PLUS ICON to convert, the dashboard totally in arabic with completely page messed up...

awaiting thanks.

July 19, 2018 at 3:14 pm #2535097

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

This is not the default behavior of WPML. Could you please try the solution described on this similar ticket? - https://wpml.org/forums/topic/admin-dashboard-cannot-stay-in-english-while-arabic-default-language/

These are the steps described in the ticket:
- Make a full backup of your site.
- Access your database using the Adminer plugin or your phpMyAdmin and look for the user meta key (in the table named wp_usermeta) - icl_admin_language - which is probably set to NULL.
- Change that to your language code (en for English)

Please let me know if it worked for you. If the issue persist, I'll need to replicate your site locally and test it with minimal settings. . For this I’ll need to temporarily install a plugin called “Duplicator” or "All-in-one WP Migration" on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please let me know if this is ok for you.

Regards,
Diego

July 19, 2018 at 4:15 pm #2535197

Hassan Saggaf

hello..

i have done all the steps which you gave the link;

1. First they asked to check to load .mo which i have already done so far but this message what showing me in my Dashboard:

=========================================================
"site can run faster
This version of WPML includes new settings that will help your site run faster. We recommend changing the following settings, which are all available in WPML->Theme and plugins localization:
Translate strings with ST and don't load .mo files: Some themes and plugins have huge .mo files that take a long time to load. WPML already knows the strings in these files and loads only the necessary strings to display each page.

Apply those changes"

==========================================================

Where as i dont think its good solution to do which will make my site load slow;

2. they finally asked to search WP_USERMETA - icl_admin_language; this is what they asked to do the final step;

, access your database using the Adminer plugin or your phpMyAdmin and look for the user meta key (in the table named wp_usermeta) - icl_admin_language - which is probably set to NULL. Change that to your language code (en for English)

So Far, i have searched ALL OVER in myphpadmin and i couldnt find what exactly they have asked to search; icl_admin_language .... there is no any such name pls see screenshot of meta.jpg

( If you want try yourself you can the credential of cpanel is the same as FTP i have provided...

Anyhow, i have already installed DUPLICATOR PLUGIN as you asked for and already backedup my site;

Awaiting thanks.

July 19, 2018 at 8:40 pm #2535480

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there, thanks for the feedback.

I will take a look at the database now and if needed duplicate the site on my local server to do some test/debugging. I will send you a feedback soon.

Regards,
Diego

July 19, 2018 at 10:48 pm #2535557

Hassan Saggaf

ok awaiting...

Thanks..