This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 14 replies, has 2 voices.

Last updated by Shekhar Bhandari 3 months, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
June 3, 2019 at 5:26 pm #3944897

kamilP-2

Hi,

I have two problems as below - links, I mean two because probably the reason is the same.
When I surfing on the website everything is ok, pages loads corectly in PL and EN language but when I paste link to a browser with "www" at the begining (EN version - .com) there is a issue.

Let's check links below: (copy and paste link)

1) Categories in the portfolio, e.g. (English version)
hidden link

link target to:
(Polish version)
hidden link

2) Portfolio projects, e.g.
hidden link

is targeting: 404 Not Found

I have setup all the redirection from hidden link to kamkam-visuals.tv and for .com

Do you know where is a problem?

Regards,
Kam

June 4, 2019 at 3:58 am #3947771

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thanks for writing in! I’m happy to help out.

I can see that the link you provided hidden link is 404, is this the issue you are mentioning?

Does disabling the WPML plugin solves the issue?

Further, for helping further on this issue it's very important to know your site related information such as themes used, plugins used, PHP versions, etc. You can easily send this using Debug information settings from WPML.

So could you please go to WPML > Support > Debug Information and give me the information in the next reply. You can read the detailed instruction here: http://wpml.org/faq/provide-debug-information-faster-support/

Look forward to your reply.

Thanks

June 4, 2019 at 7:14 am #3948599

kamilP-2

Hi,

Thank you for quick reply.

Answer your question: yes, disabling the WPML plugin solved problem - all the projects and subpages with "www" at the beginning load correctly.

I've send you debug information.

Thanks,
Kam

June 4, 2019 at 9:28 am #3949627

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

To debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

June 17, 2019 at 6:37 am #4032411

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for the details.

Can you confirm that you are still experiencing issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Nineteen)?

Where have you added the redirections rules? In htaccess or some server settings?

Look forward to your reply.

Thanks

June 18, 2019 at 7:48 pm #4046297

kamilP-2

Hi,

yes, I can confirm issues even when all plugins except WPML are disabled and the theme is Twenty Nineteen.

In .htaccess file is:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
RewriteCond %{HTTPS} !=on
RewriteRule ^ hidden link{HTTP_HOST}%{REQUEST_URI} [L,R=301]
</IfModule>

The problem still exists.

Thanks

June 19, 2019 at 3:54 am #4047849

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Could you please use the following htaccess code provided here and let me know if that helps?

RewriteCond %{HTTPS} on
RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ <em><u>hidden link</u></em> [R=301,L]

Link: hidden link

Let me know if this helps.

Thanks

June 24, 2019 at 9:02 pm #4079767

kamilP-2

Hi,

I've used provided code but nothing changed:

hidden link

When add "www" the page with Polish text is displayed:

hidden link

other examples:
hidden link
hidden link

A few months ago I changed the domain on the English version of page, form "co.uk" to ".com"
Maybe it has to do with this?

Thanks

June 25, 2019 at 5:26 am #4081417

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I discussed this issue with our 2nd tier supporter and they recommended to use server-side redirection rather than htaccess, so could you please check with your hosting service that if there is an option for server-side www to non-www redirection and let me know if that helps?

Look forward to your reply.

Thanks

June 28, 2019 at 8:45 am #4105621

kamilP-2

Hello,

Do you mean SSL redirection (http-> https) or www -> non-www?

Could you please give me some example of this kind of redirection?

Thanks

June 28, 2019 at 12:09 pm #4107215

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The settings differ from hosting provider so my best recommendation is to contact the hosting provider and ask about this? Can you please check with them once?

Thanks

July 1, 2019 at 4:43 pm #4121227

kamilP-2

Hi,

I've contacted my hosting provider (OVH: hidden link) and they tell me that I can't set redirection in server settings because I use shared-hosting, and all redirection need to be set up in .htaccess.

So, do you know another solution?

Thanks

July 2, 2019 at 9:08 am #4125163

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Could you please remove all the rules and check if URL hidden link stays on www?

Look forward to your reply.

Thanks

July 5, 2019 at 5:42 pm #4153183

kamilP-2

Hello,

I've removed all the rules and this nothing changed, still is opening page with ".tv" domain:

hidden link
hidden link

Only left wordpress rules:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Thanks

July 8, 2019 at 4:41 am #4159027

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

So there seems to be a different redirect set, probably from the server, can you check if there is any server redirection for this? or have you used any plugins before for redirection purposes.

Look forward to your reply.

Thanks

The topic ‘[Closed] Issue with domain with "www" at the beginning.’ is closed to new replies.