Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.50 hours from now. Thank you for your understanding.

This topic contains 24 replies, has 4 voices.

Last updated by Marcos Vinicios Barreto 1 week, 2 days ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
November 4, 2019 at 6:47 am #4878151

alexanderA

Hello. On my site I have used the WPML plugin to translate my content into French and Chinese. When I open a French page for editing, all of the usual WordPress editor labels remain in English--as desired and as expected (see attached screenshot). But I also have the Elementor plugin installed. When I change the WPML language, then open a page for editing using the Elementor plugin, the Elementor labels are displayed in French (screenshot: hidden link). How can I resolve this, and ensure the controls remain displayed in English?

I have asked Elementor support (see here: https://wordpress.org/support/topic/elementor-lanugage/#post-12093300) and they say it looks to be a WPML issue. You can view that post for a list of troubleshooting steps I already carried out with Elementor.

Thanks.

November 4, 2019 at 6:55 am #4878185

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Did you try this?
https://wpml.org/documentation/getting-started-guide/language-setup/setting-the-wordpress-administration-language/#convenient-content-editing-for-rtl-ltr-sites

On the Users -> Your Profile page, in the WPML language settings section select the Set admin language as editing language check-box to dynamically change the WordPress administration language, according to the content’s language.

Regards,
Bruno Kos

November 4, 2019 at 6:58 am #4878191

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Can you also check this answer?
https://wpml.org/forums/topic/cannot-use-elementor-in-english/#post-4617583

Regards,
Bruno Kos

November 6, 2019 at 6:05 am #4894907

alexanderA

>> Did you try this?
https://wpml.org/documentation/getting-started-guide/language-setup/setting-the-wordpress-administration-language/#convenient-content-editing-for-rtl-ltr-sites

I guess you did not read the link I posted--the link that describes the troubleshooting steps I'ave already taken. No worries, I will paste them here for you to read:

If I switch the WPML language in the admin bar to French, the Elementor editor changes to French, even though the language in Dashboard–>Users–>Your Profile is still English (screenshot: hidden link).

I had a look at WordPress Dashboard > Users > Your profile account > Set admin language as editing language is not ticked (screenshot: hidden link). I can also say that when I switch WPML languages via the admin bar, only the Elementor editor changes language. No other text in the WordPress back-end changes language.

I also tried deactivating all plugins except Elementor and WPML, and the issue was still present.

>> Can you also check this answer?
https://wpml.org/forums/topic/cannot-use-elementor-in-english/#post-4617583

I read that post. It looks to be a viable option. But can you confirm that the steps I should follow are:

1. go to WPML String Translation page
2. At the bottom, under Auto register strings for translation, I clicked edit and deselected elementor and elementor pro
3. back at the String Translation page, search for all strings in elementor and elementor pro domains
4. select "display all results"
5. select all strings, click on delete strings

Thanks.

November 6, 2019 at 10:09 am #4896575

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Apart from https://wpml.org/forums/topic/cannot-use-elementor-in-english/#post-4617583, I don't see what else there is the answer about this.

As for your suggestion about disabling a domain from registering, this option is showing now only when you activate " Look for strings while pages are rendered" and you can edit it then. It might work by removing all these translations from string translation table - I haven't tested this scenario I must admit, because it is particular and not very often used.

However, since all the plugin and theme translations are now pulled through .mo files (from WPML version 4.3.0), those translated .po files might get updated during plugin updates themselves and get loaded again. Maybe a workaround would be to translate some of those strings, but to "translate" them into the same language.

Regards,
Bruno Kos

November 9, 2019 at 9:51 am #4917649

alexanderA

Hi Bruno,

Thanks for your help so far, but I am having a difficult time understanding your English. Specifically, I am having trouble understanding this sentence:

>> Apart from https://wpml.org/forums/topic/cannot-use-elementor-in-english/#post-4617583, I don't see what else there is the answer about this.

Let me perhaps re-explain, and let's proceed slowly. What I was trying to say in my last reply was that I read the post you linked: https://wpml.org/forums/topic/cannot-use-elementor-in-english/#post-4617583. In it, it *seems* to say that the issue I am experiencing is expected, and to resolve it, I need to follow these steps:

1. go to WPML String Translation page
2. At the bottom, under Auto register strings for translation, I clicked edit and deselected elementor and elementor pro
3. back at the String Translation page, search for all strings in elementor and elementor pro domains
4. select "display all results"
5. select all strings, click on delete strings

Can you confirm that I should try those steps to resolve my issue?

In your reply, you later said, "As for your suggestion about disabling a domain from registering..." I'm sorry, but I don't understand what 'disabling a domain from registering' means. So I didn't really understand anything you wrote after that statement :-/

Thanks.

November 9, 2019 at 10:25 am #4917819

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

I apologize for not being clear, here is the explanation:

don't see what else there is the answer about this.

In other words, this means that since my colleague already asked our developers and got the response he did, there is nothing else I can add here because if I ask them the same, I will get the same response as well.

As for "disabling a domain from registering", this phrase means exactly the same as yours: "under Auto register strings for translation, I clicked edit and deselected elementor and elementor pro".

Can you confirm that I should try those steps to resolve my issue?

Yes, I suggest go for it, but I cannot confirm that it would work because I don't have any examples to be found in our archives, and have not tested this scenario myself.

The rest of the comment was mainly referring to this:
https://wpml.org/2019/10/wpml-4-3-with-revamped-string-translation/

Regards,
Bruno Kos

November 10, 2019 at 11:38 am #4920227

alexanderA

>> In other words, this means that since my colleague already asked our developers and got the response he did, there is nothing else I can add here because if I ask them the same, I will get the same response as well.

OK understood.

>> As for "disabling a domain from registering", this phrase means exactly the same as yours: "under Auto register strings for translation, I clicked edit and deselected elementor and elementor pro".

OK understood.

>> Can you confirm that I should try those steps to resolve my issue?
>> Yes, I suggest go for it, but I cannot confirm that it would work because I don't have any examples to be found in our archives, and have not tested this scenario myself.

I am trying to follow the steps, but have some questions. Step #2 says, "2. At the bottom, under Auto register strings for translation, I clicked edit and deselected elementor and elementor pro"

I clicked WPML-->String Translation-->Auto register strings for translation-->edit. But there are several entries for Elementor (each with a different number after it). There is also one entry for the separate Elementor plugin I'm using: Essential Add-ons for Elementor (see attached screenshot).

1. Why are there three entries for Elementor?
2. How should I proceed?

Thanks.

November 10, 2019 at 11:43 am #4920255

alexanderA

I have a follow up to my previous message. On my site, I have used Elementor to edit three different pages, each with post ID: 52555, 52012, and 52311. As you can see in the screenshot, when I open WPML-->String Translation-->Auto register strings for translation-->edit and see three different entries for Elementor, each entry has one of those post IDs appended. So I guess there is one entry for each page/post in which I have used Elementor. Is that expected?

November 11, 2019 at 6:35 am #4922071

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

I'm not entirely sure what these domains are in your case. Because when creating page translations, there should be packages that look like this (see image).

And this is related to this:
https://wpml.org/forums/topic/packages-menu/#post-1527865

However, you can go to string translation and then select these domains ( if they appear) from drop-down and then check what kind of content is within those domains, that may give you an idea on what the strings really are and the whether you should remove them from being all the registered or not.

If these contain some translations, it is possible that these were created before WPML 4.3.0 was introduced, as it brings major changes on what happens with string translation and how it works. So yes, it is expected.

Regards,
Bruno Kos

November 11, 2019 at 11:38 am #4924541

alexanderA

OK. So in light of what you just told me, when I open WPML-->String Translation-->Auto register strings for translation-->edit, what should I select? Should I select all four:

elementor-52555
elementor-52012
elementor-52311
essentials-addons-elementor

November 11, 2019 at 1:22 pm #4925195

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

You can try selecting them all, even though I'm not sure what difference will it make if you select any of the elementor-52555, since they are related to page builder content and not the Elementor itself.

You can also experiment with all this, you can easily revert back to as it was and the make any of these domains to be registered again.

Regards,
Bruno Kos

November 12, 2019 at 8:51 am #4929719

alexanderA

Are you able to pass me up to another support agent--one who perhaps knows what's going on and can answer my questions? It seems like many of my questions are met with shoulder shrugging and, "Try it and see what happens."

Also, the English in your replies frequently has errors, which is making it difficult to understand what you are trying to articulate :-/ I appreciate your assistance, but I think it might be best to transfer me to another agent.

November 12, 2019 at 5:21 pm #4933797

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Hi Alexander, I will be taking over your ticket from here. Those Elementor domains are coming from the page builder packages. In earlier versions of String Translation, page builder content was stored in the String Translation table. You can unregister those domains from String Translation.

As for the WordPress backend, typically the translations are loaded from the .mo/.po files, so I'm not sure that deleting them from String Translation will actually resolve the issue. More than likely, you will need to "translate" the strings in the string translation table but actually enter the English as the translation. This will override the strings that were created from the .mo/.po file.

In addition, I created a fresh install and activated the Elementor plugin,but I was not able to reproduce the issue. Can you take a look here and see if our settings match, or if you are able to recreate the issue on this test site?
One Click Login:hidden link
Username:demo
Password:7TaQC013woWc

If you are not able to recreate it, perhaps we can look at the differences between this test site and your live site and isolate where this is coming from.

November 13, 2019 at 3:52 am #4935603

alexanderA

>> In addition, I created a fresh install and activated the Elementor plugin,but I was not able to reproduce the issue. Can you take a look here and see if our settings match, or if you are able to recreate the issue on this test site?

I had a look at your test site, and I can confirm the issue is not present there. So, how can we track down why the issue is occurring on my site, but not yours? I'm happy to walk through any checks you suggest--even checks I may have already carried out.