Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 29 replies, has 4 voices.

Last updated by alexanderA 1 month ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
November 13, 2019 at 1:58 pm #4939723

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

November 14, 2019 at 8:44 am #4944677

alexanderA

OK. But can you give me instructions on how to make a snapshot with Duplicator?

November 14, 2019 at 1:16 pm #4947213

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Sure, you can find lots of help on the Duplicator plugin site here: hidden link

If you prefer, you can allow me access to your site and I can create the snapshot for you. I have marked the next reply so that you can share credentials if you would like me to login and install/run Duplicator. Thanks!

November 15, 2019 at 7:27 am #4951549

alexanderA

OK, I see those instructions. But you requested that I ensure the /uploads/ directory is not added to the Duplicator package. How exactly do I do that? My /uploads/ directory has an absolute path of:

/home/horizon/domains/horizonhomes-samui.com/www/public/wp-content/uploads

Do I specify this in the 'Directories' field (see attached screenshot)?

November 15, 2019 at 3:00 pm #4955065

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Yes, exactly, you specify it there. You can also click that "wp-uploads" link that you in the top right to the Directories field and it will add the path for you.

November 16, 2019 at 9:03 am #4957695

alexanderA

OK I ignored several directories, including /uploads (see attached screenshot hh-dir-ignore). The pre-compressed size of the package was still ~450 MB, which I thought was pretty high--as if it still wasn't ignore the /uploads/ directory. But anyway, I built the package successfully. It is 132 MB in size.

So what file do you want: Installer, Archive, or One-Click Download (see attached screenshot hh-duplicator-files).

November 18, 2019 at 3:08 pm #4966171

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I need both the archive file and the installer file. You can share a link to download them via Google Drive or Dropbox or something similar in the next reply, which I have marked as private. Thanks!

November 20, 2019 at 7:21 pm #4983541

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thanks for sending the files. I created a copy of your site locally and here is how I resolved the issue. First, I set my site to minimal settings (just Elementor and WPML plugins) but that did not resolve the issue. So here are my steps:
1. Go to WPML -> String Translation and check "Look for strings while pages are rendered". Then click Edit and DESELECT the Elementor domain.
2. Go to WPML -> String Translation and filter by the Elementor domain. I think I had just over 1100 strings, something like that. I deleted all of these. If you need to keep any translations, you can preserve the strings and only delete the ones you do not want to translate.
3. Via FTP, go to wp-content/languages/plugins/ and rename the elementor-ft_FR.mo and elementor-fr_FR.po files.

After these steps, as you can see from my screenshot, the English shows in the backend.Can you please try these steps on your live site and let me know if it resolves the issue for you?

November 27, 2019 at 5:22 am #5025907

alexanderA

Sorry for the delay. Thanks for those steps. I haven't tried them yet. But before I do so, I have a question. Is this a workaround I need to carry out for every one of my sites, i.e. every site with both WPML and Elementor installed? If so, it will be fairly tedious. Or will this perhaps be rectified in an upcoming version of WPML? On the surface, it seems like a bug that should be resolved. I'm not sure if that's done by WPML, Elementor, or a collaboration.

If this is something that might be resolved in the future, I may let it be, as-is.

November 27, 2019 at 9:16 pm #5032355

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates, Lauren is taking some days off, so, I am taking care of this ticket from now on. Let me clarify how the Elementor Page Builder strings (labels, descriptions and general interface texts) work in the website frontend:

1 - The frontend language of your website is independent of your WordPress Dashboard language. So, the Elementor Page Builder strings (labels, descriptions and general interface texts) will be loaded in whatever frontend language you are editing your content in the website frontend, if you are editing in french Elementor strings will be loaded in french, if in english it will be loaded in eglish and so on.

2 - It is a default WordPress behavior for themes and plugins, not a WPML bug at all, theme and plugins strings (texts found in theme/plugin codes) are stored in mo and po files and each file is saved as 'plugin-name-[language code]' for example: 'elementor-fr_FR.po/elementor-fr_FR.mo' for french translations, 'elementor-en_US.po/elementor-en_US.mo' for english translations and so on.

3 - When you change to the french language in your website frontend and then you click to edit your page using Elementor, the 'elementor-fr_FR.po/elementor-fr_FR.mo' language files will be loaded by WordPress, this is why you see the instructions in french if editing in french or in any other language you have chosen to edit your content.

As said this is the expected behavior and how things work with WordPress or any other localized systems that uses po files.

4 - As a workaround, Lauren recommended to rename the elementor french languages files (elementor-fr_FR.po/elementor-fr_FR.mo) via FTP and also deleting them using WPML String Translations, when doing so, your 'force' WordPress to read the english strings in theme/plugin files (english is the default language for the Elementor and most plugins available in the WordPress ecosystem) as it is unable to find the french ones due the renaming process.

5 - So, in short words, as it is a default and expected behavior for any theme and plugin that is bundled with language files, you will need to manually proceed with the steps below with any other site you have, as said it is not our fault, this is how things work as standard behavior in localized (translatable) systems, including WordPress.

Similar Tickets:

https://wpml.org/forums/topic/elementor-interface-displays-in-edited-language/https://wpml.org/forums/topic/cannot-use-elementor-in-english/#post-4617583

References:

https://developer.wordpress.org/themes/functionality/localization/

hidden link

hidden link

https://wpml.org/documentation/getting-started-guide/language-setup/setting-the-wordpress-administration-language/

Hope it clarifies your questions, have a nice day.

December 8, 2019 at 5:00 am #5088205

alexanderA

I'm hoping we can re-open this ticket. I apologize, but some things came up and I could not reply earlier.

I realize what I am experiencing is default and expected behavior. But wouldn't you agree it is undesirable behavior, and behavior that sometimes causes issues? When I switch the WPML language to Chinese, then open different admin pages in the WordPress back-end, the text on all WordPress controls/settings remains in English--it does not change to Chinese (screenshot: hidden link). This is default behavior, as well as desired behavior. Since I cannot read Chinese, this behavior allows me, the admin, to continue to make edits to the Chinese-language site. The same thing *needs* to occur with Elementor, regardless of whether it is a 'front-end editor' or not. In other words, when I change the WPML language to Chinese, the text on the Elementor controls *must* remain in English. If not, how can I, as the admin, use the Elementor controls (screenshot: hidden link cannot read Chinese.

Of course there are workarounds for this, e.g. open the English page in one tab, and the Chinese page in another tab, and cross reference the Elementor controls on both. But that is very tedious. Also, Lauren also presented a workaround, which was also a bit laborious. Wouldn't you agree this is undesirable behavior that causes issues?

Thanks.

December 12, 2019 at 7:07 pm #5118279

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I agree it could become tedious, but it is something out of our control in the WordPress ecosystem, the provided workarounds are the known and working solutions for now.

I do see your points and feel the laborious work you can have when dealing with such scenarions, but as said it is how Elementor works, it will be displayed always in the chosen frontend language. Any other workaround less tedious could involve a hack in Elementor code which is something we never recommend.

Unfortunately here is a particular case we can't do much to help as we don't have any other known alternatives, maybe the Elementor support could be of more help here. Hope you understand our points, have a nice day.

December 13, 2019 at 12:40 pm #5123367

alexanderA

>> Unfortunately here is a particular case we can't do much to help as we don't have any other known alternatives,

What about other front-end editors, e.g. WPBakery? Does the same issue occur when you use their 'front-end editor' feature? If not, why not?

>> maybe the Elementor support could be of more help here.

Before posting here, I asked them. They said it was a WPML issue. On the surface, I would have to agree.

December 19, 2019 at 6:34 pm #5165715

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. As said it was the expected behavior, and how Elementor was working, I've just installed a recent version where they seem to have fixed the issue and made Elementor loads the admin language in the frontend interface regardless the language being used, you can confirm it here: hidden link (it is a one click login) so, that being said, you just need to make sure your Elementor version is updated to the most recent version (2.8.2 in my tests) to include this fix in your website as well.

See: hidden link

Hope it helps, have a nice day.

December 24, 2019 at 5:59 am #5188337

alexanderA

Why don't you and I continue the discussion here, and I'll close the ticket with Jamal. I hope that's OK.

>> I've just installed a recent version where they seem to have fixed the issue and made Elementor loads the admin language in the frontend interface regardless the language being used, you can confirm it here: hidden link

I checked that test site, and I still see the same issue. Namely, the WPML language is Spanish, and the Elementor controls are still in Spanish (screenshots: hidden link). The Elementor controls need to be in English. Am I misunderstanding something? Also, I can no longer login to that test site you created.

Thanks.