This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by thierryG-4 3 months ago.

Assigned support staff: Bruno.

Author Posts
July 3, 2019 at 12:22 pm #4136177

thierryG-4

Hi,

We have an issue with the string translation on media, it doesn't work. As well we receive many error messages on some pages we translated.
See on this page: hidden link

At the same time, we would like to know if you can help us to set the flags on top of our pages, see example on the link attached: hidden link
This website is one of our old website and we would like the flags to appear before the header/menu .

Many thanks again for your kind support,

July 3, 2019 at 5:41 pm #4138419

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you for contacting us. It seems that the problem is happening with the fusion-core plugin.

Please, what is the version of WPML and WP are you using? I would like to know more about your installation. Can you please provide your WPML Debug information in the debug field below? http://wpml.org/faq/provide-debug-information-faster-support/

Thank you.

July 4, 2019 at 3:07 am #4139955

thierryG-4

Hi,

I sent you the debug information,
The version of Avada is 5.9.1
WP version is 5.2.2
Version of WPML is :
WPML Multilingual CMS 4.2.7.1
WPML CMS Nav 1.5.2
WPML String Translation 2.10.5.1
WPML Sticky Links 1.5.0
WPML Translation Management 2.8.6.2
WPML Media 2.5.2

Thank you for your help

July 4, 2019 at 11:15 pm #4146439

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please let me know exactly what steps should I follow to see the problem.

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

July 5, 2019 at 10:31 pm #4154079

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. I've installed All in One Migration plugin and I did a copy of your site. I will install it on my test environment and soon I will contact you.

Thank you.

July 9, 2019 at 7:23 pm #4174049

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

My sincere apologies for the delay. The problem was apparently happening because the slide category was not configured correctly in WPML > Translation Taxonomy. I'll attach an image for you to see.

Now from what I noticed the slider is being displayed correctly: hidden link

About the CSS you want to do in the menu, this will depend on how you are using those flags. At the moment, it looks like you're using a plugin other than WPML to add these flags - "Flag Icons".

It is recommended that you use WPML to add these flags. That would be even more easily adapted. You can see our step-by-step guide:

- https://wpml.org/documentation/getting-started-guide/language-setup/custom-language-switcher/
- https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

Thank you.

July 10, 2019 at 6:18 am #4176269

thierryG-4

Dear Bruno,

Many thanks for your help,

We tried to use WPML and already read the documentation. However, we were not able to do it. WPML does not seem to allow us to put it above the menu when using Avada theme.
We tried using some coding of these two articles as well but it didn't work.
It doesn't seem to be possible to put it above header menu.

Many thanks again for your help, much appreciated

July 10, 2019 at 8:49 pm #4184345

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

On your site, I added a language bar, but to be exactly as you want it - just like the one on the site you posted, you would need a lot of custom coding - please, note that custom coding is beyond the scope of our support.

- Click on the WPML > Languages > Language switcher options
- Click on the Additional CSS. I added this CSS code: https://pastebin.com/Ht9ZndMR
- Scroll down and enable the "Footer language switcher" language switcher;
- Click on the Plugins > Installed Plugins
- Disable the "Flag Icons" plugin

In the image, note that there are now two languages switchers. If you want to remove the language selector from the menu, just follow the steps below:

- Click on the WPML > Languages > Menu language switcher
- Remove the language switcher

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

July 11, 2019 at 8:03 am #4187107

thierryG-4

Hi,

thank you so much you are a real-life savior. We really appreciate your help.
What you did for us is perfect and exactly what we needed. However, when I deleted the language switcher from the main menu. The bar got centered. I would like to keep it as you did, on the right side.

Many thanks again

July 12, 2019 at 3:42 am #4194775

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

I fixed your site. I just edited the CSS that I had previously added to force the language selector to stay in the right position.

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

July 12, 2019 at 9:32 am #4197147

thierryG-4

Thank you so much Bruno for your help. You have been super useful, we are very grateful.

Have a good day