This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Variation and attributes do not sync between translation in WCML 4.6.2 Solution: the issue should be fixed with WCML 4.6.3

This topic contains 9 replies, has 2 voices.

Last updated by giladA 5 months ago.

Assigned support staff: Laura.

Author Posts
May 5, 2019 at 9:36 am #3742323

giladA

Hi. when i go to the translated version of the product, the sizes variations doesn't works.

hidden link

May 6, 2019 at 7:44 am #3745521

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

Could you try to go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link -> Select the last 2 options and click on Start button.
This should synchronize variations among languages and solve the issue.

Let me know if this helps you or if you need further assistance.

May 6, 2019 at 4:34 pm #3751193

giladA

It's doesn't helps...

May 8, 2019 at 8:32 am #3764573

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

did you try to resave both original and translation after the sync?

If this doesn't help, could you provide credentials so I can better check the issue?
If possible, it would be better a test site, since we don't perform tests on production sites.
I'll enable a private reply.

May 14, 2019 at 8:15 am #3804633

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I accessed your site but you didn't do the procedure I described.
If I access the troubleshooting page I can still see "Sync product stock quantity and status ( synchronizing min stock between translations ) 2465 left"

So please do a backup and do the procedure described here: https://wpml.org/forums/topic/issue-with-translated-product-variables/#post-3745521

May 14, 2019 at 11:16 am #3806253

giladA

I did it. believe me. and i have a backup. can you please do it for me? I could not get...

May 15, 2019 at 9:48 am #3814579

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

it seems the process is not saved. Please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Browse to the page with the issue and/or reproduce the issue (run again the process).

Locate the debug log in: /wp-content/debug.log

Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

May 15, 2019 at 3:12 pm #3818211

giladA

i can't locate the debug log. the file is not in wp-content location! what should i do? i tried to do it with plugin but there is a looot of options....

May 16, 2019 at 1:22 pm #3826233

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I searching for a possible solution I found that your issue is probably related to a known bug introduced in the latest WCML version, and which should be solved in the next version.

You could try to test this:
- enable the stock management for one variation
- set it to a value bigger than 0
- see if it's synchronized with the translation.

Another possible solution could be rollback to the previous WCML version, but this is something we haven't tested so I'm not sure it will work.

May 19, 2019 at 4:12 pm #3842035

giladA

My issue is resolved now. Thank you!