Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 3 voices.

Last updated by Laura 3 months, 1 week ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
March 22, 2019 at 10:06 am #3439009

julianC-9

I am trying to:
use WPML for the translation (Ger->Eng) of our global modules in divi. I have created a global module in Divi which I saved in the library. Afterward, I uploaded them on different sites and edited the content. For example, I created the global module "ICON Überschrift (Heading)" named "Conversion Optimierung (Optimization)". I saved this module in my library and uploaded it again multiple times in order to not formatting it every single time. I marked the content part not to be synchronized across all instances of that global module. I guess that is the meaning of the global modules. Finally, I edited the content in every single module. In fact, on my Homepage, I have created 6 Icons with the one global module "ICON Überschrift (Heading)". Each Icon, therefore, has the same format but different text. Screen attached.
Link to a page where the issue can be seen: hidden link

I expected to see: https://wpml.org/documentation/theme-compatibility/divi-builder/#translating-divi-global-items
I looked up the resolved thread but it is not working in my case.

Instead, I got: When I navigate to DIVI -> DIVI Library I am not getting the text, only the class as a translation. Screen attached. Same when I use the Translation Editor on the page. I cannot translate anything that is inside a global module. Screen attached.

I already translated all my content before I switched Divi Modules and everything worked out. Please help me to figure out how to translate the global modules, where and how I can use my already existing translated content...

ICON Heading 2.png
ICON Heading 1.png
Divi Library.png
Divi Builder . Hompage.png
March 22, 2019 at 1:21 pm #3440513

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, and thanks for contacting our support forum.

This issue has been escalated to our developers, and it is prioritized, but I don't have the exact ETA for the fix, and we don't have a workaround for this right now, so we have to wait for our developers to fix it and I will update you if I got any news.

Best Regards.

March 22, 2019 at 1:56 pm #3440895

julianC-9

Hi Ahmed,

thanks for the quick reply. Although, your answer does not help much. I have spent so much time during the whole week in your support forum, trying out different things and translating all my content. Now everything is gone and I can not wait until someone fixes it some day.
I need an asap solution - for my part an 80% solutions is fine. I just read that you could fix it on my site until you found a general workaround.
Please solve the issue either way.

I still need assistance in re-delivering the translated content and translating global modules.
If you need access to my site, please let me know.

March 22, 2019 at 2:44 pm #3441467

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Maybe you miss-understood the message from Amit here: https://wpml.org/forums/topic/continues-issues-with-wpml/#post-3438803, please check my last comment and you will see that I also told John to wait for the developers fix.

The Divi issue is complicated as it is in the core and should be resolved by the dev team to grant that the fix will not affect any other parts, and as I mentioned before the issue is prioritized and the fix should be available soon.

I asked the other client to give me his site copy to debug another issue, the client is using a translation service to translate his content, and he lost the translation after updating the original post, so do you have a similar issue?

Best Regards.

March 22, 2019 at 3:39 pm #3442027

julianC-9

Hi,

ja, maybe I understood it wrong. This translation is driving me crazy and I thought there would be a quick fix with your help.
Our due date is the first of April, so it is kind of important. I am waiting for the solution then.

As I mentioned before, I translated all the content from German to English. Since I changed the modules to global modules all the English translations are gone. Can I find them somewhere or can you re-deliver them?

Thanks in advance.

March 22, 2019 at 3:44 pm #3442051

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Do you have any backup to these modules before changing the module to be global?
Have you translated them locally or using a translation service?

Best Regards.

March 22, 2019 at 3:57 pm #3442101

julianC-9

I am afraid I did not back up the modules an I do not have a clue how this is working.
I used the translation service.

Best regards

March 22, 2019 at 4:48 pm #3442579

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

If you are using a TS, so there could be a chance that I can re-deliver the translation again, so please send me your credentials at the next private reply and let me know which jobs exactly should be re-delivered and I will check it.

Best Regards.

March 25, 2019 at 9:07 am #3450657

julianC-9

Hi Ahmed,

do you have any update?

March 25, 2019 at 12:32 pm #3453505

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

I have checked your site, and as I can see that you haven't used any Translation Service, you can find more about the translation services: https://wpml.org/translation-service/
all I can see that you have translated your site using local translators, can you please confirm?

If you used local translators, it could be hard to retrieve your translations again, because the TS saves the translations in XLIFF files, but this doesn't happen when using local translators.

I will check with our compatibility team if they know any procedure that could help to retrieve your content and I will update you.

Best Regards.

March 25, 2019 at 4:36 pm #3456391

julianC-9

Hi Ahmed,

you're right. We haven't used any translation service. Misunderstanding.
I am using your plugin and all the content is translations. That must be saved somewhere, right?
Especially when I did not delete those translations. I just changed the module.

What about all the slugs, etc.?
I am looking forward to your solutions.

March 25, 2019 at 6:38 pm #3457361

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Let us say that you have created a global module and translated this global module using our translation service, and you added this global module to some pages, the translation will appear as expected, but once you make some fields to be selective the translation will not be applied to the selective element, so that is why you lost the translation, and I think if you returned the element to not be selective again most probably you will get the old translations again if they still exists for the main global module.

There was an open discussion about this issue between the dev and compatibility team, and they are going to fix the issue but the fix will not be included in the next version, because the fix will be complicated and they will not be able to delay the next version because it has some important features that should be released soon.

So, for now, our compatibility team are making a small errata to state that you can't translate the selective fields using our translation editor, and you can only translate them using the manual translation editor, so you have to go to the original page and switch the language using the language switcher at the top bar, then translate the selective fields directly in the normal WP editor.

I will send you the errata once it ready and will update you about the actual fix when I get any new information about it.

Please let me know if you have any questions.
Best Regards.

March 26, 2019 at 12:00 pm #3462053

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Here is our errata: https://wpml.org/errata/divi-selective-sync-global-modules-cannot-be-translated/

Best Regards.

March 27, 2019 at 10:58 am #3469897

julianC-9

Ahmed,

it still does not work. When I edit the translations manually as you described in the workaround the global modules change back to normal modules.
To summarize the problem:
Either way, I create global modules to automate changes in no time but the language will be in German only or I will have a global website with multiple languages but no global modules. This cannot be the case, right?

March 27, 2019 at 12:21 pm #3470911

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Here is our errata about this: https://wpml.org/errata/divi-selective-sync-global-modules-cannot-be-translated/

So are you making manual translate for the global module or for the page that uses the global module?
you should make it for the page that uses the global module, and if you already tried this, please send me the link of the page and I will check it.

Best Regards.