Please make sure to update to WPML to the latest and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Ahmed Ibrahim 4 years, 9 months ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
April 27, 2015 at 3:17 pm #607060

antonioM-2

My sites default currency is Euros. After activating the multi currency option and set custom prices for my products in Pounds, the products now list without tax. Even though the woocommerce setting is set to show tax on product pages, they show as excluding tax. This only happened after activating multi currency.

Also, when the English language is selected, i need customers to be able to view the Euro price too ( for Irish customers who speak English but pay in Euros),however when I test this on a product page, the price does not change into Euros, it just stays in pounds.

April 27, 2015 at 3:54 pm #607088

antonioM-2

FYI I am using the plugin WP Rocket for my sites caching

April 27, 2015 at 4:00 pm #607098

antonioM-2

I deactivated the WP rocket plugin which has sorted out the currency switching problem on the product pages. However my issue with prices showing without tax still persists.

Thanks

April 28, 2015 at 3:04 pm #607994

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Thank you for contacting WPML support forum.

I have reproduced your issue with my text site using this steps:

First go to Woocommerce -> Settings -> tax (tab), choose "Enable taxes and tax calculations" to enable tax for my eCommerce, at "Prices Entered With Tax " choose "No, I will enter prices exclusive of tax", and at "Display Prices in the Shop:" choose "Including Tax", then save changes.( see woocommerce_tax_settings.png and standard_rate.png )

Then go to WPML -> WooCommerce Multilingual -> Manage Currencies , then choose "Multiple currencies, independent of languages" and configure your currencies .(see multi_currency_settings.png).

Then go to the product page , navigate to "Product Data" section at the general tab configure your prices , set the "Tax Status" to be "Taxable" and "Tax Class" to be "Standard".(see product_as_taxable.png)

Then when visit the product page the price is shown with taxes (see product_view_page.png and product_page_in_dollar.png and cart_page.png)

As you see the problem didn't occurred with my site, if I'n not understanding your problem well, or you have made this steps and your problem still exist please let me know, because it may be a bug within your system.

Thanks.

April 28, 2015 at 6:25 pm #608181

antonioM-2

Thanks for this Ahmed. The only difference in my set up compared to the one you just explained is that i had my "Prices Entered With Tax " set to yes. Once switching to no, this did sort the price issue, but then it added the VAT on at checkout (on top of my price already inputted with vat), which consequently made it more expensive that it should be.

Are you suggesting I enter all my prices without VAT for your setup?

I disabled the multi currency feature for now, in the hope for things to go back to normal, but now my prices are still showing without vat, even with "Prices Entered With Tax " set to yes and "Display Prices in the Shop:" set to "Including Tax".

April 29, 2015 at 7:54 am #608488

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Thank you for your reply.

I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

+ Please make sure that you have a full backup of your website and database. (Please don't ignore this)!
+ It'd be great if you give me an access for a test site where the problem is replicated.

April 29, 2015 at 2:22 pm #608935

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi antonioM-2,

From what I see from your site take this product as example :
hidden link
hidden link

You have entered it's price to be "12.45€", and when visit the product on the site
If the configuration of woocommerce tax is "Prices Entered With Tax" to be "yes" , and "Display Prices in the Shop" to be "including tax".
The price is shown as "10.38€" and with your configuration , you are expect to see it "12.45€", on the front end.

If the configuration of woocommerce tax is "Prices Entered With Tax" to be "no" , and "Display Prices in the Shop" to be "including tax".
The price is shown as "12.45€" and with your configuration .

Could you please try to use one of the default themes "Twenty Fourteen as example" with WCML deactivated , and see if the problem still exist.

If i have understand your problem wrong, please correct me.

May 6, 2015 at 7:29 pm #613540

antonioM-2

Hi Ahmed,

What you said is correct. I have now carried out your instructions and the prices do seem to go back to normal when I switch to one of the default themes.

Antonio

May 7, 2015 at 12:06 pm #614075

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi antonioM-2,

So do I understand this correctly ? that when you switched to one of the default themes every thing goes fine , but when you are activating your original theme the problem appears again .

May 7, 2015 at 1:22 pm #614180

antonioM-2

Yes that it correct.

May 7, 2015 at 7:38 pm #614507

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

OK it seems that it is a compatibility problem between your theme and WPML , but we need one more test to make every thing clear , we have tried WPML , Woocommerce and WCML with the default theme and it works well .

Now we need to test your theme with Woocommerce without any of WPML or WCML plugins, and see what will happened.

Thanks a lot.

The topic ‘[Closed] Issues with Multi Currency’ is closed to new replies.