This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by Andreas W. 3 months, 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
June 6, 2019 at 12:09 pm #3969063

musaba-2

My site started showing server error 500, then I increased the Wp memory, But there was a loop in the Arabic version of the website.

Then And after increasing the memory and changing the WPML settings when it comes to permalinks formats

( from hidden link to hidden link)

After that, the site was fixed but the Arabic home page is showing Error 404, so I redirected the home page and it's experiencing slow load now!

Please help me fix this as the site is built now and most of the e-commerce related pages are linked to /ar not the other format.

Thank you

June 6, 2019 at 6:50 pm #3971663

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

Do I understand right, that the 500 error disappeared after changing the URL structure? Could you please provide me more infirmation about the error message?

Do you receive any failure messages at WPML -> Languages -> Site URL Structure when trying to set the option to language in directories? If so, this might be a server configuration issue.
https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/

Further, 404 erros should ususlly be solved after simply going to Settings -> Permalinks and clicking the save option. No manual redirecting necessary.

Let me know if you need further assistance.

Kind regards
Andreas

June 9, 2019 at 4:52 am #3982343

musaba-2

Hi Andreas,

Greetings.

!st issue is that the flags are not showing (disappeared) from all pages.

And at the Arabic home page, it loads really heavy!

Also f you could please advice what are the best practices for structuring an Arabic woo commerce site in the feature?

Thank you

Regards.

Mo

June 10, 2019 at 5:45 pm #3989289

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

June 12, 2019 at 8:34 am #4001937

musaba-2

Hi Andreas,

Greetings.

Thank you for your support, sure thing I would love to give it a try but wouldn't be better if we created a stage and try editing on it?

I am familiar with the plugin Duplicate and it's already installed but don't you think we should try on staging to check rather than trying on the live site?

Thank you for your support

Regards.

Mo

June 12, 2019 at 6:01 pm #4006829

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello Mo,

It would be perfect if you could provide access to a staging site!

Thank you in advance.

Kind regards
Andreas

June 18, 2019 at 12:34 am #4039041

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Sorry for the delay but I had an unexpected expanded workload today. I just realized that you asked me to provide my email.

Would you prefer that I avoid using the provided account information? I have enabled the private message box again for providing access again.

My email is:

andreas.w@onthegosystems.com

Kind regards
Andreas

June 19, 2019 at 10:36 am #4050759

musaba-2

Dear Andreas,

Greetings.

Thank you for your reply and here i created an account for you on WPEngine, Please let's not do work on the live site, There is a staging or feel free to create another one if you prefer.

Waiting for your feedback.

Thank you

Regards.

Mohannad

June 19, 2019 at 3:29 pm #4052837

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have just send you a private message in order to migrate your site to our test server for further debugging.

Please leave me a short notification once the migration is completed.

Kind regards
Andreas

The topic ‘[Closed] Issues with my plugins’ is closed to new replies.