This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 22 replies, has 3 voices.

Last updated by Shekhar Bhandari 3 months, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
June 15, 2019 at 4:52 pm #4028515

nicolasF-29

I am trying to: Send a test translation following a new install of WPML.

Link to a page where the issue can be seen:

hidden link

I expected to see:

The entire page translated, only a few bits were...

-----

So I paid for a translation of this page:

hidden link

And the translation came back with not even 20% of the content translated. I've attached a screenshot of the translation. The headline and boxed content is in French, the rest is not.

Also, is there a way for the new translation NOT to be published before I can review it? This was pushed live, and I need to make sure the SEO slugs are ok (they weren't).

Thanks!

Nicolas

June 15, 2019 at 5:51 pm #4028717

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I checked the issue but I need to do some tests. I think yours is a live site so it would be better not to do them there. Do you have a test site by any chance?
If not, would be possible to take a copy?

June 15, 2019 at 6:39 pm #4028753

nicolasF-29

Yes it's a live site. Sure make a copy.

June 17, 2019 at 2:45 pm #4036289

nicolasF-29

Hi,

This seems like an insane amount of work for something that should work straight out of the box...

June 17, 2019 at 8:59 pm #4038733

nicolasF-29

I sent the migration.

I think the main issue is that on some posts, the "body" doesn't get pushed to the /wp-admin/admin.php?page=wpml-translation-management%2Fmenu%2Ftranslations-queue.php page. It's missing. See attached.

So that's why on the page I tested on none of the regular content was translated.

On some other posts it shows fine so I expect that on these everything would be fine if I sent it through the iCanLocalize service.

Nicolas

June 18, 2019 at 9:56 am #4042339

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I think it might be a workflow issue since some pages seem to be built with Fusion Builder while others don't.

Do you have a link for a post/page that returns everything in the Translation Editor?

June 18, 2019 at 12:05 pm #4043695

nicolasF-29

-- These are showing the "body":

6 "Overlooked" Ways to Make Your Ecommerce Store Stand Out
6 Ways to Optimize Your Ecommerce Product Page Conversions

( I think where there are no alert boxes or fusion boxes it seems to work fine.)

-- These are not showing the "body" but the entire content is in the field "wpml_string_wrapper: content":

7 Conversion Mistakes Most Startups & Fortune 500 Make Every Day [OMP 002]
5 Types of Blog Posts That Can Rank & Go Viral - Especially If You Hate Writing [OMP 003]

-- These are not showing the "body" AND the entire content is NOT in the field "wpml_string_wrapper: content". It's only partially there (only a box) :

ClickFunnels Review: 2,200% More Leads from ONE (Simple) Funnel

-- These are NOT showing the "body" AND there is NO field "wpml_string_wrapper: content":

How To Create a High-Converting Optin Page with ClickFunnels
The Ultimate Real Estate Agent Website Guide [2018]

June 18, 2019 at 3:59 pm #4045067

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

as I said, I think there is a workflow issue here and now that I had the various kind of posts I have a clearer picture.

Your theme Avada comes with a page builder, Fusion Builder. However, you are using the Classic WordPress editor. You can see if you go in Posts -> All posts, there is the writing "- Classic Editor" after each post's name.

When you use the Classic Editor, the post content goes in the "body" in the Translation Editor.
When you use Fusion Builder, "wpml_string_wrapper: content"

Now, with the post ClickFunnels Review: 2,200% More Leads from ONE (Simple) Funnel, you started writing with the Classic Editor, but then later you added content using the Fusion Builder editor.
I can see it from Revision History, on the version from 16 Aug @ 14:35 it appeared some contend wrapped inside [fusion_content_boxes].
This explains why you only got partial texts picked up. What I did in your test site is to enable the Fusion Builder so that all the content uses it, and I saved it. Now if I try to open the Translation Editor for any language I can see ALL the content picked up.

As for How To Create a High-Converting Optin Page with ClickFunnels
The Ultimate Real Estate Agent Website Guide [2018], I think the issue is the same because I can see that some content is wrapped in shortcodes and the rest is not, so enabling Fusion Builder should solve this too.

Could you test it and see if it works? If you can see all the content in the Translation Editor, you shouldn't have issues when you send it to your translator.

June 19, 2019 at 2:35 am #4047267

nicolasF-29

That worked, all the content is now on the Translation page.

Now, what do I have to do to have the rest of that page translated? I don't want to pay for the content already translated on the first run.

Thanks!

Nicolas

June 19, 2019 at 8:24 am #4049523

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Since Laura currently has a few days off, I will replace her here in the forum. I hope this is OK for you 🙂

You will not be charged for already translated content, so when you send the updated content only the content that needs to be updated will be chargeable.

Let me know if this helps.

Thanks

June 19, 2019 at 10:46 am #4050813

nicolasF-29

Ok thanks,

A few questions:

- Is there a way to prevent a new translation to be automatically published following the completion of the work? Last time when the translator completed the job in Translation Management, the French translation was pushed live, and I'd prefer to review everything before that.

- Is there a way to move the "This post is also available en Français" at the top of the post to the bottom of it?

- How do I get automatic translations for some languages? For example, for major languages I'll have iCanLocalize do them as I want quality. But for some languages, I might prefer not to have to pay, how would I do that? Can't seem to find out how...

Thanks!

Nicolas

June 19, 2019 at 11:16 am #4051039

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

#1
Go to WPML->Settings->Multilingual content setup -> Translated documents options and set Document status to draft.

#2
Yes, go to WPML->Languages->Links to the translation of posts -> Edit the current one and select Position of the link(s): to above post.

#3
https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/how-automatic-translation-works/

Let me know if this helps.

Thanks

June 19, 2019 at 3:40 pm #4052917

nicolasF-29

Thanks,

So how do I resend the French translation to IcanLocalize? At the moment French indicates "in progress"...

June 20, 2019 at 4:13 am #4056499

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

"in progress" means the job is being translated, so here are the steps to send the updated content.
- Complete the "InProgress" Job first, you can cancel it too, I recommend completing the job first.
- Once completed, send the job again for translations for Icanlocalize.

Let me know if this helps.

Thanks
-

June 21, 2019 at 3:21 pm #4068005

nicolasF-29

Hi,

Looking at the translation dashboard, I have many translations that are started but I don'T know why. The only translation I actually paid for is the one for French in the rectangle.

And that one is stuck because the iCanLocalize team has finished their work.

This is very confusing to me when it should be simple.

Your system seams to be great once the translation process is started. But gheez this is not an easy thing to figure out...

So...

How do I send a new translation or a request to update an existing translation to the iCanLocalize team?