This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: It does not allow us to copy the content of Spanish version into English and PT

Solution: I have change the settings of the Elementor custom fields related to the layout from 'Not translate' to 'Translate' in WPML -> Settings -> Custom Fields Translation

Relevant Documentation:

This topic contains 9 replies, has 2 voices.

Last updated by Carlos Rojas 2 months, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 1, 2019 at 3:30 pm #4323481

javierR-19

I am trying to: copy the content from the ES page to the EN and PT page. As I could not copy it I have updated the versión of the plugins and now it does not even let me to edit the page of EN and PT

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

August 1, 2019 at 6:34 pm #4324811

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- Please describe the steps to reproduce the issue. Attach some screenshots so I can have a better understanding.

2.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Kind regards,
Carlos

August 2, 2019 at 5:00 pm #4331709

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por la información suministrada.

En este caso me gustaría pedirle que realice los siguientes pasos:
- Cree una copia de seguridad del sitio completo.
- Borre cualquier memoria cache que pueda existir.
- Desactive todos los plugins excepto los de WPML y Elementor.
- Sigue los pasos descritos en este enlace: https://wpml.org/documentation/plugins-compatibility/elementor/
- Re-activa todos los plugins.

Me puede decir el resultado de los pasos anteriores?

Nota: Si necesita comprar otro paquete de WPML puede hacerlo en esta página: https://wpml.org/purchase/

Saludos cordiales,
Carlos

August 6, 2019 at 7:04 am #4344619

javierR-19

Buenas Carlos,

el problema persiste. No me deja subir pantallazos de lo que esta sucediendo.
Al sobre-escribir el contenido el EN y PT, no copia el formato de Elementor marcado en ES, lo incluye todo con texto y las imágenes no las copia.

Necesito comprar una nueva licencia pero no sé sustituir el Key en mi sitio web para dejar de usar la antigua cuenta.

Un saludo

August 6, 2019 at 11:30 am #4346777

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por su respuesta.

He visitado la página que me indicas y se muestra correctamente en todos los idiomas. Te pido que me indiques una página donde pueda ver el problema sucediendo.

Con respecto al cambio de key. Cuando compras una cuenta nueva tienes que introducir la URL del sitio para obtener la key, lo que significa que tienes que eliminar el sitio de la cuenta actual e ingresarlo en la cuenta nueva. Luego puedes cambiar la key sin ningún tipo de problemas.

Saludos,
Carlos

August 6, 2019 at 1:57 pm #4348027

javierR-19

Buenas Carlos,

Disculpa por que la hemos tenido que hacer a mano.
Si quieres, puedes comprobarlo en Entradas-> Turomas in the world brad glass
En esa puedes comprobarlo.

¿No pasara nada al eliminarlo de la cuenta, no perderemos archivos o traducciones?

Un saludo

August 6, 2019 at 2:22 pm #4348305

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por su mensaje.

He aplicado varios cambios a la configuración de los campos personalizados de Elementor y el problema ha desaparecido. Puede comprobarlo en la entrada hidden link

Saludos cordiales,
Carlos

August 6, 2019 at 2:33 pm #4348499

javierR-19

Hola buenas tardes,

Muchas gracias por la ayuda, pero todavia no nos deja editarlo en Elementor. Si compruebas esa misma entrada en Ingles no te deja acceder a la pantalla de Elementor y se queda en la pantalla que adjunto.

¿Tenéis disponible algún teléfono de contacto?

Un saludo

August 6, 2019 at 2:51 pm #4348877

javierR-19

My issue is resolved now. Thank you!

August 6, 2019 at 3:24 pm #4349101

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Por favor no dude en contactarnos si necesita de nuestra ayuda en el futuro con WPML.

Saludos cordiales,
Carlos