This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 3.22 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: PHP Catchable fatal error: Argument 1 passed to WPML_Term_Adjust_Id::filter() must be an instance of WP_Term Solution: the issue was resolved by upgrading WordPress the latest version.

This topic contains 29 replies, has 2 voices.

Last updated by Bruno Kos 4 weeks, 1 day ago.

Assigned support staff: Bruno Kos.

Author Posts
September 9, 2019 at 10:22 am #4535911

Joel Alain

Hello Dear Support Team,

I have renewed my account and downloaded the latest version of WPML. After uploading the plugin into my website hidden link, an error occurs by trying to activate the plugin. Also the plugin "AppThemes WPML Bridge" could no more be activated. The theme I am using is Classipress and the version of WordPress is 4.2.24.

Thanks in advance for your help!

Best regards
Alain

September 9, 2019 at 11:44 am #4536723

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi Alain,

Thank you for contacting WPML support!

Can you tell me if there is a reason why you are using very outdated version of WordPress? There have been significant improvements since that version, while some of these fixes and performances also impact how WPML will work. There have also been security updates and fixes, so I have nothing else to suggest but that you update it all. In July

Even though it is above our minimum requirements - https://wpml.org/home/minimum-requirements/ - I definitely suggest that you update WordPress, theme and other plugins you may be using.

Regards,
Bruno Kos

September 9, 2019 at 11:53 am #4536769

Joel Alain

Hi Bruno,

thanks for your prompt reply. I have taken a look at your minimum requirements and seen that the version of WordPress should be at least 3.9. My wordpress version is 4.2.24 and should not be the source of the problem. I have deactivated all plugins except wpml but it still not works.

Best regards
Alain

September 9, 2019 at 11:58 am #4536811

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced.

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Reproduce the issue - try activating the plugin.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

https://codex.wordpress.org/Debugging_in_WordPress

Also, can you provide debug information so I could get a better view of your current setup? I have enabled debug information for this ticket and this is how you can easily provide this info:
https://wpml.org/faq/provide-debug-information-faster-support/

Regards,
Bruno Kos

September 9, 2019 at 1:21 pm #4537573

Joel Alain

Hi Bruno,

thanks again. I did exactly what you said but I cannot see the file debug.log in the directory /wp-content/

Best regards
Alain

September 9, 2019 at 4:00 pm #4538799

Joel Alain

Here ist the message that appears in the admin dashboard:

Warning: require_once(/data/web/e37767/html/apps/wordpress-covoiturage/wp-content/plugins/sitepress-multilingual-cms/vendor/composer/autoload_real.php): failed to open stream: No such file or directory in /data/web/e37767/html/apps/wordpress-covoiturage/wp-content/plugins/sitepress-multilingual-cms/vendor/autoload.php on line 5

Fatal error: require_once(): Failed opening required '/data/web/e37767/html/apps/wordpress-covoiturage/wp-content/plugins/sitepress-multilingual-cms/vendor/composer/autoload_real.php' (include_path='.') in /data/web/e37767/html/apps/wordpress-covoiturage/wp-content/plugins/sitepress-multilingual-cms/vendor/autoload.php on line 5

Best regards
Alain

September 10, 2019 at 5:34 am #4541933

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I found one example of this error:
https://wpml.org/forums/topic/site-fails-to-load-upon-updating-wpml-multilingual-cms-plugin-to-latest-version/#post-3762857

What client did is probably that they removed the plugin and installed it back again. Can you try the same?
https://wpml.org/account/downloads/

Or, can you grant me FTP/cPanel and WordPress info in case it isn't working, so that I can checkmyself?

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

September 10, 2019 at 8:35 am #4543047

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I was able to activate WPML - however, WPML coupled with either translation management or string translation is not working. Whenever I activate any of the later, I get Error 500.

However, this error means that the issue is happening on the server level, before it even reaches WordPress. This is why debug.log is not showing up, because the error happens even before it can generate debug log. However, server logs should contain information about the issue.

I do think that there is something related to permission issues. When I tried installing translation management directly through dashboard, I received the following:

[php]
Unpacking the package…

Installing the plugin…

Could not copy file. /data/web/e37767/html/apps/wordpress-covoiturage/wp-content/plugins/wpml-translation-management/classes/notices/translation-jobs-migration/class-wpml-translation-jobs-migration.php

Plugin install failed.
[php]

Even though I installed them all through FTP directly now, it is still not working. Therefore, can you reach your hosting support and ask them what is happening, what are server logs saying? You can emulate the same behavior by activating either translation management or string translation when WPML is active. One of these combinations will trigger error 500, while you can get the website back online by renaming /plugins folder into something else, opening plugins page in dashboard and then renaming /plugins back to default state.
hidden link

Let me know how it goes!

Regards,
Bruno Kos

September 10, 2019 at 9:02 am #4543417

Joel Alain

Hi Bruno,

do you think, a solution for that could be to upgrade the php version because the site is actually running with php 5.6?

Best regards
Alain

September 10, 2019 at 9:12 am #4543509

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I don't think it would make a difference (I may be wrong about this, though). In any case, a better approach would be to find out what's behind Error 500, something we can only find out by checking server logs.

Regards,
Bruno Kos

September 12, 2019 at 2:08 pm #4561559

Joel Alain

Hi Bruno,

I have contacted my hosting and it was possible to obtain the php_error.log file directly from the cpanel of the hosting. How can I send you the file?

Best regards
Alain

September 13, 2019 at 6:34 am #4565873

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you paste only the latest lines here, such as the latest 20 lines where there should be some information about other error itself? On the other hand, you could also use for example dropbox and upload the file there so that I could download it. You can paste the link here - most of the links posted here will not be visible for public, only for WPML supporters and you.

Regards,
Bruno Kos

September 13, 2019 at 6:44 am #4565885

Joel Alain

Hi Bruno,

is it not possible to send you the file per mail?

Best regards
Alain

September 13, 2019 at 7:35 am #4566123

Joel Alain

I have sent you an email with the log file.

Best regards
Alain

September 13, 2019 at 7:42 am #4566171

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I received an email and I can see the following inside and this is what is causing all the trouble:

[12-Sep-2019 14:04:24 UTC] WordPress database error Table 'u34463db7.kdlkb_icl_string_packages' doesn't exist for query SELECT CONCAT(kind_slug, '-', name) FROM kdlkb_icl_string_packages...

In other words, for some reason the table "kdlkb_icl_string_packages" got deleted from your database. There are couple of options we can try here:

1) do have a full backup of the site before you updated plugins? if yes, I suggest you try restoring maybe on your localhost or on any of the subdomain you could create on your host. After you restore it, try checking whether this table is there, or it may have been deleted even before, but I'm not sure about this, because otherwise the site would not be working already.
2) you could try re-creating the table by trying any of the following:

- https://wpml.org/errata/missing-_icl_strings-_icl_string_translations-data-tables/
-- Try following "Workaround" you see here, so adding some code into functions.php
- You could also try this, but I think we already tried it and it didn't work:
-- https://wpml.org/forums/topic/table-toplove_db-wp_icl_string_packages-doesnt-exist/#post-4228047
- The third and last option we have at our disposal is the following:
-- https://wpml.org/forums/topic/icl_string_packages-doesnt-exist/#post-4100747

It is about running this query directly on your database, but not before making a backup or trying this on your localhost installation first. Of course, you would need to change the prefix of the table (I did this already, though). So in your case, something like this could work:

--
-- Table structure for table `kdlkb_icl_string_packages`
--
 
CREATE TABLE IF NOT EXISTS `kdlkb_icl_string_packages` (
  `ID` bigint(20) unsigned NOT NULL,
  `kind_slug` varchar(160) COLLATE utf8mb4_unicode_520_ci NOT NULL,
  `kind` varchar(160) COLLATE utf8mb4_unicode_520_ci NOT NULL,
  `name` varchar(160) COLLATE utf8mb4_unicode_520_ci NOT NULL,
  `title` varchar(160) COLLATE utf8mb4_unicode_520_ci NOT NULL,
  `edit_link` text COLLATE utf8mb4_unicode_520_ci NOT NULL,
  `view_link` text COLLATE utf8mb4_unicode_520_ci NOT NULL,
  `post_id` int(11) DEFAULT NULL,
  `word_count` varchar(2000) COLLATE utf8mb4_unicode_520_ci DEFAULT NULL
) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_520_ci;
 
--
-- Indexes for dumped tables
--
 
--
-- Indexes for table `kdlkb_icl_string_packages`
--
ALTER TABLE `kdlkb_icl_string_packages`
  ADD PRIMARY KEY (`ID`);
 
--
-- AUTO_INCREMENT for dumped tables
--
 
--
-- AUTO_INCREMENT for table `kdlkb_icl_string_packages`
--
ALTER TABLE `kdlkb_icl_string_packages`
  MODIFY `ID` bigint(20) unsigned NOT NULL AUTO_INCREMENT;

Regards,
Bruno Kos