This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Carlos Rojas 1 month, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 29, 2019 at 1:25 pm #4481363

edens

I am working on my website for 2 weeks just to translate everything and solve all the language problems,

And now i see that all strings are back to main language!
when i am in my checkout page all the strings are english,
in footer all strings are english,
something is not working correctly and not showing the translations plz help me out

August 29, 2019 at 1:31 pm #4481389

edens

Now all is back to normal but it is very weird!!!
Every few days its like something is going wrong with all the translations for limited time,
and then all back to normal

Can you explain me why is it happening?

August 29, 2019 at 1:48 pm #4481479

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

Could you check if there is some cache memory on the site or on the server side?

Kind regards,
Carlos

August 29, 2019 at 1:49 pm #4481485

edens

I have cleaned cache in website by WP rocket plugin,
is there any other cache i should clean?

August 29, 2019 at 2:04 pm #4481611

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Maybe there is a cache on the server side. If it exists your hosting providers can help you flush this cache memory.

Also, I would like to ask you to follow this steps:
- Create a full backup of the site.
- Go to WPML -> Support -> Troubleshooting link -> Apply the troubleshooting steps highlighted in the attached image.

Regards,
Carlos

August 29, 2019 at 2:40 pm #4481809

edens

and about this troubleshoot?
what do you recommend?

August 29, 2019 at 7:39 pm #4483265

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

You can apply those troubleshooting too, but please first apply the first ones, double check and if the issue persist apply the ones from Woocommerce Multilingual (the ones in your previous attached image).

Regards,
Carlos