This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by daniC 3 years ago.

Assigned support staff: Bobby.

Author Posts
March 28, 2017 at 4:17 pm #1241628

daniC

Hi ,

My pages and menu are properly translated and ready to use. But unfortunately, no matter which language I want my website to switch to, it will just reload to my default language which is English.

After that I noticed in the WPML options under Language URL Format, there is an error message that says “It looks like languages per directories will not function.”.

This can be a result of either:
• WordPress is installed in a directory (not root) and you're using default links.
• URL rewriting is not enabled in your web server.
• The web server cannot write to the .htaccess file
How to fix
When WPML accesses /fr?____icl_validate_directory=1 it gets:
A valid URL was not provided.
The expected value is:
<!--hidden link;

I want to mention that my permalink is at the default option (Post Name) and that I’m using WPML version 3.6.3 and WordPress 4.7.3.

Thanks,

Jeff

March 28, 2017 at 11:04 pm #1241850

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Thank you for contacting WPML Support,

1. Go to WP-> Settings->Reading - using the wp-admin top bar switch your language to the secondary (FR) and make sure that the front page is set to the translated homepage under the secondary

2. As a test may I kindly ask you temporary switch to a default theme such as twenty16 and let me know your results , are you able to switch to your secondary language ?

March 29, 2017 at 4:56 pm #1242623

daniC

Thanks for the reply Bobby.

Unfortunately, both steps did not fix the issue. Under (FR) language -> Settings -> Reading - the front page was already set to the translated homepage (Accuiel). I switched themes and chose Twenty Seventeen theme. Once activated, the flags on the right side of the menu weren’t even clickable and the error message “It looks like languages per directories will not function” was still present under the language URL Format settings.

I hope to hear from you soon.

Thanks!

March 29, 2017 at 6:34 pm #1242699

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Thank you for updating me !

Please note that this error " looks like languages per directories will not function" is often a false negative. If the warning is true the front end will result in a blank page or a 404 page.

As a test switch for a momemnt to "Languages as a parameter" and let me know your results

Also which host are you currently using ?

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

March 29, 2017 at 7:31 pm #1242724

daniC

Hi,

The setting for Language URL Format has always been “Language as parameter” because when I try “Different languages in directories” the website wont even open, with a message saying: “The piuchedolci.com page isn’t working - piuchedolci.com redirected you too many times”.

I tried backing up my website with duplicator and it gave me an error message and could not backup the website. So, I went with BackWPup which is the plugin I’ve used for all my other websites, and that also didn’t work, which is a first for me.

[removed by admin ]

Thanks,
Jeff

March 29, 2017 at 8:49 pm #1242768

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi Jeff,

if you go to hidden link , the page exists.

This issue might be related to your host.

We had similar issues reported with clients using GoDaddy

Please look within your database and check if wp_options "home" field is empty

You will need to make sure in wp_options "home" field is not empty and this will fix the issue

In wp_options there is the site_url field and the home field both should contain your sites URL.

March 30, 2017 at 9:37 pm #1243807

daniC

Thank you so much. Your solution worked.

March 31, 2017 at 2:53 pm #1244480

daniC

Hello again,

So the issue is NOT fixed. I dont understand how it worked for a bit yesterday and not anymore.

I want to make sure I did everything correctly in the back-end of the database so I am attaching a screen capture of what it looks like now. I am not very knowledgable with all this back-end database stuff, so I tried my best to understand your instructions.

Please let me know if I need to change anything else.
I added the "site url link" to both the "site_url field" and the "home field".
AM I MISSING SOMETHING???

I am so frustrated and discouraged right now. I need to finalize my site and this is really delaying everything ;(

Thanks for your help.