Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by Jordi Romeu 2 years, 3 months ago.

Assigned support staff: Bobby.

Author Posts
August 29, 2017 at 2:54 pm #1353504

Jordi Romeu

I have WordPress and WPML installed in a server I have no full control. Have only acces to ftp and mysql, but no control panel or cpanel.

I had WPML installed with 2 languages (catalan and spanish). I want to install a third language (french).

I can access correctly to the catalan and spanish versions:

hidden link - catalan
hidden link - spanish

But I can't access french version:

hidden link

I've translated the home page but can't access its url.

In WPML -> Languages -> Language URL format there's the red message "It looks like languages per directories will not function.".

Clicking on details it says:

When WPML accesses hidden link it gets:
cURL error 60: Peer certificate cannot be authenticated with known CA certificates

But when I access that url from my browser it does not show this error. I see this on code source:

<!--hidden link;

Maybe there's some kind of problem with the SSL certificate and WPML to check the directory working ok?

Thansk for your support.

August 29, 2017 at 4:45 pm #1353627

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Thank you for contacting WPML Support,

When i visit your site i was able to see it as expected on the /fr/ directory as well as the other ones.

The specific warning a lot of times can be a false negative. If you are able to see the home page with no errors 404 , or a blank page then it is most likely a false negative warning.

August 29, 2017 at 8:49 pm #1353798

Jordi Romeu

Hi Bobby,

Woow... Yes! I can see it when I'm not logged in. But when I'm logged in, when I access hidden link, it redirects me to hidden link.

Do you know whats happening?

Jordi

August 30, 2017 at 6:52 am #1353947

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi Jordi,

Please make sure that you have cleared your Cache.

If issue persists please sent me a screenshot of your settings for the Language URL format within the Languages page.

August 30, 2017 at 7:25 am #1353969

Jordi Romeu

I have cleared cache from WPML > Support > Troubleshooting.

But it continues not working.

I attach a screenshot of settings. I have hidden the language french to visitors and activated in my profile to see it.

But it's not working.

I see this message too:

WordPress cannot automatically download translations for the following languages:
French (current locale: fr_FR) - suggested locale(s): fr_BE, fr_FR, fr_CA
Spanish (current locale: es_ES) - suggested locale(s): es_MX, es_AR, es_VE, es_CO, es_GT, es_PE, es_CL, es_ES
To fix, open "Edit Languages" and set the "default locale" values as shown above.

But in "Edit languages" all is ok. Capture attached.

August 30, 2017 at 7:55 am #1353998

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

August 30, 2017 at 9:18 am #1354083

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

I believe you need to clear your browser's cache.

Also try accesing your site from a different browser.

Im able to view the languages as expected when logged in.

Also regarding the warning in the top its related to your default locales, its not an error. Just update your WP to the latest version and let me know if it goes away if not i can just erase it.

August 31, 2017 at 9:04 am #1354961

Jordi Romeu

It was a cache problem. I erased my cache and now is working ok.