This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by ramiI 1 month, 4 weeks ago.

Assigned support staff: Bruno.

Author Posts
August 7, 2019 at 9:13 pm

ramiI

I am hosting a wordpress website on godaddy,
I am receiving the below message and when trying to translate pages it is just giving me black pages on the new translated ones can you please check this for me, I added a test page in the about-us.

It looks like languages per directories will not function. Details

This can be a result of either:

WordPress is installed in a directory (not root) and you're using default links.
URL rewriting is not enabled in your web server.
The web server cannot write to the .htaccess file
How to fix
When WPML accesses /ar?____icl_validate_directory=1 it gets:
A valid URL was not provided.

The expected value is:
<!--hidden link;

August 7, 2019 at 10:08 pm #4358461

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. This looks like it's some configuration of your host. I fixed your site using these two lines inside the wp-config.php file:

define( 'WP_HOME', '<em><u>hidden link</u></em>' );
define( 'WP_SITEURL', '<em><u>hidden link</u></em>' );

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

August 7, 2019 at 10:18 pm #4358469

ramiI

Thank you Bruno for fixing the ink issues to be more clean,
but why I am still not translating the pages, if you check the about us page in arabic version you will find only a black page and not the same as english language,

hidden link
hidden link

please advise.

August 10, 2019 at 12:08 am #4373269

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

I tried to go back to your site to recheck what could be happening, but it looks like the credentials are incorrect: ERROR: The password you entered for the username ______ is incorrect. Lost your password?

Could you please check? Also, please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

Thank you.

August 10, 2019 at 12:22 am
August 12, 2019 at 7:53 pm #4383501

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. I noticed that the content is not displayed when the "EF3-Framework" plugin is enabled. This seems to be a compatibility issue with your theme.

To ensure that this theme/plugin is made compatible with WPML we need to contact the theme/plugin author and work with him on resolving the issue.

I have forwarded the details to our Themes & Plugins Compatibility Team and they will contact the author. Our Compatibility Team will work with the author of the plugin for this to work properly.

Please note that this process may take a while as it depends on how soon the author will reply to our efforts to contact him.

Thank you.

August 12, 2019 at 8:01 pm #4383515

ramiI

Thank you so much, please work on it and I will contact from my side with the author since he told me before purchasing the theme it is 100% compatible only with WPML plugin,

Regards,

Rami

August 12, 2019 at 9:10 pm #4383705

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. As soon as I have an answer I will keep you updated.

Thank you.

August 16, 2019 at 1:04 pm #4406483

ramiI

My issue is resolved now. Thank you!