This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 4 replies, has 2 voices.

Last updated by Bigul 3 weeks, 6 days ago.

Assigned support staff: Bigul.

Author Posts
September 16, 2019 at 7:11 pm #4583597

clarissaK

any Url Format for other languages not working in the website

hidden link

September 17, 2019 at 9:21 am #4586977

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Most of the case it will be a false alarm. So please try the following steps and check the issue is existing or not.

1) Visit Settings>>Permalinks
2) Choose *Post name* option and save the settings
3) Visit WPML>>Languages>>Language URL format
4) Choose *Different languages in directories* and update settings
5) Visit Settings>>Permalinks and resave the settings

If the issue exists, please visit the following documentation and make sure you have the correct settings.

https://wpml.org/faq/server-setting-for-languages-in-directories/

https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/

--
Thanks!

Bigul

September 17, 2019 at 10:41 am #4587759

clarissaK

Hello..
Can you please check it?

when I switch in the language , I found error 404

clarissaimmigration.com

September 17, 2019 at 10:49 am #4587777

clarissaK

Actually I am not sure that, is this conversion showing publicly ?

Hello..
Can you please check it?

when I switch in the language , I found error 404

clarissaimmigration.com

Let me know if you need wp-admin access ? I will give you update

September 17, 2019 at 5:55 pm #4590587

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please share with me the WordPress debug.log (not WPML debug information) for tracking the issue.

Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug(when I switch in the language, I found error 404*) and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

The topic ‘[Closed] It looks like languages per directories will not function’ is closed to new replies.