This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.22 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by ariadnaM-3 2 weeks, 3 days ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
September 26, 2019 at 10:49 am #4645819

ariadnaM-3

I am trying to: configure WPML to use different directories for the different languages of my website.

Link to a page where the issue can be seen:

I expected to see: When WPML accesses hidden link it gets:
HTTP code: 502 (Bad Gateway)

The expected value is:
<!--hidden link;

Instead, I got: a blank page

September 26, 2019 at 3:11 pm #4648255

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Before a more detailed look, please, make sure the following:

0 - Make sure you reviewed the instructions at: https://wpml.org/faq/server-setting-for-languages-in-directories/

1 - Your server supports mod_rewrite and you are able to use any other pretty permalinks other than the default one from your WordPress Dashboard > Settings > Permalinks settings.

See: https://wordpress.org/support/article/using-permalinks/

2 - Your website is not hosted in a subfolder inside your host public directory.

3 - Your .htaccess has the proper permissions so WPML can writing new rule for it.

See: https://wordpress.org/support/article/changing-file-permissions/#htaccess-permissions

Please, let me know if it works for you, have a nice day.

September 29, 2019 at 10:59 am #4660423

ariadnaM-3

Hello, thanks for your assistance, I've reviewed the three points and I think that I have them all good, but the problem still persists

September 30, 2019 at 5:21 pm #4666833

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

October 1, 2019 at 5:22 pm #4674283

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Unfortunately the proivide details don't seem to be working, for example the wp-admin url of your website shows a '404 not found error' do you use any plugin to rename the WordPress Dashboard login url? Which is the exact url to reach your WordPress Dashboard? Also, the provided FTP details are not working, can you please review and test it? Thank you for your collaboration and patience, have a nice day.

October 2, 2019 at 7:19 pm #4682849

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look in this issue and it seems to be a false positive, for example the call for hidden link is returning <!--hidden link; properly. See: https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/#how-wpml-determines-if-it-can-enable-languages-in-directories. Also I created a test page and add a translation for it, it also works as expected at:

English: hidden link
Spanish: hidden link

In your particular case your host seems to be blocking the fopen calls for the url validation and it seems to be the cause of the false positive warning messages. Please, ask them if fopen calls is enabled on your server or completely ignore the warning messages as we have the confirmation it works from my test page above.

Reference: hidden link

Note: I temporary unchecked the option to hide the spanish language in your WordPress Dashboard > WPML > Languages > Hide languages settings in order to confirm the languages in directories feature is working properly in your website.

Hope it brings a bit of clarifications for your questions, have a nice day.

October 2, 2019 at 7:46 pm #4682989

ariadnaM-3

My issue is resolved now. Thank you!