Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Italian home page leads to a portfolio items


This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by geoclimaS 2 years ago.

Assigned support staff: Mihai Apetrei.

Author Posts
November 5, 2019 at 10:30 am #4887681


the italian home page (which should be hidden link) is leading to another url (hidden link).

If deactivating all Yoast SEO plugins (both Premium and Multilingual) the issue is fixed.
But I need Yoast SEO.
Waiting for a fix.

November 6, 2019 at 10:59 am #4897401

Mihai Apetrei

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

My guess is that there might be a redirection added into Yoast premium that causes that.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:


- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

November 7, 2019 at 4:34 pm #4908349

Mihai Apetrei

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)


As I suspected, there is a redirect that has been added to Yoast Premium that needs to be removed. You can find it here: hidden link

I am attaching a screenshot below.

Please let me know if that solved the issue.

Kind regards,

Screenshot 2019-11-07 at 18.31.59.png
November 8, 2019 at 8:08 am #4911255


My issue is resolved now. Thank you!