Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Ahmed Ibrahim 6 years, 1 month ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
August 28, 2015 at 3:50 pm #692428

Alfredo

I am trying to: I have problems with the home voice menu of the English translated menu. It redirect to italian site.

URL of (my) website where problem appears: The site is not online, but i can give access by adding some line into hostfiel to point to my server

I expected to see:

Instead, I got:

August 28, 2015 at 3:54 pm #692435

Alfredo

I give some other details.
My site is into two languages.
main (italian) is into sansonestore.com, second (English) into sansonestore.com/en
The problem is with the home voice of english main menu it doesn't point to sansonestore.com/en but
to sansonestore.com/home redirecting me to italian site. I have to give server details to add to hostfile to point to my server and to see the site i'm developing. If needed please ask me as private.
Regards.

August 29, 2015 at 10:33 am #692748

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Thanks for contacting our support forum.

I think that your problem may be similar to this one : https://wpml.org/errata/language-switcher-adds-front-page-slug-to-the-homepage-url/ , but this problem should be resolved at version 3.2.

Could you please test it with the minimal environment, which mean only WPML plugins with one of the default WordPress themes active.

Also please see this to help you translate your menu correctly : https://wpml.org/documentation/getting-started-guide/translating-menus/

I will activate the next reply as private to give me the necessary info to see your site, and please provide me with temporary access (wp-admin and FTP) to your site in order to provide a better help

+ Please make sure that you have a full backup of your website and database. (Please don't ignore this)!

Best Regards.

August 31, 2015 at 7:13 am #693248

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Thanks for your data.

Unfortunately I still can't see your login page, I have added your lines to my hosts file and I have used your provided link to access your wp-admin page but it gives me a 404-error page.

Also I can't see your English version of the site, It redirects me to the root folder page of your server.

I think better to give me snapshot from your site. For this you'll need to temporarily install a plugin called "Duplicator" on your site. This will allow you to create a copy of your site and your content. You can provide me with the snapshot following these directions:
If you already know how Duplicator works ( http://wordpress.org/plugins/duplicator/ ), please skip the following steps and just send me the installer file and the zipped package you downloaded.

:: Duplicator instructions
. From WordPress plugin page, look for "Duplicator" and install it
. Once installed, you get a new main menu "Duplicator"
. Chose "Packages"
. Click on the first button you find in the toolbar on the right ("Create Package")
. Give it a name or leave it as is
. Click on "Create Package Set"
. Wait until the package is ready
. Click on "Installer", then on "Package": the first one is just a php script, the second one is a zip file containing everything you need
. Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big , you can also exclude the images if the file is very big )
IMPORTANT: remember to create or keep an admin account for me before creating the snapshot, or I won't be able to log-in. You may delete the new admin account once the snapshot has been built.

I will set the next reply as a private reply so you will able to provide a link to download the duplicator package.

Thanks and Best Regards

August 31, 2015 at 7:59 am #693289

Alfredo

Sorry. I don't know if you can download files if localhost changes don't work. If you can't, please open a message marked as private and i give u gdrive link.
Thanks

August 31, 2015 at 8:00 am #693290

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Yes please give me the Google Drive links .

Regards.

August 31, 2015 at 1:39 pm #693688

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Thanks for your data.

I think that the problem exists because you menus didn't synchronized correctly, please take a full backup first, an remove any cache plugin and also remove any cached files.

Then go to WPML -> WP Menu Sync -> and click on the "sync" button.

Then go to Appearance -> Menu, and check if the two menus are correctly Synced and visit the "Manage Locations" tab and also check if the two menus have set to the right location, I think this fixed the issue at my local ( see the attached images)

Also I have a strange issue with your site o my local, It always keep redirecting to the English page, and I must stop the page loading to see the page, are you having this issue too ?, Do you have any redirection script?

Please let me know if that helped you
Best Regards.

September 1, 2015 at 7:55 am #694293

Alfredo

Hello.
Thanks for your support.
I'll follow your recommendations step by step and I'll update you if all is right.
About point two I haven't this type of redirect, but I have to check deeply. Thanks for advise me about it.
Regards.

September 1, 2015 at 10:14 am #694497

Alfredo

Hello.
I have followed your indications but not solved. If I click on front end on Italian flag (default language) it redirect me to hidden link giving me a "page not found". The same happens by backend if I click on top left Sansonestore--->Visit Site menu tab.
I have checked all WP settings (general, reading and so on) and Wpml settings and are correct.
Thanks for you help. I'm near the dead line with my customer and this iusse is frustating me by two weeks.

Schermata 2015-09-01 alle 12.12.01.png
September 1, 2015 at 9:44 pm #695157

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, and sorry for the late reply

About the page not found problem when visiting this link hidden link , it is normal because this is the default language and you didn't created a root page, more info here : https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/

And here is my last thought about the home link problem,
- first I restored a new backup from your duplicator package
- Updated your WPML plugins to their latest release ( 3.2.7 has just released)
- go to Appearance -> menu, and noticed an odd thing that when you select the menu location option for one language to be "Enfold Child Main Menu", the other language menu location will be not selected, and this is what makes the home link points to a wrong location :

let's say that this option is selected for the Italian menu the Italian home link will work correctly but the English will not and vise verse.

So we must investigate now why when we select this option for one language, it is unchecked for the other language, see the attached image.

I was trying to reproduce the issue with a clean installation with the your Enfold child theme but every thing worked correctly with the new installation, the menu location option could be selected for the two languages.

I will try more debugging, also I will try to consult one of our compatibility team and will let you know the result

Best Regards

issue with menu location option.png
Location is selected for the italian menu.png
when the location is selected for the english menu.png
root page.png
September 3, 2015 at 8:09 am #696519

Alfredo

Hello. Thanks for your detailed support.
Sorry for late reply but I had rush days.
You have focused the real problem, that it is on enfold child menu position than couldn't select on both languages.
Please let me know if a solution is possibile.
Regards.

September 3, 2015 at 3:12 pm #697048

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi Alfredo,

I have tried some steps which fixed the menu problem at my local copy, Please take a full backup and try it too:

- Delete all your cache plugins and all your cache files, I think you have two plugins ( w3-total-cache, sg-cachepress)
- Update your WPML plugin to it's latest version "3.2.7"
- Deactivate all your plugin except for WPML Multilingual CMS 3.2.7
- Go to Appearance -> menu
- Delete the English menu.
- Go to the Italian menu and make sure that the location is selected correctly.
- Click on the Sync link above the "save menu" button, and complete the Sync process.

After the Sync check the location, should be selected for the two menus, please check your front-end then.

If every thing is working correctly, reactivate your plugins one by one and observe is every thing is correctly configured.

Please let me know if that helps you.
Best Regards.

The topic ‘[Closed] Iusse with translated menu’ is closed to new replies.