Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 3 voices.

Last updated by Andrés 5 years, 11 months ago.

Assigned support staff: Andrés.

Author Posts
August 20, 2015 at 9:02 am #682997

Alfredo

I am trying to: switch by admin panel from Italian to English clicking on menu language switcher on the top bar but it doesn't work after I have updated to last vers WP and WPML plugins.

URL of (my) website where problem appears:

I expected to see:

Instead, I got:

August 20, 2015 at 9:28 am #683025

Alfredo

Hello Sumit. Into my previous post you have admin credentials.
Regards.

August 20, 2015 at 10:17 am #683080

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Alfredo,

This is Andrés from WPML support. As Sumit is not longer available today, I would like to take care of your case unless you prefer to wait and continue with Sumit tomorrow. Either way, following information would help us to understand what is happening in your site.

1. There has been a lot of updates this week, WordPress, WPML and WooCommerce Multilingual. Could you please double check that you are using:
- WordPress 4.3
- WPML 3.2.5 and its add-ons
- WCML 3.6.8

2. It would be good if you can provide me the WordPress debug.log (not WPML debug informations). Please check this page for instructions
https://wpml.org/documentation/support/debugging-wpml/
If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way, because sometimes the logs are long and create a complete mess in discussion).

I'll wait for your information (Or Sumit 🙂 ).
Andrés

August 20, 2015 at 11:12 am #683134

Alfredo

Hello Andrés:)
Thanks for tour attention and time.
All into my WP installation is updated.
Here the link with error.log. There aren't new errors.
http://pastebin.com/s8YqkeVD
If You have to access to my wp admin, I have given details to Sumit in previous post. The site is obscured so you have to set ip to point to the domain into your host file.

August 20, 2015 at 12:17 pm #683202

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Thank you Alfredo.

From your debug information, everything seems to be fine. Could you please perform the following test:

1. Please check if this issue appears when
- All non WPML Plugins are disabled. It will tell us if there is an interaction issue with other plugin.
- Theme is set to a WordPress default like Twenty Fourteen. Its will tell us if there is an interaction issue with your theme.
- If the problem disappears, start activating one at the time to track where the incompatibility is produced.

August 21, 2015 at 8:12 am #683894

Alfredo

Hello Andrés.
I have disabled all no WPML plugin, disabled enfold and turned on Twenty Fourteen.
I have the iusse yet. By back end when I try to switch language the loading is blocked. I have uploaded an image.
Thanks for your help.

Schermata 2015-08-21 alle 10.12.35.png
August 21, 2015 at 9:36 am #683998

Sander

I have the same problem. The string translation module is causing the admin pages to slow down extremely (and sometimes timeout) when you switch to a non-default admin language. If you disable the string translation module the performance is back. Please provide a update of the string translations module asap.

August 21, 2015 at 9:46 am #684004

Alfredo

Thanks very much, Sander.
I have disabled sting plugin and now it works.
I wait for module update.
Regards.

August 21, 2015 at 9:55 am #684014

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Thank you for your comment @sander.

Indeed @alfredo, we are experiencing some performance issues with last String Translation. To confirm this I would like you to do the following:

1. Activate WPML String Translation.
2. Set your admin language in English (If it wasn't, does the problem disappear? ).
3. Go to Users -> Your profile and mark 'Set admin language as editing language', does the problem disappear?

August 21, 2015 at 10:07 am #684026

Alfredo

Hello Andrés.
Yes it solves the problem.
Thank you.
But I think we need some module update.
Regards.

August 21, 2015 at 10:10 am #684030

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

I'm glad it worke,d @alfredo.
Sure, we are working on it, our developers are already aware of it.

August 21, 2015 at 10:20 am #684041

Sander

Hi Andres,

I think that that answer is too easy. Disabling the module is not a temporary solution at all. The WPML functionality doesn't work without it. A lot of other errors occur. There needs to be a solution FAST! There are a couple of other threads where the same issue is discussed. The new update is just not correctly coded.

August 21, 2015 at 10:43 am #684069

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

I completely agree @sander. That's why I asked to reactivate WPML string translation in here:
https://wpml.org/forums/topic/iusses-after-last-wp-and-wpml-plugins-update/#post-684014

@sander, if you are experiencing this issue, could you please open a new thread, this way you'll get the attention you deserve. Our developers are aware of this situation and would provide a fix for this soon.
Thank you.

August 21, 2015 at 10:54 am #684080

Sander

@andres. That solution doesn't work. At least not on my site.

August 21, 2015 at 11:07 am #684090

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

WPML 3.2.6 and WPML ST 2.2.5 has been released. Con you upgrade your WPML package, please?
@alfredo, Can you confirm that this upgrade solve your issue?

@sander, can you please open a new thread?

The topic ‘[Closed] iusses after last WP and Wpml plugins update’ is closed to new replies.