This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 38 replies, has 2 voices.

Last updated by Laura 6 months, 2 weeks ago.

Assigned support staff: Laura.

Author Posts
March 25, 2019 at 10:54 am

cleliaM-2

First time using WPML on my main site hidden link (used it multiple times on my second website). Both are running on X Theme.

So I'm using the editor translator, I bought 150K words and tried to translate an article from English to Italian. Everything seemed to go smooth, I saved the translation and somehow only an english flag is showing on the top bar menu (I thought it was because I didn't translate anything yet) and if I go to the article I have translated (the English original version) there is no way to see that there is also an Italian version of it. I can't see the preview of it because it redirects me on the main page. Not sure what I'm doing wrong in here as on the other website I had other small issues but at least I could immediately see the flags and the translation.

The article I have translated is this one:
hidden link

If I switch to the Italian on the dashboard I can see 2 translated versions? It's pretty confusing. And no matter which one I try to see the preview... they redirect to the main English page.

Can you please help? I'm just starting out with my main website and I've read all the documents possible before contacting you, but I must be doing something wrong or some settings are wrong.

PS, I installed the duplicator plugin to give you the package but I don't know how to create one and I watched their tutorial but given that I already have some mess on my website due to the WPML I'd rather ask if someone can tell me if I'm doing it right before creating one.

Thanks

March 25, 2019 at 12:23 pm
March 25, 2019 at 1:21 pm #3453895

cleliaM-2

Hi After a chat with a customer service representative, she suggested I made a copy of my website (migrate to cloud) and she asked me to update this ticket to tell her when the migration was completed (which is now), please let me know if you need the link or if I can do anything else while you investigate the issue.

Thank you!

March 26, 2019 at 11:20 am #3461859

cleliaM-2

Do you have any update? I'm still stuck waiting for an answer. Thank you.

March 27, 2019 at 2:24 am #3467327

cleliaM-2

Can I have at least a reply to this? Or am I forced to open a new ticket? I'm completely stuck with this issue and a lot more now and this is my full-time job. Not even getting an answer is not acceptable for a paid service.

March 27, 2019 at 9:50 am #3469201

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

please notice I don't work on Tuesdays, that's why I didn't reply until now.

I see you deleted the other post in your site.
I can't replicate the issue: if I translate another post, I only get one post, even if I edit it before publishing it, and it shows it correctly on the front end. Did you try to see if creating another translation created 2 posts or just one? When editing the post, did you use the Advanced Editor or the WordPress one?

About the category, it seems to be the "Destination" category in Russian. I don't know why it's among Italian categories, but since it's the default one, this explains why it gets automatically added to all posts.
I also notice there is a "Destinazioni" category among the German one - it's the default one as well.
I suggest you determine which should be the default category, if "Destination" or "Blog" (since English default category it's blog) then:
- assign any post from that category to Nункт Hазначения
- delete the category
- rename Nункт Hазначения

March 27, 2019 at 11:09 am #3470003

cleliaM-2

Hi Laura, thanks for letting me know that you don't work on Tuesdays at least now I know about the delay.

As for the issues:

1) Yesterday I translated a 10K words article: hidden link and I didn't have the duplicate content BUT the translation, even if it said it was completed, is not showing in the Italian version. The only way to see that I did the job is if I go to the English article, click on edit and I can see the Italian translation with two symbols (not the usual pencil one). So I'm also stuck in there. No idea why it's not working. I'M USING THE ADVANCE EDITOR with automatic translation paying for the service ( I bought the package for 150k words)

2) The categories: I did everything by the book initially, I had already tested the plugin on my other website with no issues. Now I have no idea why the Russian was assigned to the Italian category by default and the german too as you are pointing out.

3) I deleted the Russian and Spanish from my options so I can't even see the categories to remove them, how am I supposed to work on this if I can't see the Russian language anymore? For now, what I did was a temporary solution. I went to the all posts and clicked on "Quick edit" and removed that Russian category from that specific post but that's not ideal being that category there by default.

4) Going back to point n.1... why on earth now I can't even see the second translation I made last night? I can see the "engine" symbol next to the Italian translation (instead of the + for translate the article) when I go to edit the English version. That's' all I can see. If I click on it, it redirects me to the advanced editor with the completed translation. I resubmit the translation as complete and back to square one.

March 27, 2019 at 3:34 pm #3472741

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

1-4) we currently have an issue with advanced editor. It's not fixed yet, but we have a workaround, which is to delete the WPML_TM_ATE_JOBS from the database.
So:
- take a full backup of the site
- open the database
- search for the WPML_TM_ATE_JOBS function
- delete it
- do a small change to the original ITALY ROAD TRIP: Your Italian Itinerary By a Local! post
- reopen the translation and mark it again as complete
now you should see the translation completed.

2-3) You may have deleted the Russian categories, but the Nункт Hазначения category is among the Italian ones, so you can edit it - not delete it, since it's the default one, but you can change its name.

March 27, 2019 at 4:31 pm #3473745

cleliaM-2

1) I have no idea how to do that. If you have an issue with the plugin as you have stated, the least I expect is that since you have the login and FTP access you could do it for me instead of a back and forth of comments. I also specified that I'm not IT savvy when registering which I suppose is to understand how much you can expect the client might be able to deal with IT issues like this one.

2) I already told you in our chat a few times that I tried to change the category name (as I can't delete it) but when I click on "update" it says "the category was not updated" and it reverts back to the Russian for which we have no idea on how it became the main one. I certainly didn't do it.

You have the credentials to enter my website and see for yourself that it doesn't allow me to edit that category.

Thanks for your feedback on the previous two points. I'm still stuck with my website and after checking out 10K words of translation the last thing I want is to try to do something I have no idea how to fix because the plugin itself has an issue at the moment and maybe jeopardize a work that took me 8 hours to complete.

Thank you.

March 27, 2019 at 5:10 pm #3474173

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

we usually do not perform database changes on live sites. If you want me to do it, I can, but please notice that:
1. I can't access your database with credentials and FTP access, I would need to install some plugins, and in some cases hosting blocks them
2. I would never perform such an operation without having a backup, and I can't backup your database

Therefore no, you can't expect I just log in and do that for you because if something goes wrong you would be rightly upset, and we don't want that. If you confirm you have a full backup of your site, I'll try to see if I can access the database with the plugin Ari Adminer and fix the issue.

As for the category, I don't encounter that issue. Maybe it happens because you're trying to rename it with the name of an already existing category. How are you trying to rename it?

March 27, 2019 at 5:36 pm #3474291

cleliaM-2

Hi

I am with Siteground and they do daily backup of the database and files, sometimes when something goes wrong (example when a plugin update messes up my whole website) I revert to the previous version of my website (In this case if I want to keep the translation I did last night, I'll have to wait for 24 hrs to be 100% sure I'll have a backup with the translation included.

For the category, I am simply trying to put the right translation for "Blog" and for both languages (IT and DE) remains as blog. I can't change it to any other name as it would be the wrong translation.

Plus I still don't get why it assigned a Russian name to the Blog category translation and set it as a default, I'm pretty sure I translated it correctly. I'm a bit worried that the general settings are not right but I have the same ones on my other website and never had any issue.

March 28, 2019 at 8:33 am #3478221

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

it's not possible to run Ari Adminer on your site, it's blocked by the firewall, so I can't access the database.

About the categories, I could rename Nункт Hазначения as "blog" without issue on my copy of the site. Probably it's happening for one of those reasons:
1. in the database there still is a "blog" category even if you deleted it
2. a 3rd party plugin is somehow blocking the editing

I think n.2 as more likely as I deactivated everything except WPML on my copy.

As for why this happens, I can't tell. I would need a backup from before the issue happened to make a comparison.

March 28, 2019 at 4:34 pm #3483917
cleliaM-2

1) Is there any other way you can think of to help me with that issue as I have no idea how to do it by myself (deactivate the firewall? any other idea?)

2) If you have a copy, is it possible to double check which plugin might be causing the issue? Can I have access to that copy so I can see it for myself? I'm so stuck that I can't even work on my normal workload and I certainly don't want to remove WPML immediately after I bought it.

Thanks in advance for your help

New threads created by Laura and linked to this one are listed below:

https://wpml.org/forums/topic/impossible-to-edit-default-category/

March 29, 2019 at 10:14 am #3490113

cleliaM-2

Is there any news? I'm still stuck with no answers. Thank you

March 29, 2019 at 4:01 pm #3492839

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

if you want me to access the database you need to ask your hosting to disable the firewall or any other software that is blocking Ari Adminer.

Otherwise, like I explained here: https://wpml.org/forums/topic/ive-translated-an-article-but-i-cant-see-the-flag-switch-and-the-article/#post-3472741
you need to access the database and search for WPML_TM_ATE_JOBS option and delete it.

Usually, all hostings offer software to access databases, the most common is PhpMyAdmin.
If you don't know where it is or how to access it, you need to ask them, because each hosting has its own configuration and control panel.

About the category issue, I split the topic so we'll continue here: https://wpml.org/forums/topic/impossible-to-edit-default-category/