This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Bobby 2 months ago.

Assigned support staff: Bobby.

Author Posts
July 5, 2019 at 2:19 pm #4152107

darvinS

I am using Jetpack load more in my website, it works fine in the primary language hidden link but not in the secondary hidden link.

It does not load any posts.

Can you help me fix this?

July 5, 2019 at 10:58 pm #4154107

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

i was not able to detect any specific error within the console that could be causing this behavior

If possible i would like to take a closer look at the backend to further test this issue

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

July 9, 2019 at 2:08 am #4166599

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details !

i was able to reproduce this behavior on a clean environment and have escalated it to our compatibility team.

once there are news you will be updated here

at the meantime you might be able to use the following :

go to Jetpack->Settings->Writting-> switch to "Load more posts using the default theme behavior"

July 9, 2019 at 10:59 pm #4174727

darvinS

Thanks, I'll try as you said and will wait for your update.

Regards.

August 6, 2019 at 1:22 pm #4347773

darvinS

Hi, any news?

August 6, 2019 at 7:22 pm #4350169

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

we have been testing this issue and have not been able to reproduce it on our side , please review the following 2 different installation as they both works as expected

hidden link

hidden link

August 8, 2019 at 9:28 pm #4366147

darvinS

Can you provide some sample code of one of these installations?

August 9, 2019 at 2:20 pm #4371099

darvinS

And there is something else that I noticed, our problem only occurs when we use multiple domains, in your examples you use different directories, eg.: /en/ /pt/ etc

When we change to use directories it works flawless.

August 9, 2019 at 11:30 pm #4373211

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I have reviewed the ajax call on the secondary domain and i can see that it actually does not get triggered fully and the one time it did the response was not correct and it was empty

to check you can right click the page -> inspect-> network (filter by XHR)

are you currently using a certificate for each domain or a certificate the supports multidomain SSL ?

please verify the above, as you need to have an SSL certificate for each domain

let me know your results please

The topic ‘[Closed] Jetpack load more not working on secondary language’ is closed to new replies.