This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: After translating a job post, the translation returns a 404 error.

Solution: Go to WPML -> Settings and scroll down to the Custom Post Types section, check the box to translate slugs for post type "Job". Then, add the translated slug and then resave permalinks.

Tagged: 

This topic contains 7 replies, has 3 voices.

Last updated by andrev-12 1 year ago.

Assigned support staff: Lauren.

Author Posts
September 28, 2018 at 7:15 am #2772731

andrev-12

Tell us what you are trying to do?
Posted a job ad through plugin WP Job Manager. Translated this posting in EN through WPML. Opening this EN job gives a 404 error.

What is the link to your site?
hidden link

September 28, 2018 at 9:05 pm #2774879

Ricardo Alday

Hi,

Thank you for contacting WPML support.
In your WordPress dashboard go to Settings -> Permalinks and click the "Save changes" button a couple of times.

Let me know if that helps,
Ricardo

October 1, 2018 at 1:33 pm #2778320

andrev-12

I clicked the "Save changes button a couple of times", i didnt result in resolving this issue.
Als after clicking this button a couple of times and posting a new translated job

October 1, 2018 at 6:25 pm #2779181

Ricardo Alday

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.

If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:

hidden link

October 3, 2018 at 2:08 pm #2784773

andrev-12

Before allowing the temporary access, do you have some tips/actions we can perform from our end first?

October 4, 2018 at 1:31 pm #2787679

andrev-12

Hi translated another job ad, after i changed settings to manual in WPML - settings - translate posts en pages. The created permalink for the job ad is hidden link while its shows on the website as hidden link.
Therefore how to make sure the created permalink will be /job/ instead of /vacature/?

October 4, 2018 at 4:18 pm #2788189

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hello, Ricardo is off for today so I am stepping in to help out. I hope that is okay.

If you go to WPML -> Settings and scroll down to the Custom Post Types section, check the box to translate slugs for post type "Job". Then, add the translated slug and then resave permalinks. Does this resolve the issue?

If not, check WPML -> String Translations to see if the Jobs slug is already translated. If you find a translated slug there, try deleting the string, then go back to Settings and resave the slug there.

Please let me know if you need any further assistance and I will be happy to help.

October 11, 2018 at 2:49 pm #2808748

andrev-12

My issue is resolved now. Thank you!