Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: The translated version of my JQuery Slider (original: French, Translated: English and Dutch) are not showing.

Solution: Go to: - WPML → Settings → Post Types Translation and set Slider Posts (karma-slider) to Not translatable; - WPML → Settings → Taxonomies Translation and set Categories (karma-slider-category) to Not translatable.

Once you do this, edit the homepage to make sure that the right category is selected, then go back to WPML → Settings and change the two elements to Translatable - only show translated items.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by Radu 10 months, 2 weeks ago.

Assigned support staff: Radu.

Author Posts
January 15, 2021 at 12:33 am #7848995

Philippe

Hi there! I hope this email find you well.

Since a few weeks, the translated version of my JQuery Slider (original: French, Translated: English and Dutch) are not showing.

I have tried all the tricks found in the WPML forum but nothing helps. I have desactivated all the plugins but the problem remains until I desactivage WPML CMS (and, of course, at this stage, I don't even see the two other languages at all...)

I have also cleared all the caches (website, server, browser, WPML) but no change.

You can see the problem here: hidden link

I can give you the credentials as admin to see what is going on.

Thanks!!

jquery.jpg
January 16, 2021 at 10:28 am #7858387

Laura
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hi,

thanks for contacting us.

Before your ticket is assigned to one of my colleagues, please allow me to walk you through some initial debugging steps. This will help speed up the support process.

As the first thing, I'd ask you to increase the WP Memory Limit. PHP memory limit is fine but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb.

Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.
You can check the current WP Memory Limit value from WPML -> Support in the Info section
More info here:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
https://wpml.org/home/minimum-requirements/

If this doesn't help, I'd ask you to better explain how and where did you create the slider's content so that we can better understand the issue.

January 16, 2021 at 2:28 pm #7859187

Philippe

Hello Laura and thank you for your answer.

About the Max memory limit, it looks like everything is fine and that the 40Mb is just a wrong value. I have contacted Siteground support to make sure. Memory limit on the server is set to 768Mb and in my wpconfig file, it was already set to 512Mb.

Siteground WP technician did an inquiery and didn't find any codes that would force WP to use only 40Mb. So perhaps it's the same situation that the one explained by Bobby here:

https://wpml.org/forums/topic/memory-limit-40m/

About the slider itself, it is part of Karma theme. It as been created and working since 2015.

The slides are created first in French, then duplicated in English and in Dutch.

Same thing for Slides category: hidden link

Then, in the webpage editor, I choose what kind of Slider I want and wich category to display: hidden link

January 16, 2021 at 2:31 pm #7859195

Philippe

Oups!... I have pressed to Submit to fast...

So here's the rest.

I have tried with different Slider types and different Slider Categories. I have also tried to do just English slider (not translated from French), but nothing helped.

Thank you!

January 18, 2021 at 12:24 pm #7868527

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Philippe,

I'm not sure why is this happening all of a sudden, so I need to have a closer look at the settings from your website. Can you give me access to the dashboard area, please? The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

January 19, 2021 at 12:21 pm #7877627

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Philippe,

Thank you for giving me access to the dashboard area. I was able to make the slider work once I temporarily deactivated the caching, then set the slides and categories as not translatable and back to translatable in WPML → Settings area. I'm not sure why this change did the job or how's the slider working (I think it's a part of the theme functionality), but things are looking fine now in all the languages.

Thanks,
Radu

January 19, 2021 at 2:06 pm #7878591

Philippe

Hello Radu,

Thank you so much for your solution!

Just to be sure I am able to fix it by myself if the problem comes again, can you give me a print screen of the fields that you have worked on? Are they those on this printscreen?:

hidden link

Thanks again!

January 19, 2021 at 3:05 pm #7879069

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Philippe,

I'm glad I could help ^_^

The change was pretty simple. Once I deactivated all the modules of the SG Optimizer plugin (in order to make sure that the changes that I make are applied, and I'm not served the cached elements), I just went:
- to WPML → Settings → Post Types Translation and set Slider Posts (karma-slider) to Not translatable;
- to WPML → Settings → Taxonomies Translation and set Categories (karma-slider-category) to Not translatable.

Once I did this, I edited the homepage to make sure that the right category is selected, then went back to WPML → Settings and changed the two elements to Translatable - only show translated items. That's all 🙂

Thanks,
Radu