Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by Lauren 1 month, 4 weeks ago.

Assigned support staff: Lauren.

Author Posts
July 24, 2018 at 1:23 pm #2575063

nielsM-2

The following URL is not loaded with a ?ver=1.2.3 query parameter, making it quite hard to apply good caching techniques:
- hidden link

Please provide a ?ver= parameter when loading this URL.
Thanks!

July 25, 2018 at 6:08 pm #2581279

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

In my test site, I have the version parameter added: hidden link

It could be there is a plugin that is removing it, maybe a minifying or caching plugin? I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyFifteen. With these settings, is the issue resolved?

July 30, 2018 at 8:37 am #2593015

nielsM-2

I tried but the URL is still not versionized. I'm using version 4.0.5 of the plugin.
class-wpml-cookie-scripts.php (the file loading the language-cookie.js file) is including it by:
wp_enqueue_script( 'wpml-cookie', ICL_PLUGIN_URL . 'https://cdn.wpml.org/res/js/cookies/language-cookie.js', array( 'jquery', 'jquery.cookie' ) );
Note that wp_enqueue_script takes an optional version parameter as its 4th parameter (which your file doesn't provide). So it's clearly a problem on your site 🙂

Provide the version information like such:
wp_enqueue_script( 'wpml-cookie', ICL_PLUGIN_URL . 'https://cdn.wpml.org/res/js/cookies/language-cookie.js', array( 'jquery', 'jquery.cookie' ), '4.0.5' );

Thanks!

July 30, 2018 at 3:31 pm #2594831

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for testing that for me. I've escalated this to our 2nd tier support so that they can get this resolved for you. I'll update here as soon as I have more information.

August 8, 2018 at 7:44 am #2623235

nielsM-2

Hi, what's the status on this? Thanks!

August 8, 2018 at 1:28 pm #2624933

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Our developers are currently working on this and as soon as I have more information, I will update here. I appreciate your continued patience.

July 27, 2021 at 5:12 pm #9282021

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Fix was included in WPML update.