Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Philippe 5 years, 5 months ago.

Assigned support staff: Yvette.

Author Posts
June 10, 2016 at 1:40 pm #906471


Hello, with the last updates of WPML, I get the exact same problem than the last time I wrote these requests on this forum:

Karma Media gallery translation don't work with last WPML update, and
Karma JQuery slidder translations don't work with last WPML update

Karma version: 4.8.2
WPML Multilingual CMS 3.4.0
WPML String Translation 2.3.8
WPML Sticky Links 1.3.18
WPML Translation Management 2.2.0
WPML Media 2.1.21

You can see it on the testing version of my website at:
hidden link and
hidden link

Thank you!

June 12, 2016 at 1:32 pm #907973


Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+01:00)


I took some time to track the history of this problem and from what I can see, it is marked as "fixed" in our records.

For this reason, I think we need to open and escalate this problem once again.

Here are some questions that I have for you:

1. Are the workaround(s) that were previously provided still active in your theme files?
2. Has your theme also been updated to the latest release available?
3. If the workaround was removed, does the problem get resolved if you reapply it?

I undrestand that this must be frustrating for you to continuously have the same problem. I will do my best to make sure that this time our internal processes verify with you that the problem is fixed before it is closed on our end.

Thanks for your patience and collaoboration.

June 13, 2016 at 1:26 pm #909356


Hello Yvette,

Thank you for your kind answer.

1- Yes, the work around has been implemented by the Karma theme author (wich is Themeforest) in a recent update of there theme. (see uploaded screenshot).

2- Yes, the theme is up to date with version 4.8.2

3- No, if I remove the workaround, the problem is still there. And if I reapply it, the problem remains.

Thank you for your help.

June 14, 2016 at 12:16 pm #911238


Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+01:00)


Can I have your permission to take a snapshot of your system in order to confirm the situation on my local system. After this step, I can then escalate it back to our compatibility team.

Thanks for your ongoing patience. I have opened the private area for you to provide FTP and wp-admin details.

Kind regards.

June 16, 2016 at 2:16 pm #915718


Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+01:00)


Thanks for your ongoing patience. I was able to install a fresh copy of your theme and recreated the problem even with the previous workarounds applied.

It appears this might be a bug on our end and our developers are now taking a closer look at it.

I will update you with news as soon as I have something to share.

June 16, 2016 at 9:04 pm #916261


Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+01:00)


I have some good news and bad news.

Good news: there is a new fix (very small) that seems to address the issue. I tested the fix and it works on a new installation of the Karma theme for both Gallery and Slider post types.

Bad news.
I cannot seem to get it to work for the Gallery Images in the test system you provided. This may be becuase I inadvertantly changed a multilinguagl configuration option. I am not sure.

I would like to know if you can provide another replica of your current system. Alternatively, you can apply the fix to your live system to see if it addresses your issue.

Here is the steps that need to be applied:


by changing this occurrences of this line from this

'field' => 'id',


'field' => 'term_id',

I wait for your news.

June 17, 2016 at 1:33 pm #917109


I Yvette,

I'm working on that and will be back very soon. Thank you!

June 17, 2016 at 2:05 pm #917175


Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+01:00)

Great! I hope it works for you.

I forgot to mention that the theme has been marked to be re-tested so that this correction will be passed on to the theme author.

June 17, 2016 at 2:13 pm #917183


Hi again,

Yes, I confirm that it works both on my testing and my main website. I wanted to inform the theme author, but if you already did it, that's perfect.

Thank you very much!