This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 23 replies, has 4 voices.

Last updated by blackbookdesign 1 year, 1 month ago.

Assigned support staff: Sumit.

Author Posts
August 5, 2018 at 7:14 am #2613433

jamieH-5

I have translated my site in four languages French, Chinese, Portuguese and Spanish. I want to keep my admin in English but I am not able to figure it out.

English is my default language. And Set admin language as editing language is unchecked.

I have checked so many solutions but none of them is working including renaming languages file in content/languages. Please provide me the working solution.
hidden link

August 6, 2018 at 5:30 am #2614535

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Could you please go to Users->your Profile ->Language and set it to English.

Let me know if this helps.

Thanks

August 6, 2018 at 7:02 am #2614643

jamieH-5

Yes, it is already set to English but still seeing admin translations.

August 6, 2018 at 10:26 am #2615398

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

This seems unusual, to further debug this issue, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues needs some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

August 8, 2018 at 4:37 am #2622733

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

With the login details provided, I can see the whole dashboard in the English language so could you please check the issue once again?

Look forward to your reply.

Thanks

August 8, 2018 at 9:03 am #2623514

jamieH-5

No, it is not. Did you even try changing the admin language?

August 8, 2018 at 12:45 pm #2624647

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Yes, I am able to replicate the issue now, it seems unusual as on my test site this feature is working without any issue, To further debug this issue, could you please provide me a backup of your wp-content (without uploads) as well as database backup so I can replicate your site on my localhost and perform further debugging.

You can zip these files and upload to google drive later to share it with me.

Look forward to your reply.

Thanks

August 9, 2018 at 12:07 pm #2628652

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The database backup file you provided seems to be missing tables, could you please create a new database backup and send it to me.

Further, your site is also not working for me with the following message" This site can’t be reached" could you please check this?

Look forward to your reply.

Thanks

August 9, 2018 at 5:47 pm #2630330

jamieH-5

I have updated the previous private reply. The new database is added please check it.

August 10, 2018 at 3:33 pm #2634492

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I tested this on my localhost and noticed that when deactivating Content Aware Sidebars plugin the issue is not happening, so could you please deactivate the plugin and let me know if this helps?

Look forward to your reply.

Thanks

August 10, 2018 at 7:20 pm #2635259

jamieH-5

Hi,
I disabled that plugin and the issue is still there.

August 13, 2018 at 11:00 am #2639526

jamieH-5

Can you guys give me a solution it's been more than a week?

August 13, 2018 at 11:40 am #2639633

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I replicated your site on my localhost and while using just WPML plugins (as well as when deactivating the plugin I mentioned earlier) the languages are working perfectly for me. It seems like some plugin/themes are also creating conflicts on your site.

So, is it possible for you to create a staging site so I can test this issue there? Could you please disable all non-related WPML plugins, switch to one of default themes, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Look forward to your reply.

Thanks

August 15, 2018 at 5:33 pm #2647308

jamieH-5

hidden link
Username = admin
Pass=jamie1234
Then Use the admin credentials I provided you to access the admin panel.
Please provide me the solution ASAP. It is affecting my sales.

August 16, 2018 at 10:42 am #2649313

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

While trying to debug the issue using deactivate/activate the plugins, currently I am receiving the below errors so could you please check it once?

500 - Internal Server Error
 This is a temporary server error. 
Please try to reload the webpage later. 

Look forward to your reply.

Thanks