This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.46 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: How can I modify original content without changing the translation?

Solution: To edit the translated content (English), click on the pencil icon to edit the translation using the Translation editor. In the editor, I see the original language in Spanish and the translated content in English. If I update the translated content in the editor, the content remains in English on both the translation editor and on the front end of the site.

If you are trying to edit the original content in the translation editor, it is not possible. You need to edit the original content in the page builder.

0% of people find this useful.

This topic contains 8 replies, has 2 voices.

Last updated by sebasO 1 year ago.

Assigned support staff: Lauren.

Author Posts
September 12, 2018 at 5:11 pm #2728389

sebasO

Tell us what you are trying to do?

I started a site writing content in english because I thought that would be original languaje. Then my client told me that original languaje should be spanish, and english should be a translation. Now I want to keet all texts I wrote in english as a translation but whatever I do (duplicating languaje or editing in editor) texts I wrote in english dissapear or they are replaced by spanish texts. I need keep english texts when I copy all fields, otherwise I will do double work 🙁

What is the link to your site?
hidden link

September 14, 2018 at 5:30 pm #2736321

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

If the fields are set to copy, then when you change the original content, it will automatically update in the English translation. I recommend creating the post independently in Spanish, and then try linking the English page to the Spanish page. If you do that, and then view the translation editor, do you see the content in the correct language?

September 17, 2018 at 4:41 pm #2741928

sebasO

Sorry, I don't understand. How do I link them? I don't want to duplicate pages, just translating texts.
How is it possible there's no button or anything that allows to change original content but not translations?
I mena, there is actually a button but it doesn't work either! (please see jpg attached). If this checkbox is marked I can change original content and translation doesn't (which it's cool) but original content dissappear in editor! And if I unmark the checkbox to see these contents in editor, then it happens automatically: original content changes even if I saved and updated page minutes ago.

It's super exasperating and frustrating 🙁

September 17, 2018 at 6:32 pm #2742261

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

September 28, 2018 at 2:24 pm #2774215

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

THanks for sending me access. Perhaps I am not understanding the issue correctly, but everything seems to be working correctly.

To update the default language (Spanish), go to edit the page and edit the content that you have created using the page builder.

To edit the translated content (English), click on the pencil icon to edit the translation using the Translation editor. In the editor, I see the original language in Spanish and the translated content in English. If I update the translated content in the editor, the content remains in English on both the translation editor and on the front end of the site.

If you are trying to edit the original content in the translation editor, it is not possible. You need to edit the original content in the page builder.

Please let me know if you need any further assistance and I will be happy to help.

October 2, 2018 at 11:08 am #2781197

sebasO

Everything seems to work correctly because finnally I wrote everything again. So it's not working correctly but this particular problem is solved (loosing a lot of time)

Thanks.

October 2, 2018 at 2:28 pm #2781868

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Okay, I'm glad you were able to resolve it. Thanks for letting me know.

October 6, 2018 at 4:51 pm #2792962

sebasO

Hi Lauren:
I have two new issues, I'll write about them here instead of opening a new ticket, it it's ok for you.
1. Why texts in my footer widgets are rendered english as original languaje if ALL my site is in spanish as original languaje?
I'm trying to translate texts in footer widgets to catalan and english but when I search strings in strings translator, they appear in english (when they should appear in spanish) please see jpg attached

2. How do I translate this sentence in subfooter? I can't find it in strings translator (please see jpg attached)

I edit: I found how to do it, issues solved

October 6, 2018 at 5:03 pm #2792988

sebasO

My issue is resolved now. Thank you!