This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by ahmedM-19 6 months, 2 weeks ago.

Assigned support staff: Bruno.

Author Posts
February 26, 2019 at 10:46 am #3244235

ahmedM-19

Tell us what you are trying to do? I want to keep all the images as it is without translation

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?

February 26, 2019 at 8:41 pm #3247301

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. If you do not want to sync the images, you can follow the steps below:

- Click on the WPML > Settings > Media Translation
- On the "How to handle media for new content", uncheck the desired options
- Click on the Save button

By following the steps above, the images will no longer be synchronized between languages.

Also, on the WPML > Settings > Post Types Translation, you can select the "Translatable - use translation if available or fallback to default language" option for the "Media" post type.

You can see more details in our documentation: https://wpml.org/documentation/getting-started-guide/media-translation/.

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

February 27, 2019 at 8:25 am #3248841

ahmedM-19

Hi Bruno,

I followed your steps as you can see in the attached screenshot media_translations.png.
Please let me know if that is right or not.

Waiting for your feedback
Thanks

February 27, 2019 at 8:26 am #3248855

ahmedM-19

Sorry to forget the attached screenshot

February 27, 2019 at 2:57 pm #3250946

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Yes. This causes neither the attached images nor the featured images to be duplicated (which duplicates, in fact, are just the database records)

Ideally, you should test to see if your site will work properly as expected. Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

March 1, 2019 at 11:05 am #3259865

ahmedM-19

My issue is resolved now. Thank you!

March 14, 2019 at 8:42 am #3341497

ahmedM-19

hello,

Some of the business logos are shown and some are not.

Please check examples of the logos appeared on hidden link
While here logos don't appear on hidden link

Waiting for your feedback
Thanks