This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.64 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: I have all the pages translated and when I activate the language switcher and choose my language it goes back to the Default rather than staying in the chosen language as soon as the page is switched.

Solution: - Please make sure minimum requirements for WPML meet: https://wpml.org/home/minimum-requirements/

- Please make sure your theme is WPML compatible. Here is our compatible theme list. You can search you theme in this list. https://wpml.org/documentation/theme-compatibility

Also make sure you are using updated Plugins and Theme.

This topic contains 2 replies, has 2 voices.

Last updated by marinerJ 1 year, 4 months ago.

Assigned support staff: Noman.

Author Posts
May 21, 2018 at 11:00 am #2200534

marinerJ

Tell us what you are trying to do?
I have all the pages translated and when i activate the language switcher and choose my language it goes back to the default rather than staying in the chosen language as soon as the page is switched.

Is there any documentation that you are following?
At the moment just using the documentation your company provided and your forums

Is there a similar example that we can see?

What is the link to your site?

May 22, 2018 at 10:43 am #2207231

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello,

Thank you for contacting WPML Support.

- Please make sure minimum requirements for WPML meet:
https://wpml.org/home/minimum-requirements/

- Please make sure your theme is WPML compatible. Here is our compatible theme list. You can search you theme in this list. https://wpml.org/documentation/theme-compatibility

Also make sure you are using updated Plugins and Theme.

- If still issue persists, please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/

Thank you

May 23, 2018 at 9:47 am #2213820

marinerJ

Thank you