This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

_icl_string_pages is causing the site to be slow.

Solution:

1. Go to WPML -> Support -> Troubleshooting (link)

2. Scroll down and press the 'Recreate ST DB cache tables' button.

Take a backup of the DB of your site before this action!

Also for this specific performance issue, the user found that the WP Rocket cache plugin was not configured correctly. After configuring it correctly, the performance issue got solved.

100% of people find this useful.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by Itamar 8 months ago.

Assigned support staff: Itamar.

Author Posts
March 11, 2019 at 6:31 pm #3316007

John T.

My Woocommerce/WPML website is extremely slow these days, so I decided to ask my web host just now to check the server for me. Here's their reply:

------------------------
A higher tier was able to see your table /ksth_icl_string_pages' is marked as crashed, we got that repaired, but the issue is coming down to the amount of rows you have, this table has a million rows, which could keep causing this table to crash. We are seeing after the table was repaired the load has gone down, to further improve we recommend optimization of your database with a developer.
------------------------

And now I need your help.

Without a proper fix, I would have to uninstall WPML for good. My ecommerce site is essentially useless if it's as slow as now... (note: it takes about 2 minutes to update a woocommerce product page.)

March 12, 2019 at 2:54 pm #3323859

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

Does the problem with the _icl_string_pages persist after that your hosting support fixed this table?

If so, then please share with me the access to your site and tell me how I can see performance issue on your site.

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

March 13, 2019 at 9:36 am #3331285

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, John and thanks for the access details and extra information.

I've checked things on your site, and I can see that it takes a lot of time for a product to load on the front-end. But when I tried to update a product on the backend, it seemed that the updating time was normal and didn't take a lot of time.

To check the specific issue that you are mentioning in this ticket (_icl_string_pages has too many rows), I installed the ARI Adminer plugin (https://wordpress.org/plugins/ari-adminer/) to be able to check the DB of your site. Nevertheless, when I try to view the DB of your site with this plugin, I'm blocked by the security plugin that you are using. Please see the attached screenshot. So if you want me to continue to check the DB of your site, please disable this security feature that blocks me from viewing the site. Alternatively, you can share with me the dump of the DB of your site. You can upload it to a service like Google Drive or Dropbox and share the link with me. For this, I'll enable a private message for the next reply.

Other than that and to determine whether the performance issue on your site is coming from WPML, please read our related documentation on how to prevent and debug performance issues.
https://wpml.org/faq/prevent-performance-issues-with-wpml/
https://wpml.org/faq/how-to-debug-performance-problems/
Please let me know if the above documentation helps you identify the problem.

Regards,
Itamar.

March 14, 2019 at 5:52 pm #3347701

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, John and thanks for sending me the DB.

Currently, when I check the ksth_icl_string_pages table it does not contain millions of rows.
Please see the attached screenshot.

I've discussed this issue with our second tier supporter and he suggested the following.

1. Go to WPML -> Support -> Troubleshooting (link)

2. Scroll down and see the 'Recreate ST DB cache tables' button. Please see the attached screenshot.

This should fix the issue of the oversized table.

Please let me know if it working for you.

Regards,
Itamar.

March 15, 2019 at 3:48 am #3350929

John T.

Hi Itamar,

Thank you for the update.

Unfortunately, the frontend of my site is still very slow after recreating ST DB cache table.

Each product page takes about 30 seconds to load.

In contrast, another site of mine which is identical to this one (i.e. same theme, same plugins, same server) but doesn't have WPML installed (i.e. same domain but with .com ending) takes about 6 seconds for a single product page to complete loading.

The .com site has smaller database, of course, but that shouldn't cause this much of a difference, should it?

Please advise.

Best regards,

John

March 15, 2019 at 4:19 am #3351265

John T.

On a side note, I've already followed every tip on this article (https://wpml.org/faq/prevent-performance-issues-with-wpml/).

Other details that might be useful to you are as the following:
- I'm using WP Rocket as my caching plugin
- Nginx has been set up as reverse proxy for my site.
- I've subscribed to Sucuri for CDN (and Firewall) service.

Regards,

March 17, 2019 at 6:51 am #3362791

John T.

Hi,

Just to give you a little update.

I've reviewed and updated my caching plugin settings, and my website speed has significantly improved. So, it's probably my caching misconfiguration (in addition to the broken database table) that was the cause of my website being slow, and I say we can close the ticket for now.

Thank you for your support.

Best regards,

John

March 18, 2019 at 1:52 pm #3369849

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Great, John! I'm glad that you have found the cause of this issue.
Indeed, misconfiguration of cache plugins can cause performance issues.
Thank you for updating us on this matter.

Best Regards,
Itamar.