This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Bigul 2 months, 1 week ago.

Assigned support staff: Bigul.

Author Posts
August 24, 2019 at 10:09 am

Dennis van Essen

I am trying to:
Get English labels of attribute son the product page additional info

Link to a page where the issue can be seen:
hidden link

I expected to see:
The English label names, not the Dutch

Instead, I got:
Dutch label names

August 24, 2019 at 10:13 am
August 25, 2019 at 6:23 pm #4454959

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Recreate ST DB cache tables

--
Thanks!

Bigul

August 26, 2019 at 6:58 am #4456203

Dennis van Essen

Hi Bigul,

I have done as you advised, but no difference, it has not resolved the issue.

August 26, 2019 at 5:46 pm #4460627

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please switch for a moment to Flatsome parent theme after a site backup and check the issue is existing or not.

Also please increase the *MaxInputVars* of PHP settings to *5000* more. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

--
Thanks!

Bigul

August 27, 2019 at 8:17 am #4463599

Dennis van Essen

Hi Bigul,
I have done both, but still no change.
Regards,
Dennis

August 27, 2019 at 6:01 pm #4468893

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Dennis,

Thank you for the updates. It requires further checking. So please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

August 28, 2019 at 5:02 am #4471207

Dennis van Essen

Hi Bigul,

It is okay to make a duplicator copy.

Regards,
Dennis

August 28, 2019 at 6:18 pm #4476321

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Dennis,

Thank you for your permission. I made a Duplicator copy of the site now. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

August 30, 2019 at 2:40 pm #4487763

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Dennis,

Somehow the Duplicator copy is not working on my local and testing servers. The result is similar after a few tries. So I will try it in our external and get back to you soon.

Please check the attached images for more details.

--
Thanks!

Bigul

September 2, 2019 at 5:20 am #4494485

Dennis van Essen

Okay, I await your further news.

September 2, 2019 at 1:03 pm #4497189

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Dennis,

Finally, the site backup is working almost ok in our external server. But it often shows Database connection error.

Sorry, I need a help. Because I am not able to reproduce the issue in our copy or on your site now. Please check the following links and attached image. Therefore please let me know the exact steps to reproduce the issue on your site.

hidden link

hidden link

Sorry for the delay happened because of the weekend.

--
Thanks!

Bigul

September 2, 2019 at 1:36 pm #4497413

Dennis van Essen

Hi Bigul,

The problem is that the labels of the attributes on the English pages are still in Dutch. Thi sis not correct. I have indicated the labels on the attached visual.

September 3, 2019 at 2:39 pm
September 4, 2019 at 12:05 pm #4510715

Dennis van Essen

Dear Bigul,

I can see that in the Sandbox reproduction you created the translation is dealt with correctly. But in my website it does not... how can we resolve it further?

The topic ‘[Closed] Labels of attributes do not show in second language’ is closed to new replies.