This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by catherineD-2 5 months, 3 weeks ago.

Assigned support staff: Bruno.

Author Posts
May 1, 2019 at 2:33 pm #3718575

catherineD-2

Hello,

we just finish to translate our website in spanish, and I activated the spanish language for all visitors on our website (alfadinamica.ch) but in the laguage menu only the italian and french language appears on desktop browser. It works just fine on smartphone thought...

You can access the spanish version form alfadinamica.ch/es but if you go on an other language, you can't go back from the menu...

What can I do to solve this issue?

thanks,
Eric

May 1, 2019 at 7:28 pm #3719531

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you for contacting us. I noticed you are using a cache plugin. Have you tried clearing your site's cache to see if the language selector will be displayed?

If the problem persists, please follow the steps below:

- Click on the WPML > Support > Troubleshooting
- Look for 'Clean up'
- Click on the "Clear the cache in WPML" button
- Clear your site's cache again

By following these steps, please let me know if the language selector is displayed correctly.

Thank you.

May 1, 2019 at 8:49 pm #3719871

catherineD-2

Hello,

it was the cache... I didn't think about it... sorry.

Thank you !
Eric