Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
March 23, 2016 at 6:35 pm #844742


I am trying to: display the correct translation link in the language switcher for product category base depending on the language

URL of (my) website where problem appears: hidden link

I expected to see: the translated link for English translation hidden link (which is the translated version of hidden link )

Instead, I got: The shop url hidden link in the language switcher (located in the top left corner of the site)

When the Woocommerce Multilingual plugin is deactivated, the switcher displays the correct translation link but without the correct product category base slug. For example the category base slug is "products" for English and "produits" for French version. But it only displays "products" for both version when Woocommerce Multilingual is deactivated. However, when Woocommerce Multilingual is activated it displays the shop url instead the proper translated parent product category.

Steps to duplicate the issue: Activating and deactivating the Woocommerce Multilingual plugin will generate the issue.

The site runs on WordPress core version 4.4.2 with Woocommerce V2.5.3, WPML V3.3.6, Woocommerce Multilingual V3.7.10

Any help would be much appreciated.

Thanks !

March 24, 2016 at 10:59 am #845139

Shekhar Bhandari

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for contacting WPML support.

Could you please make sure you have followed the below steps to translate the category slug?

1) Go to WordPress -> Settings -> Permalinks -> Optional section -> Product Category base and enter “product-category’ and save the permalinks. Note: if you see this value appear in grey color it is NOT inputted, and you need to do it manually.

2) Go to WPML->Themes & Plugin Localization -> Select how to translate strings in the theme and plugins -> check the “Translate the theme and plugins using WPML's String Translation” checkbox.

3) Go to WPML -> Translation Management -> Multilingual Content Setup -> Custom posts slug translation options and enable the “Translate custom posts slugs (via WPML String Translation).” checkbox.

4) Go to String Translation -> and search for “product-category” strings.

5) You can find a product-category string where “Domain ⇒ WordPress & Name ⇒ URL product_cat tax slug”

6) Click on the strings and translate it accordingly.

Could you please send me the screenshot of your permalinks page?

I will wait for your feedback


March 24, 2016 at 1:07 pm #845290


The issue was resolved