This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 10 replies, has 2 voices.

Last updated by Yvette 4 months ago.

Assigned support staff: Yvette.

Author Posts
June 4, 2019 at 7:37 pm

nimoB

I am trying to: Ticket to Bruno.
he was dealing with a problem in the webpage 3 days ago.

we have changed Url's to "different languages in directories"
First languge english
secon german.

Everything works, but not the landing page:
URL lustlock.com/de is not accepted.
A redirect in Yoast SEO /de to /de/home does not work.

also Language flag link for german not working in the landing page.

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

June 5, 2019 at 10:08 am #3959239

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

It looks like this URL format will not work (see image).

Please confirm that you have gone through the following steps of this article on how to fix common causes of this :
https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/

The behaviour you describe is most likely due to the fact that the system is not suporting this format on your installation.

June 5, 2019 at 1:31 pm #3960877

nimoB

yes i know, that the landing page does not work in the second language:
but it is supposed that this page should be only in 1 Language (lustlock.com) (english as first language only. In this 1 page, the visitor has information in both languages, and chooses by link to goto the english or german pages, which all work fine in both languages.

So, what i want, that the landing page is solely not translated by WPML and not redirected to /de.
For all other pages, settings are ok.

June 5, 2019 at 2:30 pm #3961505

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Just to clarify - the behaviour you describe is the same as a "Root" page. Can you please read the following and let me know if this is what you are seeking?

https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/#what-is-a-root-page-and-do-i-need-one

June 10, 2019 at 1:24 pm #3987663

nimoB

i can put in WPML language
as root url:
hidden link

but then , switching to second language is not possible anymore.

my problem still exists!

June 10, 2019 at 2:11 pm #3988063

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I´m sorry but I am not clear on the issue.

- When I visit : hidden link (landing/root page) I see two links to your shop.
I am not redirected anywhere
- I select the English link, I am taken here: hidden link
- I select the German link, I am taken here: hidden link

What is not working?
What SHOULD be the expected behaviour?

June 10, 2019 at 3:12 pm #3988439

nimoB

yes, correct what you checked.

But the language link (Flag Sign Engl. or German) in the upper right leads in german to a dead link:
lustlock.com/de

June 10, 2019 at 5:17 pm #3989037

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

GOT IT. Ok - let me look at that now. Thank you for the clarification.

So what page do you expect to show when the switcher goes to yoursite/de?
and where should it go when it goes to yoursite/en?

Is there another language-specific "home page" that you would direct them to and which one is it?

June 10, 2019 at 5:22 pm #3989055

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

So what page do you expect to show when the switcher goes to yoursite/de?
and where should it go when it goes to yoursite/en?

Is there another language-specific "home page" that you would direct them to and which one is it?

June 10, 2019 at 8:15 pm #3990179

nimoB

the landing URL (root) is in default english = correct.
the switch english or german are made by the menu links.

The flag is just a template link and should not lead to lustlock.com/de, which is an "error page".
It should just redirect to lustlock.com/
but this redirect i tried to make, does not work.

Again , what my question is:
Can WPML make an exception and leave the root page only in english, and exclude a translation to /de, but just for this page.

June 11, 2019 at 7:52 am #3992909

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

You asked: "Can WPML make an exception and leave the root page only in english, and exclude a translation to /de, ."

Answer:
Technically, the root page does not "translate" and has no language information in our internal tables. So WPML does not do anything special to translate it and you can therefore also configure it to NOT show a language switcher if you want. (see images)

It sounds like the real issue is in the language switcher on this page.

I´ve just checked your configuration and I can see that you have a lot of warnings on the URL format you are using.

I would suggest, to meet your needs, that you get the URL format to work correctly, and then implement a root page, as in my own example, with the option of not showing a language switcher on the landing page.

I believe this will meet your needs. Do you agree?

If so, please work through the following link to understand why the warnings are appearing in the URL format.
https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/

The topic ‘[Closed] landing page not correctly directing in new URL of second language: /de’ is closed to new replies.