Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 38 replies, has 2 voices.

Last updated by Carlos Rojas 3 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 4, 2019 at 1:05 pm #4143561

Molly Fitzg

I am trying to: Updating post and pages ACF field content in English That should automatically update content in other languages...

Link to a page where the issue can be seen:hidden link

I expected to see: All the ACF block content in the bottom of the page in all languages

Instead, I got: Only few blocks displaying

July 4, 2019 at 3:05 pm #4144753

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes, specially WPML plugins.
- Flush any cache memory that might exists.
- Go to WPML -> Support -> Troubleshooting link -> Apply the steps pointed out in the attached image.

If the issue persists then please visit this link where you will find the steps to follow in order to translate custom fields using WPML: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Kind regards,
Carlos

July 8, 2019 at 6:40 pm #4165079

Molly Fitzg

Thanks for your response Carlos, I have applied your given solution, but looks like it is not working for us... Still custom field content are not translating into other languages... Please check screenshot below... First screenshot is of English and second screenshot is of German... as you can see, German is missing first block...

July 8, 2019 at 8:58 pm #4165791

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for the information provided.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

July 9, 2019 at 12:04 pm #4170429

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

Before we continue I need to ask you to update all outdated plugins and themes. Outdated functionalities can causa conflicts in the code.

Please don't forget to create a full backup of the site before making any change.

Could you tell me if the issue persists after the steps above?

Regards,
Carlos

July 9, 2019 at 3:14 pm #4172371

Molly Fitzg

Hi Carlos,

I have updated WordPress and all plugins; But still issue is there... Could you look now

July 9, 2019 at 8:17 pm #4174219

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

Each Advance Custom Field has two fields to set up, one regular custom field and one system field. I can see that the system fields hasn't been set to 'Translate' or 'Copy' -depending on the case-.

To set all the systems fields in the right configuration I would like to ask you to follow this steps:
- Edit the page "What is Wellmune?" in English -> Scroll down to the 'Multilingual Content Setup' section -> Click on the 'Show system fields' link -> Set each system field (the ones with the underscore as a prefix) as their correspondent regular custom field -> Save the changes.
- Make a small change in the content of the page -> Save the changes -> Update the translations.

Could you tell me the result of the steps above?

Regards,
Carlos

July 10, 2019 at 12:26 pm #4180207

Molly Fitzg

Hi Carlos,

Thanks for your response, I have already tried this thing before, but I have tried again, and still translation is not going across... Issue remains same... Could you please look into it...

July 11, 2019 at 11:41 am #4189393

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I took another look at the page and I set the fields and system fields to their correspondent status -as described in my previous message-. Please update the translations of the page and let me know if the issue disappeared.

Note: You can always translate the page manually by switching the language in the admin menu (top bar) and then clicking in 'Edit anyways button'. This might be a better way to translate the ACF in this case.

Regards,
Carlos

July 11, 2019 at 12:54 pm #4189893

Molly Fitzg

Hey Carlos,

Thanks for your response... I tried and still it did not translate.... Could you please look into it,

July 11, 2019 at 1:50 pm #4190441

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Please follow this steps:
- Go to hidden link -> "Multilingual Content Setup" section -> Set all fields that start with 'blocks_19' and '_blocks_19' to 'Translate' -> Save the changes.
- Make a small change in the content of the blocks that have the issue -> Save the changes -> Update the translation.

Does the issue disappeared?

Regards,
Carlos

July 11, 2019 at 4:21 pm #4191831

Molly Fitzg

Hey Carlos,

Thanks for your response... They are all already set translated... I updated content but still it is not going across... Pleas find attached screenshot

July 11, 2019 at 8:00 pm #4192983

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I refreshed the German translation and now all the content appears correctly.

Note: I don't speak German so I 'translated' with the same content in English 🙂

Could you confirm that the issue is solved?
Regards,
Carlos

July 12, 2019 at 9:21 am #4197055

Molly Fitzg

Hi Carlos,

I am assuming you had done this manually. As I can see, current translation requires manual interference like admin has to manually update translation from admin?? If this is the work around in this case, Please confirm... Because manual translation was working before too. I was expecting it would do auto translation for the content update??

July 12, 2019 at 1:35 pm #4199355

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

In this case I "translated" the page using the Advance Translation Editor (ATE). You can use the automatic translation options of the ATE to translate the content.

I did this "manual translation" as an example to demonstrate the the issue is solved.

Regards,
Carlos